Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

xine hangs rather that exits

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


stinga at wolf-rock

May 4, 2012, 11:17 AM

Post #1 of 4 (395 views)
Permalink
xine hangs rather that exits

G'day all,

On to my next problem...

When watching an ISO and I want to exit I hit the exit button on my
remote.
The picture freezes and nothing else happens, at this point I need to
killall xine to get some signs of life again.

Hitting Q on the keyboard exits properly.

Getting to the end of the film works properly.
ESC on the keyboard takes me to the start of the film (not sure if that
is correct).

I ran ircat xine while watching something and pressed the Back key, it
spat out 'Quit' but xine hung and I did a killall to get rid of it.
So as far as I can tell everything is correct, just xine/lirc are not
doing what they are supposed to?

Or has something changed?

Any suggestions?

linhes 7.1

mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version : g294968b
MythTV Branch : 0.24-fixes
Network Protocol : 63
Library API : 0.24.20110505-1
QT Version : 4.7.3
Options compiled in:
linux release using_alsa using_oss using_backend using_bindings_perl
using_bindings_python using_crystalhd using_dvb using_firewire
using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv
using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video
using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11
using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw
using_bindings_perl using_bindings_python using_mythtranscode
using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

--
'ooroo

stinga...(:)-)
---------------------------------------------------
Email: stinga [at] wolf-rock o
You need only two tools. o /////
A hammer and duct tape. If it /@ `\ /) ~
doesn't move and it should, > (O) X< ~ Fish!!
use the hammer. If it moves and `\___/' \) ~
shouldn't, use the tape. \\\
---------------------------------------------------
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


raymond at wagnerrp

May 4, 2012, 11:25 AM

Post #2 of 4 (388 views)
Permalink
Re: xine hangs rather that exits [In reply to]

On 5/4/2012 14:17, stinga [at] wolf-rock wrote:
> Any suggestions?

Try using MythTV to play the ISOs.
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


dan.littlejohn at gmail

May 8, 2012, 7:52 AM

Post #3 of 4 (353 views)
Permalink
Re: xine hangs rather that exits [In reply to]

On Fri, May 4, 2012 at 1:25 PM, Raymond Wagner <raymond [at] wagnerrp> wrote:

> On 5/4/2012 14:17, stinga [at] wolf-rock wrote:
>
>> Any suggestions?
>>
>
> Try using MythTV to play the ISOs.
>
> ______________________________**_________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/**listinfo/mythtv-users<http://www.mythtv.org/mailman/listinfo/mythtv-users>
>

I also use myth to play most ISOs, but some won't work right with forced
subtitles so I also use xine. Found this lirc method somewhere to kill
xine. Make sure you have irexec started and added to rc so it starts on
boot.

begin
remote = mce
button = KEY_EXIT
prog = irexec
config = killall -9 xine;
end


digitalaudiorock at gmail

May 8, 2012, 12:17 PM

Post #4 of 4 (352 views)
Permalink
Re: xine hangs rather that exits [In reply to]

On Fri, May 4, 2012 at 2:17 PM, <stinga [at] wolf-rock> wrote:
> G'day all,
>
> On to my next problem...
>
> When watching an ISO and I want to exit I hit the exit button on my remote.
> The picture freezes and nothing else happens, at this point I need to
> killall xine to get some signs of life again.
>> Hitting Q on the keyboard exits properly.

Like others, as of MythTV 0.24 I've switched to using the internal
player rather than xine for DVDs, but in answer to the question:

This is a bug in xine-ui that occurs only when lirc is in use which I
reported. As far as I know It's not been fixed:

https://bugs.xine-project.org/show_bug.cgi?id=362

It does exactly as you describe, and locks up on exit. If you're bold
enough to compile it from source, the patch on that bug does in fact
work.

Tom
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.