Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV)

 

 

First page Previous page 1 2 Next page Last page  View All MythTV users RSS feed   Index | Next | Previous | View Threaded


michael at waremanfamily

Apr 11, 2012, 8:58 AM

Post #1 of 39 (3591 views)
Permalink
0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV)

..then we get dropped back to the main menu.

I'm seeing this since I upgraded last night. Using mythbuntu, HD Homerun
and my frontends are both ION systems (using VDPAU). Is anyone else seeing
this symptom? Where do I go looking?

Michael.


nospam at netrom

Apr 11, 2012, 9:03 AM

Post #2 of 39 (3437 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Wed, Apr 11, 2012 at 11:58 AM, Michael Wareman <michael [at] waremanfamily
> wrote:

> ..then we get dropped back to the main menu.
>
> I'm seeing this since I upgraded last night. Using mythbuntu, HD Homerun
> and my frontends are both ION systems (using VDPAU). Is anyone else seeing
> this symptom? Where do I go looking?
>
> Michael.
> !DSPAM:500,4f85ab85325861522114592!
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>
>
>
Yes, seeing it with my HD Homerun prime as well. Just started today. Can
watch varying amounts of live content and then the video freezes, a tuner
LED on the HD unit is flashing instead of solid and after a bit the above
error message comes up.


michael at waremanfamily

Apr 11, 2012, 9:17 AM

Post #3 of 39 (3438 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

Look like this may still not be resolved?

http://code.mythtv.org/trac/ticket/10490

Should I add to this ticket?

On Wed, Apr 11, 2012 at 11:03 AM, John <nospam [at] netrom> wrote:

> On Wed, Apr 11, 2012 at 11:58 AM, Michael Wareman <
> michael [at] waremanfamily> wrote:
>
>> ..then we get dropped back to the main menu.
>>
>> I'm seeing this since I upgraded last night. Using mythbuntu, HD Homerun
>> and my frontends are both ION systems (using VDPAU). Is anyone else seeing
>> this symptom? Where do I go looking?
>>
>> Michael.
>> !DSPAM:500,4f85ab85325861522114592!
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users [at] mythtv
>> http://www.mythtv.org/mailman/listinfo/mythtv-users
>>
>>
>>
> Yes, seeing it with my HD Homerun prime as well. Just started today. Can
> watch varying amounts of live content and then the video freezes, a tuner
> LED on the HD unit is flashing instead of solid and after a bit the above
> error message comes up.
>
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>
>


josu.lazkano at gmail

Apr 11, 2012, 9:19 AM

Post #4 of 39 (3455 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

2012/4/11 Michael Wareman <michael [at] waremanfamily>:
> Look like this may still not be resolved?
>
> http://code.mythtv.org/trac/ticket/10490
>
> Should I add to this ticket?
>
>
> On Wed, Apr 11, 2012 at 11:03 AM, John <nospam [at] netrom> wrote:
>>
>> On Wed, Apr 11, 2012 at 11:58 AM, Michael Wareman
>> <michael [at] waremanfamily> wrote:
>>>
>>> ..then we get dropped back to the main menu.
>>>
>>> I'm seeing this since I upgraded last night. Using mythbuntu, HD Homerun
>>> and my frontends are both ION systems (using VDPAU). Is anyone else seeing
>>> this symptom? Where do I go looking?
>>>
>>> Michael.
>>> !DSPAM:500,4f85ab85325861522114592!
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users [at] mythtv
>>> http://www.mythtv.org/mailman/listinfo/mythtv-users
>>>
>>>
>>
>> Yes, seeing it with my HD Homerun prime as well. Just started today. Can
>> watch varying amounts of live content and then the video freezes, a tuner
>> LED on the HD unit is flashing instead of solid and after a bit the above
>> error message comes up.
>>
>>
>>
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users [at] mythtv
>> http://www.mythtv.org/mailman/listinfo/mythtv-users
>>
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>

Is this happens on program guide change?

Regards.

--
Josu Lazkano
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


stichnot at gmail

Apr 11, 2012, 9:21 AM

Post #5 of 39 (3425 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Wed, Apr 11, 2012 at 9:17 AM, Michael Wareman
<michael [at] waremanfamily> wrote:
> Look like this may still not be resolved?
>
> http://code.mythtv.org/trac/ticket/10490
>
> Should I add to this ticket?

No need, we're aware of the issue and working to solve it.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


michael at waremanfamily

Apr 11, 2012, 9:34 AM

Post #6 of 39 (3398 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

OK - Thanks Jim!

On Wed, Apr 11, 2012 at 11:21 AM, Jim Stichnoth <stichnot [at] gmail> wrote:

> On Wed, Apr 11, 2012 at 9:17 AM, Michael Wareman
> <michael [at] waremanfamily> wrote:
> > Look like this may still not be resolved?
> >
> > http://code.mythtv.org/trac/ticket/10490
> >
> > Should I add to this ticket?
>
> No need, we're aware of the issue and working to solve it.
>
> Jim
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>


snharris99 at live

Apr 13, 2012, 8:07 AM

Post #7 of 39 (3374 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

> > Look like this may still not be resolved?
> >
> > http://code.mythtv.org/trac/ticket/10490
> >
> > Should I add to this ticket?
>
> No need, we're aware of the issue and working to solve it.
>
> Jim
I should report that since 2 updates ago (the update immediately after danielk's "I misread Jim's.." reversion comment in ticket 10490), LiveTV transitions for me have been near flawless. I get a ~1 second audio drop and a nano second video blip (I also posted this in the ticket for feedback). Thanks you guys!


stichnot at gmail

Apr 13, 2012, 9:05 AM

Post #8 of 39 (3367 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 13, 2012 at 8:07 AM, Scott and Nicole Harris
<snharris99 [at] live> wrote:
>
>
>> > Look like this may still not be resolved?
>> >
>> > http://code.mythtv.org/trac/ticket/10490
>> >
>> > Should I add to this ticket?
>>
>> No need, we're aware of the issue and working to solve it.
>>
>> Jim
> I should report that since 2 updates ago (the update immediately after
> danielk's"I misread Jim's.." reversion comment in ticket 10490), LiveTV
> transitions for me have been near flawless. I get a ~1 second audio drop
> and a nano second video blip (I also posted this in the ticket for
> feedback). Thanks you guys!

Are you referring to this commit?

In 2531893d539ceb7158033a5862e9fbd51e01da1d/mythtv:
RingBuffer?: Set the oldfile flag only once per live TV segment.

So far this is only in Master, not 0.25-fixes, because I don't believe
it is addressing the root cause.

I appreciate feedback on these changes, since the problem is affecting
different systems in different ways.

By the way, the slight stuttering at program transitions is
unavoidable for now, according to Daniel K., since there is some DB
stuff going on within the UI thread that won't necessarily complete
within a 60Hz (or whatever) frame interval.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


snharris99 at live

Apr 13, 2012, 10:42 AM

Post #9 of 39 (3359 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

> >> > Look like this may still not be resolved?
> >> >
> >> > http://code.mythtv.org/trac/ticket/10490
> >> >
> >> > Should I add to this ticket?
> >>
> >> No need, we're aware of the issue and working to solve it.
> >>
> >> Jim
> > I should report that since 2 updates ago (the update immediately after
> > danielk's "I misread Jim's.." reversion comment in ticket 10490), LiveTV
> > transitions for me have been near flawless. I get a ~1 second audio drop
> > and a nano second video blip (I also posted this in the ticket for
> > feedback). Thanks you guys!
>
> Are you referring to this commit?
>
> In 2531893d539ceb7158033a5862e9fbd51e01da1d/mythtv:
> RingBuffer?: Set the oldfile flag only once per live TV segment.
>
> So far this is only in Master, not 0.25-fixes, because I don't believe
> it is addressing the root cause.
>
> I appreciate feedback on these changes, since the problem is affecting
> different systems in different ways.
>
> By the way, the slight stuttering at program transitions is
> unavoidable for now, according to Daniel K., since there is some DB
> stuff going on within the UI thread that won't necessarily complete
> within a 60Hz (or whatever) frame interval.
>
> Jim
I don't know what to tell you, my frontend failed to the main menu at LiveTV transitions 100% (literally) of the time from the time I upgraded to 0.25 a few weeks ago. Since the update that coresponded to that comment in 10490, I have not had one single failure. As far as the ~1 stutter, I wasn't complaining, I was rejoicing :).


jaglover at gmail

Apr 13, 2012, 10:46 AM

Post #10 of 39 (3365 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, 13 Apr 2012 09:05:43 -0700
Jim Stichnoth <stichnot [at] gmail> wrote:

> On Fri, Apr 13, 2012 at 8:07 AM, Scott and Nicole Harris
> <snharris99 [at] live> wrote:
> >
> >
> >> > Look like this may still not be resolved?
> >> >
> >> > http://code.mythtv.org/trac/ticket/10490
> >> >
> >> > Should I add to this ticket?
> >>
> >> No need, we're aware of the issue and working to solve it.


> I appreciate feedback on these changes, since the problem is affecting
> different systems in different ways.

Currently the only way for me to change live TV analog channel is to
switch to digital and then back to desired analog channel. (I have set
up 2250 as dual analog and pcHDTV-5500 as digital).

--
Cheers, Saul
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


stichnot at gmail

Apr 13, 2012, 11:10 AM

Post #11 of 39 (3358 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 13, 2012 at 10:46 AM, Saul A. Peebsen <jaglover [at] gmail> wrote:
> Currently the only way for me to change live TV analog channel is to
> switch to digital and then back to desired analog channel. (I have set
> up 2250 as dual analog and pcHDTV-5500 as digital).

This sounds like http://code.mythtv.org/trac/ticket/10566 , which has
been fixed in Master and 0.25-fixes. If you still see problems with
channel changing, we'll get them fixed.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


stichnot at gmail

Apr 13, 2012, 11:22 AM

Post #12 of 39 (3373 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 13, 2012 at 10:42 AM, Scott and Nicole Harris
<snharris99 [at] live> wrote:
>> Are you referring to this commit?
>>
>> In 2531893d539ceb7158033a5862e9fbd51e01da1d/mythtv:
>> RingBuffer?: Set the oldfile flag only once per live TV segment.
>>
>> So far this is only in Master, not 0.25-fixes, because I don't believe
>> it is addressing the root cause.
>>
>> I appreciate feedback on these changes, since the problem is affecting
>> different systems in different ways.
>>
>> By the way, the slight stuttering at program transitions is
>> unavoidable for now, according to Daniel K., since there is some DB
>> stuff going on within the UI thread that won't necessarily complete
>> within a 60Hz (or whatever) frame interval.
>>
>> Jim
>
>
> I don't know what to tell you, my frontend failed to the main menu at LiveTV
> transitions100% (literally) of the time from the time I upgraded to 0.25 a
> few weeks ago. Since the update that coresponded to that comment in 10490,
> I have not had one single failure. As far as the ~1 stutter, I wasn't
> complaining, I was rejoicing :).

Since 0.25 has been out less than a week, it sounds like you've been
running Master, meaning you picked up the commit in question and it
helped. That's good to hear.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


snharris99 at live

Apr 13, 2012, 11:41 AM

Post #13 of 39 (3349 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

> >> Are you referring to this commit?
> >>
> >> In 2531893d539ceb7158033a5862e9fbd51e01da1d/mythtv:
> >> RingBuffer?: Set the oldfile flag only once per live TV segment.
> >>
> >> So far this is only in Master, not 0.25-fixes, because I don't believe
> >> it is addressing the root cause.
> >>
> >> I appreciate feedback on these changes, since the problem is affecting
> >> different systems in different ways.
> >>
> >> By the way, the slight stuttering at program transitions is
> >> unavoidable for now, according to Daniel K., since there is some DB
> >> stuff going on within the UI thread that won't necessarily complete
> >> within a 60Hz (or whatever) frame interval.
> >>
> >> Jim
> >
> >
> > I don't know what to tell you, my frontend failed to the main menu at LiveTV
> > transitions 100% (literally) of the time from the time I upgraded to 0.25 a
> > few weeks ago. Since the update that coresponded to that comment in 10490,
> > I have not had one single failure. As far as the ~1 stutter, I wasn't
> > complaining, I was rejoicing :).
>
> Since 0.25 has been out less than a week, it sounds like you've been
> running Master, meaning you picked up the commit in question and it
> helped. That's good to hear.
>
> Jim
I can' answer that for sure (I don't follow it closely enough). I simply use the Mythbuntu repos, which I *believe* have moved over to 0.25/fixes.... mythbackend --versionMythTV Version : v0.25
MythTV Branch : fixes/0.25
Network Protocol : 72
Library API : 0.25.20120408-1


jaglover at gmail

Apr 13, 2012, 12:22 PM

Post #14 of 39 (3352 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, 13 Apr 2012 11:10:10 -0700
Jim Stichnoth <stichnot [at] gmail> wrote:

> On Fri, Apr 13, 2012 at 10:46 AM, Saul A. Peebsen
> <jaglover [at] gmail> wrote:
> > Currently the only way for me to change live TV analog channel is to
> > switch to digital and then back to desired analog channel. (I have
> > set up 2250 as dual analog and pcHDTV-5500 as digital).
>
> This sounds like http://code.mythtv.org/trac/ticket/10566 , which has
> been fixed in Master and 0.25-fixes. If you still see problems with
> channel changing, we'll get them fixed.

This ticket is about changing channels from guide, I can't change
channels from guide nor by typing the numbers.

BE

2012-04-13 14:17:01.244340 W DevRdB(/dev/video1): Poll took an
unusually long time 2503 ms 2012-04-13 14:17:03.754044 W
DevRdB(/dev/video1): Poll took an unusually long time 2503 ms
2012-04-13 14:17:06.263502 W DevRdB(/dev/video1): Poll took an
unusually long time 2503 ms 2012-04-13 14:17:08.115864 I TVRec(7): HW
Tuner: 7->7 2012-04-13 14:17:08.321125 E MPEGRec(/dev/video1): Device
EOF detected 2012-04-13 14:17:08.333497 I V4LChannel(/dev/video1):
SetInputAndFormat(7, NTSC) (v4l v2) input_switch: 0 mode_switch: 1
2012-04-13 14:17:08.636688 N AutoExpire: CalcParams(): Max required
Free Space: 2.0 GB w/freq: 15 min 2012-04-13 14:17:08.713835 N
AutoExpire: CalcParams(): Max required Free Space: 2.0 GB w/freq: 15
min 2012-04-13 14:17:08.720114 E
RecordingInfo::InsertProgram(ProgramInfo(1063_20120413141708.mpg):
channame(Turner Classic Movies) startts(Fri Apr 13 13:15:00 2012)
endts(Fri Apr 13 15:00:00 2012) recstartts(Fri Apr 13 14:17:08 2012)
recendts(Fri Apr 13 15:00:00 2012) title(Seven Brides for Seven
Brothers)): recording already exists... 2012-04-13 14:17:19.108956 I
TVRec(7): Changing from WatchingLiveTV to None 2012-04-13
14:17:26.109926 I MainServer::ANN Playback

FE

2012-04-13 14:17:01.095217 N Player(0): Waited 7362ms for video
buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.197406 N
Player(0): Waited 7464ms for video buffers
AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.299860 N
Player(0): Waited 7566ms for video buffers
AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.402054 N
Player(0): Waited 7668ms for video buffers
AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.504241 N
Player(0): Waited 7771ms for video buffers
AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.512050 W AFD:
Audio 523 ms behind video but already 220 video frames queued. AV-Sync
might be broken. 2012-04-13 14:17:01.514109 W AFD: Audio 557 ms behind
video but already 220 video frames queued. AV-Sync might be broken.
2012-04-13 14:17:01.516159 W AFD: Audio 542 ms behind video but
already 220 video frames queued. AV-Sync might be broken. 2012-04-13
14:17:01.520097 W AFD: Audio 551 ms behind video but already 220 video
frames queued. AV-Sync might be broken. 2012-04-13 14:17:01.524914 W
AFD: Audio 537 ms behind video but already 220 video frames queued.
AV-Sync might be broken. 2012-04-13 14:17:03.598867 I
RingBuf(/home/mythtv/rec/1025_20120413141653.mpg): Waited 0.2 seconds
for data to become available... 23108 < 32768 2012-04-13
14:17:03.654220 I RingBuf(/home/mythtv/rec/1025_20120413141653.mpg):
Waited 0.2 seconds for data to become available... 23108 < 32768
2012-04-13 14:17:19.045676 E
FileRingBuf(/home/mythtv/rec/1063_20120413141709.mpg): OpenFile(): File
too small (0B). 2012-04-13 14:17:19.045713 E Player(0):
JumpToProgram's OpenFile failed (card type: MPEG). 2012-04-13
14:17:19.045850 E LiveTVChain has 6 entries DUMMY: 1063 (14:16:42 to
14:16:42) MPEG: 1063 (14:16:43 to 14:16:53) discontinuous DUMMY: 1025
(14:16:52 to 14:16:53) discontinuous MPEG: 1025 (14:16:53 to 14:17:08)
discontinuous DUMMY: 1063 (14:17:08 to 14:17:08) discontinuous
* MPEG: 1063 (14:17:09 to 15:00:00) discontinuous

2012-04-13 14:17:19.045876 E Player(0): Unknown recorder error,
exiting decoder 2012-04-13 14:17:19.089768 I TV: Attempting to change
from WatchingLiveTV to None 2012-04-13 14:17:26.109265 E
MythSocket(7f67b880cb60:48): readStringList: Error, timed out after
7000 ms. 2012-04-13 14:17:26.109330 E
RemoteEncoder::SendReceiveStringList(): No response. 2012-04-13
14:17:26.109368 I TV: Changing from WatchingLiveTV to None

--
Cheers, Saul
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


michael at waremanfamily

Apr 13, 2012, 12:28 PM

Post #15 of 39 (3378 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

..but this thread is about 'Video Frame Buffering Failed Too Many Times'
whenever a new program starts (Live TV) - without changing channel.

In my case - I'm on 0.25-fixes (v0.25-5-g5c87d03) for sure. I have no
issues with changing channels - but live program transitions are still
failing and on a regular basis - simply leaving LiveTV on thru program
transitions often causes the buffer issue and a drop back to the main menu.

Per Jim's comment above though - I'm not expecting that to be fixed in
-fixes yet. I'm waiting for the root cause to be identified - and my Wife
is simply using a cable box for LiveTV in the meantime. Inconvenient, yes -
but tolerable.

Jim, if there is anything from my system or logs that would help pin it
down - I would be happy to help out. If I may namedrop a little - I work a
few cubes over from the author of this page http://www.mythtv.org/docs/ at
the same company - I'm sure he will provide a suitable reference to my
troubleshooting prowess if you ask him. :P

Michael.

On Fri, Apr 13, 2012 at 2:22 PM, Saul A. Peebsen <jaglover [at] gmail> wrote:

> On Fri, 13 Apr 2012 11:10:10 -0700
> Jim Stichnoth <stichnot [at] gmail> wrote:
>
> > On Fri, Apr 13, 2012 at 10:46 AM, Saul A. Peebsen
> > <jaglover [at] gmail> wrote:
> > > Currently the only way for me to change live TV analog channel is to
> > > switch to digital and then back to desired analog channel. (I have
> > > set up 2250 as dual analog and pcHDTV-5500 as digital).
> >
> > This sounds like http://code.mythtv.org/trac/ticket/10566 , which has
> > been fixed in Master and 0.25-fixes. If you still see problems with
> > channel changing, we'll get them fixed.
>
> This ticket is about changing channels from guide, I can't change
> channels from guide nor by typing the numbers.
>
> BE
>
> 2012-04-13 14:17:01.244340 W DevRdB(/dev/video1): Poll took an
> unusually long time 2503 ms 2012-04-13 14:17:03.754044 W
> DevRdB(/dev/video1): Poll took an unusually long time 2503 ms
> 2012-04-13 14:17:06.263502 W DevRdB(/dev/video1): Poll took an
> unusually long time 2503 ms 2012-04-13 14:17:08.115864 I TVRec(7): HW
> Tuner: 7->7 2012-04-13 14:17:08.321125 E MPEGRec(/dev/video1): Device
> EOF detected 2012-04-13 14:17:08.333497 I V4LChannel(/dev/video1):
> SetInputAndFormat(7, NTSC) (v4l v2) input_switch: 0 mode_switch: 1
> 2012-04-13 14:17:08.636688 N AutoExpire: CalcParams(): Max required
> Free Space: 2.0 GB w/freq: 15 min 2012-04-13 14:17:08.713835 N
> AutoExpire: CalcParams(): Max required Free Space: 2.0 GB w/freq: 15
> min 2012-04-13 14:17:08.720114 E
> RecordingInfo::InsertProgram(ProgramInfo(1063_20120413141708.mpg):
> channame(Turner Classic Movies) startts(Fri Apr 13 13:15:00 2012)
> endts(Fri Apr 13 15:00:00 2012) recstartts(Fri Apr 13 14:17:08 2012)
> recendts(Fri Apr 13 15:00:00 2012) title(Seven Brides for Seven
> Brothers)): recording already exists... 2012-04-13 14:17:19.108956 I
> TVRec(7): Changing from WatchingLiveTV to None 2012-04-13
> 14:17:26.109926 I MainServer::ANN Playback
>
> FE
>
> 2012-04-13 14:17:01.095217 N Player(0): Waited 7362ms for video
> buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.197406 N
> Player(0): Waited 7464ms for video buffers
> AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.299860 N
> Player(0): Waited 7566ms for video buffers
> AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.402054 N
> Player(0): Waited 7668ms for video buffers
> AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.504241 N
> Player(0): Waited 7771ms for video buffers
> AAAAAAAAAAAAAAAAAAAAAAAAAAAAUuLP 2012-04-13 14:17:01.512050 W AFD:
> Audio 523 ms behind video but already 220 video frames queued. AV-Sync
> might be broken. 2012-04-13 14:17:01.514109 W AFD: Audio 557 ms behind
> video but already 220 video frames queued. AV-Sync might be broken.
> 2012-04-13 14:17:01.516159 W AFD: Audio 542 ms behind video but
> already 220 video frames queued. AV-Sync might be broken. 2012-04-13
> 14:17:01.520097 W AFD: Audio 551 ms behind video but already 220 video
> frames queued. AV-Sync might be broken. 2012-04-13 14:17:01.524914 W
> AFD: Audio 537 ms behind video but already 220 video frames queued.
> AV-Sync might be broken. 2012-04-13 14:17:03.598867 I
> RingBuf(/home/mythtv/rec/1025_20120413141653.mpg): Waited 0.2 seconds
> for data to become available... 23108 < 32768 2012-04-13
> 14:17:03.654220 I RingBuf(/home/mythtv/rec/1025_20120413141653.mpg):
> Waited 0.2 seconds for data to become available... 23108 < 32768
> 2012-04-13 14:17:19.045676 E
> FileRingBuf(/home/mythtv/rec/1063_20120413141709.mpg): OpenFile(): File
> too small (0B). 2012-04-13 14:17:19.045713 E Player(0):
> JumpToProgram's OpenFile failed (card type: MPEG). 2012-04-13
> 14:17:19.045850 E LiveTVChain has 6 entries DUMMY: 1063 (14:16:42 to
> 14:16:42) MPEG: 1063 (14:16:43 to 14:16:53) discontinuous DUMMY: 1025
> (14:16:52 to 14:16:53) discontinuous MPEG: 1025 (14:16:53 to 14:17:08)
> discontinuous DUMMY: 1063 (14:17:08 to 14:17:08) discontinuous
> * MPEG: 1063 (14:17:09 to 15:00:00) discontinuous
>
> 2012-04-13 14:17:19.045876 E Player(0): Unknown recorder error,
> exiting decoder 2012-04-13 14:17:19.089768 I TV: Attempting to change
> from WatchingLiveTV to None 2012-04-13 14:17:26.109265 E
> MythSocket(7f67b880cb60:48): readStringList: Error, timed out after
> 7000 ms. 2012-04-13 14:17:26.109330 E
> RemoteEncoder::SendReceiveStringList(): No response. 2012-04-13
> 14:17:26.109368 I TV: Changing from WatchingLiveTV to None
>
> --
> Cheers, Saul
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>


stichnot at gmail

Apr 13, 2012, 4:17 PM

Post #16 of 39 (3346 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 13, 2012 at 12:22 PM, Saul A. Peebsen <jaglover [at] gmail> wrote:
> This ticket is about changing channels from guide, I can't change
> channels from guide nor by typing the numbers.
[logs]

This probably deserves a new ticket. If you open one, attach FE and
BE logs with "-v general,playback,channel", and make sure the version
info is clear. Also indicate whether these tuners are part of an
input group you defined. I found some suspicious code in the frontend
channel-changing code, particularly with respect to input groups, but
I couldn't actually get anything to fail so I left it alone.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


stichnot at gmail

Apr 13, 2012, 4:26 PM

Post #17 of 39 (3357 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 13, 2012 at 12:28 PM, Michael Wareman
<michael [at] waremanfamily> wrote:
> Jim, if there is anything from my system or logs that would help pin it down
> - I would be happy to help out.

Thanks for the offer. Fortunately (or cursedly, depending on how you
look at it), I can easily reproduce the problem and have gigabytes of
logs to show for it, but I'm new to this part of the code base and the
expert can't reproduce it...

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


michael at waremanfamily

Apr 20, 2012, 4:38 PM

Post #18 of 39 (3199 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

Hi Jim,

I saw your commit towards this (
http://www.gossamer-threads.com/lists/mythtv/commits/514122 ) - but still
having the issue. Just wanted to let you know that (at least for me) your
suspicion about this not being the root cause is a good one.

It's strange - the transition just not (FOX - Simpsons => The Office)
seemed to happen OK - then at 4 mins into The Office the video paused - and
then after a minute or so dropped back to main menu with the dreaded 'Video
frame buffering failed too many times'. I wonder why it took 4 minutes.

Michael.

On Fri, Apr 13, 2012 at 6:26 PM, Jim Stichnoth <stichnot [at] gmail> wrote:

> On Fri, Apr 13, 2012 at 12:28 PM, Michael Wareman
> <michael [at] waremanfamily> wrote:
> > Jim, if there is anything from my system or logs that would help pin it
> down
> > - I would be happy to help out.
>
> Thanks for the offer. Fortunately (or cursedly, depending on how you
> look at it), I can easily reproduce the problem and have gigabytes of
> logs to show for it, but I'm new to this part of the code base and the
> expert can't reproduce it...
>
> Jim
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>


jyavenard at gmail

Apr 20, 2012, 5:03 PM

Post #19 of 39 (3215 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On 21 April 2012 09:38, Michael Wareman <michael [at] waremanfamily> wrote:
> Hi Jim,
>
> I saw your commit towards this (
> http://www.gossamer-threads.com/lists/mythtv/commits/514122) - but still
> having the issue. Just wanted to let you know that (at least for me) your
> suspicion about this not being the root cause is a good one.
>
> It's strange - the transition just not (FOX - Simpsons => The Office) seemed
> to happen OK - then at 4 mins into The Office the video paused - and then
> after a minute or so dropped back to main menu with the dreaded 'Video frame
> buffering failed too many times'. I wonder why it took 4 minutes.

you are running master or fixes/0.25?

and don't top post
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


michael at waremanfamily

Apr 20, 2012, 6:51 PM

Post #20 of 39 (3199 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 20, 2012 at 7:03 PM, Jean-Yves Avenard <jyavenard [at] gmail>wrote:
>
> you are running master or fixes/0.25?
>
> and don't top post


fixes/0.25 from Mythbuntu (currently 0.25.0+fixes.20120420.eb7e73e).

..and sorry 'bout the top-post. Mail client default - I should know better..

Michael.


stichnot at gmail

Apr 20, 2012, 7:21 PM

Post #21 of 39 (3199 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Fri, Apr 20, 2012 at 4:38 PM, Michael Wareman
<michael [at] waremanfamily> wrote:
> Hi Jim,
>
> I saw your commit towards this (
> http://www.gossamer-threads.com/lists/mythtv/commits/514122) - but still
> having the issue. Just wanted to let you know that (at least for me) your
> suspicion about this not being the root cause is a good one.
>
> It's strange - the transition just not (FOX - Simpsons => The Office) seemed
> to happen OK - then at 4 mins into The Office the video paused - and then
> after a minute or so dropped back to main menu with the dreaded 'Video frame
> buffering failed too many times'. I wonder why it took 4 minutes.

That change didn't quite work, though it was a step in the right
direction. A subsequent commit to Master does it right, but I haven't
committed it to 0.25-fixes because I'm now seeing a new premature EOF
problem when the program transition happens.

I can't explain why it would fail midway through a program, but I've
seen that reported elsewhere.

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


jyavenard at gmail

Apr 20, 2012, 9:05 PM

Post #22 of 39 (3185 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Saturday, 21 April 2012, Michael Wareman wrote:

>
>
> fixes/0.25 from Mythbuntu (currently 0.25.0+fixes.20120420.eb7e73e).
>
>
Then the fixes aren't in there yet as the roOt cause hasn't been identified
yet.


>


kenni at kelu

Apr 21, 2012, 4:25 AM

Post #23 of 39 (3190 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

Den 21/04/2012 01.38 skrev "Michael Wareman" <michael [at] waremanfamily>:
>
> Hi Jim,
>
> I saw your commit towards this (
http://www.gossamer-threads.com/lists/mythtv/commits/514122 ) - but still
having the issue. Just wanted to let you know that (at least for me) your
suspicion about this not being the root cause is a good one.
>
> It's strange - the transition just not (FOX - Simpsons => The Office)
seemed to happen OK - then at 4 mins into The Office the video paused - and
then after a minute or so dropped back to main menu with the dreaded 'Video
frame buffering failed too many times'. I wonder why it took 4 minutes.
>

Interesting...I noticed the same pattern the other day. Every time the
error occurred in the middle of a program, it did it at xx:x4 o'clock. Eg.
at 10:04, 10:14, 10:24, etc. And this was on a news-channel with program
transitions every 10 minutes - 10:00, 10:10, 10:20 etc.

I haven't had time to verify this any further, but I'm fairly sure that all
occurrences I've had of buffer errors, which didn't occur at program
transitions, happened at the beginning of a program. It is not unlikely
that this always was 4 minutes into the program.

Best regards
Kenni


snharris99 at live

Apr 21, 2012, 4:51 AM

Post #24 of 39 (3185 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

>On Saturday, 21 April 2012, Michael Wareman wrote:
>fixes/0.25 from Mythbuntu (currently 0.25.0+fixes.20120420.eb7e73e).


>>Then the fixes aren't in there yet as the roOt cause hasn't been identified yet.

I’m so confused, because everyone keeps saying the “fix” hasn’t been ported to 0.25/fixes yet, but my system magically started being near flawless with live TV transitions right at the same time the “fixes” in 10490 were reported. Prior to that, it had a 100% failure rate.

I’m pretty sure I’m also on fixes, not master....

MythTV Version : v0.25-27-ged7c43e
MythTV Branch : fixes/0.25
Network Protocol : 72
Library API : 0.25.20120408-1

Then again, his version “number” includes a date in it and mine doesn’t. His date indicates 4/20 and I haven’t seen a myth update for a couple days now. I’m also using the Mythbuntu repos.


stichnot at gmail

Apr 21, 2012, 6:29 AM

Post #25 of 39 (3185 views)
Permalink
Re: 0.25-fixes 'Video Frame Buffering Failed Too Many Times' whenever a new program starts (Live TV) [In reply to]

On Sat, Apr 21, 2012 at 4:51 AM, Scott & Nicole Harris
<snharris99 [at] live> wrote:
>>>Then the fixes aren't in there yet as the roOt cause hasn't been
>>> identified yet.
>
> Im so confused, because everyone keeps saying the fix hasnt been ported
> to 0.25/fixes yet, but my system magically started being near flawless with
> live TV transitions right at the same time the fixes in 10490 were
> reported. Prior to that, it had a 100% failure rate.

The problem seems to affect different systems in different ways.
You're just one of the lucky ones. :)

Jim
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users

First page Previous page 1 2 Next page Last page  View All MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.