Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

transcode error - status 247

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


pmeisner at yahoo

Jan 22, 2007, 6:40 PM

Post #1 of 5 (3585 views)
Permalink
transcode error - status 247

I tried to transcode several programs but none of them have had the cut points removed ... ( I selected cutpoints using 'edit' - via onscreen menu).

After running transcode the program doesn't seem changed.

I loaded up mythweb to see the job queue and noticed the job had the following information:

Job: Transcode
Status: Errored
Status Time: Sat Jan 20, 1:58PM
Host: localhost.localdomain

Comments:
Transcode failed with status: 247


I looked for status: 247 on the WIKI... no luck

Can anyone give me some help here?

Thanks!




_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


dylan.semler at gmail

Jan 23, 2007, 9:30 AM

Post #2 of 5 (3417 views)
Permalink
Re: transcode error - status 247 [In reply to]

On 1/22/07, Paul Meisner <pmeisner [at] yahoo> wrote:
>
> I tried to transcode several programs but none of them have had the cut
> points removed ... ( I selected cutpoints using 'edit' - via onscreen menu).
>
> After running transcode the program doesn't seem changed.
>
> I loaded up mythweb to see the job queue and noticed the job had the
> following information:
>
> Job: Transcode
> Status: Errored
> Status Time: Sat Jan 20, 1:58PM
> Host: localhost.localdomain
>
> Comments:
> Transcode failed with status: 247
>
>
> I looked for status: 247 on the WIKI... no luck
>
> Can anyone give me some help here?
>

Try another transcode and then check the end of
/var/log/mythtv/mythbackend.log for more details. Post here if necessary

--
Dylan

Type faster. Use Dvorak:
http://dvzine.org


knowledgejunkie at gmail

Jan 23, 2007, 11:26 AM

Post #3 of 5 (3408 views)
Permalink
Re: transcode error - status 247 [In reply to]

On 23/01/07, Paul Meisner <pmeisner [at] yahoo> wrote:
> I tried to transcode several programs but none of them have had the cut points removed ... ( I selected cutpoints using 'edit' - via onscreen menu).
>
> After running transcode the program doesn't seem changed.
>
> I loaded up mythweb to see the job queue and noticed the job had the following information:
>
> Job: Transcode
> Status: Errored
> Status Time: Sat Jan 20, 1:58PM
> Host: localhost.localdomain
>
> Comments:
> Transcode failed with status: 247
>
>
> I looked for status: 247 on the WIKI... no luck

From the source, exit 247 is a GENERIC_EXIT_UNKNOWN_ERROR. Can you run
transcode again with more verbosity to try and pin down the error, or
check the backend log?

Nick
--
MythTV Official wiki:
http://mythtv.org/wiki/
MythTV users list archive:
http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


pmeisner at yahoo

Jan 24, 2007, 8:02 PM

Post #4 of 5 (3410 views)
Permalink
Re: transcode error - status 247 [In reply to]

Ok, I tried it again... Here is the relevant section of the log file from 'mythbackend.log'

----------------------------------------------------
2007-01-24 19:21:22.240 JobQueue: Transcode Starting for Elvis: 4.4 GB (Autodetect)
2007-01-24 19:21:22.245 transcode: Transcode Starting: Elvis: 4.4 GB (Autodetect)
2007-01-24 19:21:22.414 Using runtime prefix = /usr
2007-01-24 19:21:22.442 New DB connection, total: 1
2007-01-24 19:21:22.451 Connected to database 'mythconverg' at host: localhost
2007-01-24 19:21:22.462 Enabled verbose msgs: important
2007-01-24 19:21:22.466 New DB connection, total: 2
2007-01-24 19:21:22.467 Connected to database 'mythconverg' at host: localhost
2007-01-24 19:21:22.471 Transcoding from /video//1034_20070114153000.mpg to /video//1034_20070114153000.mpg.tmp
2007-01-24 19:21:22.499 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2007-01-24 19:21:22.516 Using protocol version 31
2007-01-24 19:21:22.518 MainServer::HandleAnnounce Monitor
2007-01-24 19:21:22.519 adding: localhost.localdomain as a client (events: 0)
2007-01-24 19:21:22.528 MainServer::HandleAnnounce Monitor
2007-01-24 19:21:22.530 adding: localhost.localdomain as a client (events: 1)
[mpeg @ 0x359a30]Parser not found for Codec Id: 94210 !
0: start_time: 0.036 duration: 654.098
1: start_time: 233.434 duration: 654.085
2: start_time: 0.026 duration: 654.074
stream: start_time: 0.289 duration: 9861.034 bitrate=3849 kb/s
2007-01-24 19:21:22.565 AFD: Opened codec 0x89f2f00, id(MPEG2VIDEO) type(Video)
2007-01-24 19:21:22.603 AFD: Opened codec 0x89f3640, id(MP2) type(Audio)
2007-01-24 19:21:23.037 Honoring the cutlist while transcoding
2007-01-24 19:21:23.042 Cutlist : 33924-41517,55039-63338,77281-84259,104447-111848,129045-136158,162881-217845
2007-01-24 19:21:23.043 Original Length: 217845 frames
2007-01-24 19:21:23.044 New Length : 125497 frames
2007-01-24 19:21:23.084 New DB connection, total: 3
2007-01-24 19:21:23.098 Connected to database 'mythconverg' at host: localhost
2007-01-24 19:21:23.118 Unknown video codec:
2007-01-24 19:21:23.120 Transcoding /video//1034_20070114153000.mpg failed
2007-01-24 19:21:23.130 Deleting /video//1034_20070114153000.mpg.tmp
2007-01-24 19:21:23.143 JobQueue: Transcode Errored: Elvis: (Autodetect)
2007-01-24 19:21:23.148 transcode: Transcode Errored: Elvis: (Autodetect)
--------------------------------------

Any ideas?
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


gnome42 at gmail

Jan 25, 2007, 11:51 AM

Post #5 of 5 (3400 views)
Permalink
Re: transcode error - status 247 [In reply to]

> Try another transcode and then check the end of
> /var/log/mythtv/mythbackend.log for more details. Post here if necessary

(Using r12640)

Hi, I am also seeing error 247 for some MPEG2 -> MPEG2 transcodes...

2007-01-25 14:20:38.546 Converting frame #6 from B to I
2007-01-25 14:20:38.569 Converting frame #7 from B to I
2007-01-25 14:20:38.579 Converting frame #8 from P to I
2007-01-25 14:20:45.144 expectedPTS != expectedDTS+ptsIncrement
2007-01-25 14:20:45.193 Transcoding
/myth/mythtv/recordings/2198_20070106020000.mpg failed
2007-01-25 14:20:45.195 Deleting
/myth/mythtv/recordings/2198_20070106020000.mpg.tmp
2007-01-25 14:20:51.583 JobQueue: Transcode Errored: Miami Vice "Cool
Runnin'": Autodetect (exit status 247, job status was "Errored")

Is what I get for that file when running the job via the frontend.

In an effort to collect more debug info I ran the mythtranscode
manually from the cmdline with -v all and it completed successfully! I
captured that log if anyone is interested, but it's big.

This is the command I used:
/usr/bin/mythtranscode -i
/myth/mythtv/recordings/2198_20070106020000.mpg -V 3 -p autodetect -l
-v all > mythtrans_err247_02.out 2>&1

This is the command when run as a job:
/usr/bin/mythtranscode -j 7095 -V 3 -p autodetect -l

This have done this twice now and its completely repeatable. It always
fails when run as a job, but it always succeeds when run manually!?

Any ideas what would cause that?

Also, I noticed that there isn't an --mpeg2 option being used.
Shouldn't there be for MPEG2 -> MPEG2?
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.