Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

G400, Maven, and TVout through the framebuffer chip

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


journey4712 at yahoo

Feb 6, 2003, 11:10 AM

Post #1 of 3 (2096 views)
Permalink
G400, Maven, and TVout through the framebuffer chip

Hello, I have a G400 DH, and i'm trying to run the
frambuffer stuff to make it output to the TV. Output
does work in X, but i would prefer to get it working
through the framebuffer.

Basically my problem has been that output onto the TV
just plain fails. i can do 'matroxset -f /dev/fb1 -m
0' to disconnect it, but matroxset -f /dev/fb0 -m 3'
fails with ioctl failed.

I have been having the wierdest problems, but after
looking through my settings it seems to come down to
the Maven chip wasn't being found. Everything is
compiled into the kernel, I2C, bit-banging, and all
the g400 stuff.
Here is everything from dmesg relating to the g400:

i2c-core.o: i2c core module
i2c-dev.o: i2c /dev entries driver module
i2c-core.o: driver i2c-dev dummy driver registered.
i2c-algo-bit.o: i2c bit algorithm module
i2c-proc.o version 2.6.1 (20010825)
matroxfb: Matrox G400 (AGP) detected
matroxfb: MTRR's turned on
matroxfb: 640x480x8bpp (virtual: 640x26208)
matroxfb: framebuffer at 0xE0000000, mapped to
0xd0812000, size 33554432
Console: switching to colour frame buffer device 80x30
fb0: MATROX VGA frame buffer device
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory:
203M
agpgart: Detected AMD Irongate chipset
agpgart: AGP aperture is 64M @ 0xd8000000
[drm] AGP 0.99 on AMD Irongate @ 0xd8000000 64MB
[drm] Initialized mga 3.0.2 20010321 on minor 0
i2c-dev.o: Registered 'DDC:fb0 #0 on i2c-matroxfb' as
minor 1
i2c-core.o: adapter DDC:fb0 #0 on i2c-matroxfb
registered as adapter 1.
i2c-dev.o: Registered 'DDC:fb0 #1 on i2c-matroxfb' as
minor 2
i2c-core.o: adapter DDC:fb0 #1 on i2c-matroxfb
registered as adapter 2.
i2c-dev.o: Registered 'MAVEN:fb0 on i2c-matroxfb' as
minor 3
i2c-core.o: adapter MAVEN:fb0 on i2c-matroxfb
registered as adapter 3.
i2c-core.o: driver maven registered.
matroxfb_crtc2: secondary head of fb0 was registered
as fb1


I'm wondering if anyone else has had this problem, i
am using kernel 2.4.18-xfs-1.1. Also, does anyone
know which version of the 2.5.x kernels has a
compilable matroxfb? 2.5.59 didn't want to compile,
but i noticed the drivers have changed, although it
seems like it might just be a cleanup. I was hoping
maybee the new code would work though.

Any help would be appreciated, or if anyone needs more
information to try and figure this out.

Erik


__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com


steven.gill at verizon

Feb 6, 2003, 6:21 AM

Post #2 of 3 (1982 views)
Permalink
Re: G400, Maven, and TVout through the framebuffer chip [In reply to]

Erik,

I had an ioctl problem when using -m 3 on my G200 card. I was able to
solve this problem by loading i2c-matroxfb and matroxfb-maven before
loading the mgavideo set of drivers. I suppose since you have a G400
that you may also need to load the matroxfb-crtc2 module also, so I
would do this before the mgavideo drivers too. Let me know how you make
out.

Steve

On Thu, 2003-02-06 at 18:10, Erik Bernhardson wrote:
> Hello, I have a G400 DH, and i'm trying to run the
> frambuffer stuff to make it output to the TV. Output
> does work in X, but i would prefer to get it working
> through the framebuffer.
>
> Basically my problem has been that output onto the TV
> just plain fails. i can do 'matroxset -f /dev/fb1 -m
> 0' to disconnect it, but matroxset -f /dev/fb0 -m 3'
> fails with ioctl failed.
>
> I have been having the wierdest problems, but after
> looking through my settings it seems to come down to
> the Maven chip wasn't being found. Everything is
> compiled into the kernel, I2C, bit-banging, and all
> the g400 stuff.
> Here is everything from dmesg relating to the g400:
>
> i2c-core.o: i2c core module
> i2c-dev.o: i2c /dev entries driver module
> i2c-core.o: driver i2c-dev dummy driver registered.
> i2c-algo-bit.o: i2c bit algorithm module
> i2c-proc.o version 2.6.1 (20010825)
> matroxfb: Matrox G400 (AGP) detected
> matroxfb: MTRR's turned on
> matroxfb: 640x480x8bpp (virtual: 640x26208)
> matroxfb: framebuffer at 0xE0000000, mapped to
> 0xd0812000, size 33554432
> Console: switching to colour frame buffer device 80x30
> fb0: MATROX VGA frame buffer device
> Linux agpgart interface v0.99 (c) Jeff Hartmann
> agpgart: Maximum main memory to use for agp memory:
> 203M
> agpgart: Detected AMD Irongate chipset
> agpgart: AGP aperture is 64M @ 0xd8000000
> [drm] AGP 0.99 on AMD Irongate @ 0xd8000000 64MB
> [drm] Initialized mga 3.0.2 20010321 on minor 0
> i2c-dev.o: Registered 'DDC:fb0 #0 on i2c-matroxfb' as
> minor 1
> i2c-core.o: adapter DDC:fb0 #0 on i2c-matroxfb
> registered as adapter 1.
> i2c-dev.o: Registered 'DDC:fb0 #1 on i2c-matroxfb' as
> minor 2
> i2c-core.o: adapter DDC:fb0 #1 on i2c-matroxfb
> registered as adapter 2.
> i2c-dev.o: Registered 'MAVEN:fb0 on i2c-matroxfb' as
> minor 3
> i2c-core.o: adapter MAVEN:fb0 on i2c-matroxfb
> registered as adapter 3.
> i2c-core.o: driver maven registered.
> matroxfb_crtc2: secondary head of fb0 was registered
> as fb1
>
>
> I'm wondering if anyone else has had this problem, i
> am using kernel 2.4.18-xfs-1.1. Also, does anyone
> know which version of the 2.5.x kernels has a
> compilable matroxfb? 2.5.59 didn't want to compile,
> but i noticed the drivers have changed, although it
> seems like it might just be a cleanup. I was hoping
> maybee the new code would work though.
>
> Any help would be appreciated, or if anyone needs more
> information to try and figure this out.
>
> Erik
>
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] snowman
> http://www.snowman.net/mailman/listinfo/mythtv-users
Attachments: signature.asc (0.18 KB)


bpreston at networkusa

Feb 6, 2003, 11:51 AM

Post #3 of 3 (1984 views)
Permalink
Re: G400, Maven, and TVout through the framebuffer chip [In reply to]

> I have been having the wierdest problems, but after
> looking through my settings it seems to come down to
> the Maven chip wasn't being found. Everything is
> compiled into the kernel, I2C, bit-banging, and all
> the g400 stuff.
> Here is everything from dmesg relating to the g400:

I think you're pretty much there...you just need to load your modules:

modprobe i2c-matroxfb
modprobe matroxfb_maven
modprobe matroxfb_crtc2 (Required for G400, not for the G200)

and then do matroxset commands to duplicate the display to the TV head (at
least that's how I'm using it.)

matroxset -f /dev/fb1 -m 0
matroxset -f /dev/fb0 -m 3
matroxset -f /dev/fb0 -o 1 2

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.