Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

Another yum bites the dust (was: Cannot update ivtv)

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


Axel.Thimm at ATrpms

Jan 23, 2006, 8:21 AM

Post #1 of 5 (2610 views)
Permalink
Another yum bites the dust (was: Cannot update ivtv)

On Fri, Jan 20, 2006 at 12:16:24PM -0500, David R Robison wrote:
> I am trying to update ivtv by
>
> yum install ivtv
>
> I get the following error:
>
> Error: Missing Dependency: /lib/modules/v4l-cx2341x-init-mpeg.bin is
> needed by package ivtv-kmdl-2.6.14-1.1653_FC4
>
> Yet the file is in /lib/modules. What is also interesting is that the
> package being updated is ivtv-kmdl-2.6.14-1.1656_FC4.i589 (updating from
> 1653 to 1656). Any thoughts? Do I first need to uninstall the 1653
> version and then reinstall 1656 version?

This is YAYB (yet another yum bug).

yum install smart smart-gui
smart update
smart upgrade
smart remove yum

(last step is optional ;)

Also simply try

smart --gui

See also

http://bugzilla.atrpms.net/show_bug.cgi?id=710

--
Axel.Thimm at ATrpms.net


chrisribe at gmail

Jan 23, 2006, 6:12 PM

Post #2 of 5 (2523 views)
Permalink
Re: Another yum bites the dust (was: Cannot update ivtv) [In reply to]

Does smart know out of the box to look at your repository? Does it read the
the yum repos file? How does this work?



On 1/23/06, Axel Thimm <Axel.Thimm [at] atrpms> wrote:
>
> On Fri, Jan 20, 2006 at 12:16:24PM -0500, David R Robison wrote:
> > I am trying to update ivtv by
> >
> > yum install ivtv
> >
> > I get the following error:
> >
> > Error: Missing Dependency: /lib/modules/v4l-cx2341x-init-mpeg.bin is
> > needed by package ivtv-kmdl-2.6.14-1.1653_FC4
> >
> > Yet the file is in /lib/modules. What is also interesting is that the
> > package being updated is ivtv-kmdl-2.6.14-1.1656_FC4.i589 (updating from
> > 1653 to 1656). Any thoughts? Do I first need to uninstall the 1653
> > version and then reinstall 1656 version?
>
> This is YAYB (yet another yum bug).
>
> yum install smart smart-gui
> smart update
> smart upgrade
> smart remove yum
>
> (last step is optional ;)
>
> Also simply try
>
> smart --gui
>
> See also
>
> http://bugzilla.atrpms.net/show_bug.cgi?id=710
>
> --
> Axel.Thimm at ATrpms.net
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>
>
>


Axel.Thimm at ATrpms

Jan 23, 2006, 6:16 PM

Post #3 of 5 (2513 views)
Permalink
Re: Another yum bites the dust (was: Cannot update ivtv) [In reply to]

On Mon, Jan 23, 2006 at 09:12:02PM -0500, Chris Ribe wrote:
> Does smart know out of the box to look at your repository? Does it read the
> the yum repos file? How does this work?

smart has its own config files under /etc/smart/channels

If you are using atrpms-package-config or medley-package-config you
are all set to go. If not

yum install atrpms-package-config smart smart-gui

and

smart --gui

to start into using smart. Don't forget that smart, like apt, needs an
"update" before anything else to have it download/refresh the channel
contents. Yum does it upon every invocation.

> On 1/23/06, Axel Thimm <Axel.Thimm [at] atrpms> wrote:
> >
> > On Fri, Jan 20, 2006 at 12:16:24PM -0500, David R Robison wrote:
> > > I am trying to update ivtv by
> > >
> > > yum install ivtv
> > >
> > > I get the following error:
> > >
> > > Error: Missing Dependency: /lib/modules/v4l-cx2341x-init-mpeg.bin is
> > > needed by package ivtv-kmdl-2.6.14-1.1653_FC4
> > >
> > > Yet the file is in /lib/modules. What is also interesting is that the
> > > package being updated is ivtv-kmdl-2.6.14-1.1656_FC4.i589 (updating from
> > > 1653 to 1656). Any thoughts? Do I first need to uninstall the 1653
> > > version and then reinstall 1656 version?
> >
> > This is YAYB (yet another yum bug).
> >
> > yum install smart smart-gui
> > smart update
> > smart upgrade
> > smart remove yum
> >
> > (last step is optional ;)
> >
> > Also simply try
> >
> > smart --gui
> >
> > See also
> >
> > http://bugzilla.atrpms.net/show_bug.cgi?id=710
> >
> >
> >
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users [at] mythtv
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
> >
> >
> >

> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


--
Axel.Thimm at ATrpms.net


fpikus at gmail

Jan 24, 2006, 10:57 PM

Post #4 of 5 (2486 views)
Permalink
Re: Another yum bites the dust (was: Cannot update ivtv) [In reply to]

On 1/23/06, Axel Thimm <Axel.Thimm [at] atrpms> wrote:
>
> On Fri, Jan 20, 2006 at 12:16:24PM -0500, David R Robison wrote:
> > I get the following error:
> >
> > Error: Missing Dependency: /lib/modules/v4l-cx2341x-init-mpeg.bin is
> > needed by package ivtv-kmdl-2.6.14-1.1653_FC4
> >
>
> This is YAYB (yet another yum bug).
>
> yum install smart smart-gui
> smart update
> smart upgrade
>
Also simply try
>
> smart --gui


Smart has a great depsolver, but the gui is rather limited. First of all,
unlike synaptic, it does not show installed versions, so I'm looking at a
list of packages and versions and in an xterm on the side haveto do rpm -q
all the time. Second, unlike synaptic smart gui will list all available
versions of a package, not just the latest one. Sometimes it is useful, but
much more often it just slows things down: I have to read all versions and
see which is the latest, and I can't just select a range of packages from
the gui and click "install" because if there are two versions of the same
package, both will be selected and smart will report an error.

--
> Axel.Thimm at ATrpms.net
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>
>
>


--
Fedor G Pikus (fpikus [at] gmail)
http://www.pikus.net
http://wild-light.com


Axel.Thimm at ATrpms

Jan 25, 2006, 5:26 AM

Post #5 of 5 (2475 views)
Permalink
Re: Another yum bites the dust (was: Cannot update ivtv) [In reply to]

On Tue, Jan 24, 2006 at 10:57:02PM -0800, Fedor Pikus wrote:
> On 1/23/06, Axel Thimm <Axel.Thimm [at] atrpms> wrote:
> >
> > On Fri, Jan 20, 2006 at 12:16:24PM -0500, David R Robison wrote:
> > > I get the following error:
> > >
> > > Error: Missing Dependency: /lib/modules/v4l-cx2341x-init-mpeg.bin is
> > > needed by package ivtv-kmdl-2.6.14-1.1653_FC4
> > >
> >
> > This is YAYB (yet another yum bug).
> >
> > yum install smart smart-gui
> > smart update
> > smart upgrade
> >
> Also simply try
> >
> > smart --gui
>
>
> Smart has a great depsolver, but the gui is rather limited. First of all,
> unlike synaptic, it does not show installed versions, so I'm looking at a
> list of packages and versions and in an xterm on the side haveto do rpm -q
> all the time. Second, unlike synaptic smart gui will list all available
> versions of a package, not just the latest one. Sometimes it is useful, but
> much more often it just slows things down: I have to read all versions and
> see which is the latest, and I can't just select a range of packages from
> the gui and click "install" because if there are two versions of the same
> package, both will be selected and smart will report an error.

I agree. smart's strengths are in its command line interface and shell
mode. I recommend the gui here because users tend to prefer it. For an
"upgrade all" or search function and install the gui is OK, but it
still needs to reach synaptic.

Fedor, would you like to place these remarks in smart's tracker, so
Gustavo and friends have a chance to implement this?

http://tracker.labix.org/ or
http://tracker.labix.org/issue?@template=item&project=smart

Sorry for getting a bit off-topic for a mythtv list.
--
Axel.Thimm at ATrpms.net

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.