Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

DVB-S channel scan problem with 18.1, Astra 19.2, skystar2

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


bobiko at gmail

Sep 17, 2005, 3:46 PM

Post #1 of 9 (2210 views)
Permalink
DVB-S channel scan problem with 18.1, Astra 19.2, skystar2

Hi,

I just installed MythTV on my Gentoo desktop with skystar2 DVB-S card
pointed to Astra 19.2E. The broadcast reception works fine with
mplayer. But I have problems with channel scanning in mythtv. During
the scan the channels and dtv_multiplex tables in mythconverg are
filled, but dvb_channel and dvb_pids are empty. Following error
message is shown on the command line:
QMYSQLResult::data: column 3 out of range

I also tried the SVN snapshot with similar result (here the
dvb_channel and dvb_pids tables are not present at all).
I tried to use the import feature and the channels.conf file prepared
with dvbscan, but it didn't work either - probably because of the
incompatible format.

I have several questions now:
1) Does anybody have mythtv 0.18.1 + DVB-S card (skystar2?) with a
working scan feature?
2) Does anybody know how to import channels.conf into mythtv?
Apparently there are some switches that affect the file format...
3) Could somebody provide me with the current mythconverg database
dump of the Astra 19.2E?
4) Is there any older version of mythtv able to scan channels with the
skystar2 DVB-S card?

Thanks!
Bob
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


jochen.kuehner at gmx

Sep 19, 2005, 12:33 AM

Post #2 of 9 (2164 views)
Permalink
AW: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

Hello, i've 3 skystar cards in my pc and the scan worked, but i don't know
wich version i used because it's 3 or 4 month away.

When you search for the channels, you have to give a starting frequency and
and symbol rate:

Example: ARD 27500 28106, but you have to enter in myth: 27500000 28106000)

The Dvb_channels table is no longer used!! The channels are in the normal
channels table!!!

Any further questions, ask (you can also do in german)


-----Ursprüngliche Nachricht-----
Von: mythtv-users-bounces [at] mythtv
[mailto:mythtv-users-bounces [at] mythtv] Im Auftrag von Bob Honzik
Gesendet: Sonntag, 18. September 2005 00:46
An: mythtv-users [at] mythtv
Betreff: [mythtv-users] DVB-S channel scan problem with 18.1, Astra
19.2,skystar2

Hi,

I just installed MythTV on my Gentoo desktop with skystar2 DVB-S card
pointed to Astra 19.2E. The broadcast reception works fine with
mplayer. But I have problems with channel scanning in mythtv. During
the scan the channels and dtv_multiplex tables in mythconverg are
filled, but dvb_channel and dvb_pids are empty. Following error
message is shown on the command line:
QMYSQLResult::data: column 3 out of range

I also tried the SVN snapshot with similar result (here the
dvb_channel and dvb_pids tables are not present at all).
I tried to use the import feature and the channels.conf file prepared
with dvbscan, but it didn't work either - probably because of the
incompatible format.

I have several questions now:
1) Does anybody have mythtv 0.18.1 + DVB-S card (skystar2?) with a
working scan feature?
2) Does anybody know how to import channels.conf into mythtv?
Apparently there are some switches that affect the file format...
3) Could somebody provide me with the current mythconverg database
dump of the Astra 19.2E?
4) Is there any older version of mythtv able to scan channels with the
skystar2 DVB-S card?

Thanks!
Bob
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


bobiko at gmail

Sep 19, 2005, 3:00 PM

Post #3 of 9 (2157 views)
Permalink
Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

Hi Jochen,

thank you very much for your response.

On 9/19/05, Jochen Kühner <jochen.kuehner [at] gmx> wrote:
> Hello, i've 3 skystar cards in my pc and the scan worked, but i don't know
> wich version i used because it's 3 or 4 month away.
>
> When you search for the channels, you have to give a starting frequency and
> and symbol rate:
>
> Example: ARD 27500 28106, but you have to enter in myth: 27500000 28106000)
>
I know how to start the scan process, but the problem is that it
doesn't work rigt, I guess. Transponders and particular channels are
found, but (probably) not inserted into the database correctly. Here
is an example of my mythconverg data:

channel table:

INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
brightness, colour, hue, tvformat, commfree, visible, outputfilters,
useonairguide, mplexid, serviceid, atscsrcid) VALUES
(1110,'28106',NULL,1,'Das Erste','Das
Erste','none',NULL,'','',0,32768,32768,32768,32768,'Default',0,1,'',1,50,28106,0);
INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
brightness, colour, hue, tvformat, commfree, visible, outputfilters,
useonairguide, mplexid, serviceid, atscsrcid) VALUES
(1111,'28107',NULL,1,'Bayerisches FS','Bayerisches
FS','none',NULL,'','',0,32768,32768,32768,32768,'Default',0,1,'',1,50,28107,0);
INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
brightness, colour, hue, tvformat, commfree, visible, outputfilters,
useonairguide, mplexid, serviceid, atscsrcid) VALUES
(1112,'28108',NULL,1,'hr-fernsehen','hr-fernsehen','none',NULL,'','',0,32768,32768,32768,32768,'Default',0,1,'',1,50,28108,0);
INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
brightness, colour, hue, tvformat, commfree, visible, outputfilters,
useonairguide, mplexid, serviceid, atscsrcid) VALUES
(1113,'28109',NULL,1,'arte','arte','none',NULL,'','',0,32768,32768,32768,32768,'Default',0,1,'',1,50,28109,0);

dtv_multiplex table (this multiplex corresponds to the channels listed above):

INSERT INTO dtv_multiplex (mplexid, sourceid, transportid, networkid,
frequency, inversion, symbolrate, fec, polarity, modulation,
bandwidth, lp_code_rate, transmission_mode, guard_interval, visible,
constellation, hierarchy, hp_code_rate, sistandard, serviceversion,
updatetimestamp) VALUES
(50,1,1101,1,11836500,'a',27500000,'3/4','h','qpsk','a','auto','a','auto',0,'auto','a','auto','dvb',17,20050917221523);

So far it looks OK. But, the dvb_pids table is empty! And this is a
problem, I think.
Could you please send me some sample of your tables? I mean channel,
dtv_multiplex and dvb_pids (and any other relevant table, if there is
any).

> The Dvb_channels table is no longer used!! The channels are in the normal
> channels table!!!

Well, this is a new information to me. It looks like the database
table formats are changing quite often... I found an mythconverg dump
in this mailing list, which used the dvb_channel. I was quite confused
by that.

When I run mythtv, I see only black screen and this on the command line:

bob [at] godzill ~ $ mythtv
2005-09-19 23:51:11.618 New DB connection, total: 1
Total desktop width=1024, height=768, numscreens=1
2005-09-19 23:51:11.632 Using screen 0, 1024x768 at 0,0
2005-09-19 23:51:11.730 Switching to square mode (G.A.N.T.)
2005-09-19 23:51:13.336 New DB connection, total: 2
2005-09-19 23:51:13.429 Connecting to backend server: 127.0.0.1:6543
(try 1 of 5)
2005-09-19 23:51:13.470 Using protocol version 15
2005-09-19 23:51:13.588 Using protocol version 15
2005-09-19 23:51:18.959 taking too long to be allowed to read..
2005-09-19 23:51:23.961 taking too long to be allowed to read..
2005-09-19 23:51:28.962 taking too long to be allowed to read..
2005-09-19 23:51:28.962 Took more than 10 seconds to be allowed to
read, aborting.
Couldn't read file: rbuf://127.0.0.1:6543/tmp//ringbuf1.nuv
2005-09-19 23:51:28.997 Changing from None to WatchingLiveTV
2005-09-19 23:51:28.998 Decoder not alive, and trying to play..
2005-09-19 23:51:29.973 RemoteFile::Read() failed in RingBuffer::safe_read().
2005-09-19 23:51:30.182 RemoteFile::Read() failed in RingBuffer::safe_read().
2005-09-19 23:51:30.391 RemoteFile::Read() failed in RingBuffer::safe_read().
2005-09-19 23:51:30.600 RemoteFile::Read() failed in RingBuffer::safe_read().
2005-09-19 23:51:30.809 RemoteFile::Read() failed in RingBuffer::safe_read().
2005-09-19 23:51:30.834 Changing from None to None
2005-09-19 23:51:31.018 RemoteFile::Read() failed in RingBuffer::safe_read().


Anyway I am glad to hear that the scanning was working with skystar
card (btw. do you have skystar2 or skystar1 cards?). I was afraid that
it is the driver issue (it looks like everybody in the mailing list is
using these PVR-XXX cards...).
I will probably try some older versions of mythtv, maybe the 18.1 and
the SVN snapshot has really broken DVB-S scan functionality.

Thank you.
Bob

>
> Any further questions, ask (you can also do in german)
>
>
> -----Ursprüngliche Nachricht-----
> Von: mythtv-users-bounces [at] mythtv
> [mailto:mythtv-users-bounces [at] mythtv] Im Auftrag von Bob Honzik
> Gesendet: Sonntag, 18. September 2005 00:46
> An: mythtv-users [at] mythtv
> Betreff: [mythtv-users] DVB-S channel scan problem with 18.1, Astra
> 19.2,skystar2
>
> Hi,
>
> I just installed MythTV on my Gentoo desktop with skystar2 DVB-S card
> pointed to Astra 19.2E. The broadcast reception works fine with
> mplayer. But I have problems with channel scanning in mythtv. During
> the scan the channels and dtv_multiplex tables in mythconverg are
> filled, but dvb_channel and dvb_pids are empty. Following error
> message is shown on the command line:
> QMYSQLResult::data: column 3 out of range
>
> I also tried the SVN snapshot with similar result (here the
> dvb_channel and dvb_pids tables are not present at all).
> I tried to use the import feature and the channels.conf file prepared
> with dvbscan, but it didn't work either - probably because of the
> incompatible format.
>
> I have several questions now:
> 1) Does anybody have mythtv 0.18.1 + DVB-S card (skystar2?) with a
> working scan feature?
> 2) Does anybody know how to import channels.conf into mythtv?
> Apparently there are some switches that affect the file format...
> 3) Could somebody provide me with the current mythconverg database
> dump of the Astra 19.2E?
> 4) Is there any older version of mythtv able to scan channels with the
> skystar2 DVB-S card?
>
> Thanks!
> Bob
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


uwe.uwe at gmx

Sep 20, 2005, 5:48 AM

Post #4 of 9 (2158 views)
Permalink
Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

> Anyway I am glad to hear that the scanning was working with skystar
> card (btw. do you have skystar2 or skystar1 cards?). I was afraid that
> it is the driver issue (it looks like everybody in the mailing list is
> using these PVR-XXX cards...).
> I will probably try some older versions of mythtv, maybe the 18.1 and
> the SVN snapshot has really broken DVB-S scan functionality.
>
> Thank you.
> Bob

Bob,

I used .18 and .18.1 along with DVB-S on ASTRA, both did the job.
Technotrend and Skystar cards.

But, when I start mythbackend and mythfrontend on the same system, I
sometimes get the same logentries, and the backend says something like "DVB0
no data from card...". Do you have the same ? Only a reboot fixed the
problem then, restarting myth does not.
Switched to .18, "seems" to be more resistant against this, but perhaps is
not. Do not know.
Some Entries in the mailing list cover the same problem, but no solution.
Not using mythfrontend on the backend machine and no problem anymore.

If you need a db-dump, write an email. I will provide you a complete db of
my production box.

hth,
uwe

--
GMX DSL = Maximale Leistung zum minimalen Preis!
2000 MB nur 2,99, Flatrate ab 4,99 Euro/Monat: http://www.gmx.net/de/go/dsl


bobiko at gmail

Sep 20, 2005, 8:21 AM

Post #5 of 9 (2143 views)
Permalink
Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

Hi Jochen,

On 9/20/05, Jochen Kühner <jochen.kuehner [at] gmx> wrote:
>
> I hope i can help you...
>
> The DVB data in your Tables in correct.
>
> The dvb_pids table is also no longer used!
>
> The pid is in the channel table and it is correct (I have only checked for
> "Das Erste")


Well, I can see the service ID there in the channel table - e.g. 28106 for
Das Erste. But there should also be video, audio and videotext PIDs
somewhere, I think. I wonder where are they, then. Maybe they are negotiated
somehow "on the fly"? Btw. how do you select the desired audio channel on
Arte, if it is sending in German and french?
My dvb_pids table is empty and therefore I assumed THIS is the reason why I
am not able to receive anything. Well, maybe the problem is somewhere
else...

Also the data in the mplex table is correct for "Das erste"
>
> I have 3 skystar 2 cards, one in rev 3 and two in rev 6.
>
> Have you checkt the dvb functionality in an other program like Kaffeine???


Sure. Not in Kaffeine, but I have mplayer installed which shows all FTA
channels without problems, I am using channels.conf file gathered by
dvbscan. So all the drivers are up and running properly.

What kernel are you using?? I use 2.6.11, the skystar module was rewritten
> in 2.6.13 I've heard (don't know exactly, but it has a new name in that
> kernel!)


I am using 2.6.12 but as I said I think this is not the reason.

I think this is not a dvb problem, maybe a rights problem??


Yes, that's the question. I will further investigate it.

Start the
> backend with a higher verbose level....


I will.

Thanks a lot for hints.
Bob


john.pullan at gmail

Sep 20, 2005, 8:30 AM

Post #6 of 9 (2141 views)
Permalink
Re: Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

On 20/09/05, Bob Honzik <bobiko [at] gmail> wrote:
> Hi Jochen,
>
> On 9/20/05, Jochen Kühner <jochen.kuehner [at] gmx> wrote:
> > I hope i can help you...
> >
> > The DVB data in your Tables in correct.
> >
> > The dvb_pids table is also no longer used!
> >
> > The pid is in the channel table and it is correct (I have only checked for
> > "Das Erste")
>
> Well, I can see the service ID there in the channel table - e.g. 28106 for
> Das Erste. But there should also be video, audio and videotext PIDs
> somewhere, I think. I wonder where are they, then. Maybe they are negotiated
> somehow "on the fly"? Btw. how do you select the desired audio channel on
> Arte, if it is sending in German and french?

If you are recording in TS mode then use + and - to change the audio
channel. Also there's some database config you can set which will auto
select the correct stream. (sorry can't remember the setting)

> My dvb_pids table is empty and therefore I assumed THIS is the reason why I
> am not able to receive anything. Well, maybe the problem is somewhere
> else...

Bad assumption, at least if you're running later than 0.16. dvb_pids
is no longer used (along with dvb_channel but that's been pointed out
before).

<snip>

Daft question, but do you have your initial channel to tune to set to
something appropriate e.g 28106 for "Das Erste" ?

Regards.

--
John
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


bobiko at gmail

Sep 20, 2005, 8:41 AM

Post #7 of 9 (2146 views)
Permalink
Re: Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

Hi Uwe,

On 9/20/05, Uwe Schmidt <uwe.uwe [at] gmx> wrote:
>
>
> I used .18 and .18.1 along with DVB-S on ASTRA, both did the job.
> Technotrend and Skystar cards.
>
> But, when I start mythbackend and mythfrontend on the same system, I
> sometimes get the same logentries, and the backend says something like
> "DVB0
> no data from card...". Do you have the same ? Only a reboot fixed the
> problem then, restarting myth does not.


On my system there is a message like

2005-09-19 23:51:28.962 taking too long to be allowed to read..
2005-09-19 23:51:28.962 Took more than 10 seconds to be allowed to
read, aborting.
Couldn't read file: rbuf://127.0.0.1:6543/tmp//ringbuf1.nuv
2005-09-19 23:51:28.997 Changing from None to WatchingLiveTV
2005-09-19 23:51:28.998 Decoder not alive, and trying to play..
2005-09-19 23:51:29.973 RemoteFile::Read() failed in
RingBuffer::safe_read().

but this could probably be a problem with some rights, as Jochen pointed
out. I will try to increase the backend verbosity level.

In your case I would also try to unload the DVB related modules and load
them again with rmmod and modprobe (if they are not compiled in the kernel),
before the reboot. I will see how it will work for me...

If you need a db-dump, write an email. I will provide you a complete db of
> my production box.


Could you please send me your complete mythconverg db dump on my email? I
just want to be sure that my problems are not caused by wrong database data.
Btw., is your dvb_pids table empty as well? The channel table contains only
service IDs. Don't you know where are the video, audio and videotext PIDs
saved? But I will see it from your db dump...

Thank you!
Bob


bobiko at gmail

Sep 20, 2005, 2:05 PM

Post #8 of 9 (2138 views)
Permalink
Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 - SOLVED [In reply to]

Hi John,

On 9/20/05, John Pullan <john.pullan [at] gmail> wrote:

Daft question, but do you have your initial channel to tune to set to
> something appropriate e.g 28106 for "Das Erste" ?


Bingo! This is a goog question! Stupid me...
Actualy I tried to set the initial channel before, but the mythbackend was
running, i.e. the new value was not set/applied after this "change" (and I
didn't notice it). Now I did it again - stopped the mythbackend, changed the
initial channel, started mythbackend, started mythfrontend - and it works!
Finally I will sleep well tonight :o)

Now I can see that it is not so difficult to set the whole system, but there
is a lot of confusing things like empty unused tables (dvb_channel,
dvb_pids), useless debug messages (DVB#0 ERROR - No PIDS set, please correct
your channel setup.) etc., which misguided me to the wrong way. But on the
other hand, it's for free :)

Thanks everybody helping me in this thread!!!
Cheers
Bob


jochen.kuehner at gmx

Sep 21, 2005, 1:17 AM

Post #9 of 9 (2111 views)
Permalink
AW: Re: DVB-S channel scan problem with 18.1, Astra 19.2, skystar2 [In reply to]

I have this problem too sometimes, but then also tuning with other programs
(like kaffeine works not!!)

-----Ursprüngliche Nachricht-----
Von: mythtv-users-bounces [at] mythtv
[mailto:mythtv-users-bounces [at] mythtv] Im Auftrag von Uwe Schmidt
Gesendet: Dienstag, 20. September 2005 14:49
An: mythtv-users [at] mythtv
Betreff: [mythtv-users] Re: DVB-S channel scan problem with 18.1, Astra
19.2, skystar2


> Anyway I am glad to hear that the scanning was working with skystar
> card (btw. do you have skystar2 or skystar1 cards?). I was afraid that
> it is the driver issue (it looks like everybody in the mailing list is
> using these PVR-XXX cards...).
> I will probably try some older versions of mythtv, maybe the 18.1 and
> the SVN snapshot has really broken DVB-S scan functionality.
>
> Thank you.
> Bob

Bob,

I used .18 and .18.1 along with DVB-S on ASTRA, both did the job.
Technotrend and Skystar cards.

But, when I start mythbackend and mythfrontend on the same system, I
sometimes get the same logentries, and the backend says something like "DVB0
no data from card...". Do you have the same ? Only a reboot fixed the
problem then, restarting myth does not.
Switched to .18, "seems" to be more resistant against this, but perhaps is
not. Do not know.
Some Entries in the mailing list cover the same problem, but no solution.
Not using mythfrontend on the backend machine and no problem anymore.

If you need a db-dump, write an email. I will provide you a complete db of
my production box.

hth,
uwe

--
GMX DSL = Maximale Leistung zum minimalen Preis!
2000 MB nur 2,99, Flatrate ab 4,99 Euro/Monat: http://www.gmx.net/de/go/dsl

_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.