Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Mythtvnz

audio pauses latm-aac

 

 

First page Previous page 1 2 Next page Last page  View All MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded


mythicalbeast at slingshot

Apr 2, 2012, 10:45 PM

Post #1 of 33 (3029 views)
Permalink
audio pauses latm-aac

Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
last 2-3 weeks?

Both 0.24+fixes & 0.25 (2 weeks old) show this problem.

Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
does ancient VLC 1.0.6.



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


paulgir at gmail

Apr 3, 2012, 11:42 AM

Post #2 of 33 (2983 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Tue, 03 Apr 2012 17:45:34 +1200, Brett <mythicalbeast [at] slingshot>
wrote:

> Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
> at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
> last 2-3 weeks?
>
> Both 0.24+fixes & 0.25 (2 weeks old) show this problem.
>
> Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
> does ancient VLC 1.0.6.
>
I have had a couple of instances where the sound had a repetitive

"motorboating" distortion.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mike.brady at devnull

Apr 3, 2012, 11:46 AM

Post #3 of 33 (2980 views)
Permalink
Re: audio pauses latm-aac [In reply to]

Quoting Brett <mythicalbeast [at] slingshot>:

> Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
> at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
> last 2-3 weeks?
>
> Both 0.24+fixes & 0.25 (2 weeks old) show this problem.
>
> Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
> does ancient VLC 1.0.6.
>
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>

Yes I have, although I think that the silences that I was getting were
worse than you describe. I have deleted the recordings now so I can't
try transcoding them.


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 3, 2012, 12:39 PM

Post #4 of 33 (2972 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Tue, Apr 3, 2012 at 5:45 PM, Brett <mythicalbeast [at] slingshot> wrote:
> Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
> at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
> last 2-3 weeks?
>

Now that you mention it, I did notice this in 'Mayday' that I watched
and was recorded on Prime.
I'll check my next recording from Prime and see if it happens again.

> Both 0.24+fixes & 0.25 (2 weeks old) show this problem.
>
> Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
> does ancient VLC 1.0.6.
>

If it transcodes correctly then it may be that our ALSA buffer is set
slightly too small.
Perhaps prime has moved from stereo to 5.1 sound and now the buffers
are sometimes
a little too small.

I'll check tonight and again when Mayday records on Sunday night.

Cheers,
Paul

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 4, 2012, 2:29 AM

Post #5 of 33 (2956 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Wed, 2012-04-04 at 07:39 +1200, Paul Kendall wrote:
> On Tue, Apr 3, 2012 at 5:45 PM, Brett <mythicalbeast [at] slingshot> wrote:
> > Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
> > at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
> > last 2-3 weeks?
> >
>
> Now that you mention it, I did notice this in 'Mayday' that I watched
> and was recorded on Prime.
> I'll check my next recording from Prime and see if it happens again.
>
> > Both 0.24+fixes & 0.25 (2 weeks old) show this problem.
> >
> > Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
> > does ancient VLC 1.0.6.
> >
>
> If it transcodes correctly then it may be that our ALSA buffer is set
> slightly too small.
> Perhaps prime has moved from stereo to 5.1 sound and now the buffers
> are sometimes
> a little too small.
>
> I'll check tonight and again when Mayday records on Sunday night.
>
> Cheers,
> Paul
>

I tried
echo 512 | sudo tee /proc/asound/card0/pcm1p/sub0/prealloc
and other much larger numbers; made no difference.
Is this the same buffer you refer ?

mediainfo reports typical Prime as:
04/04/2012 as 2 ch HE-AAC/LC max 99Kbps
05/01/2012 much the same...

Thanks,
Brett


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 4, 2012, 12:46 PM

Post #6 of 33 (2964 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Wed, Apr 4, 2012 at 9:29 PM, Brett <mythicalbeast [at] slingshot> wrote:
> On Wed, 2012-04-04 at 07:39 +1200, Paul Kendall wrote:
>> On Tue, Apr 3, 2012 at 5:45 PM, Brett <mythicalbeast [at] slingshot> wrote:
>> > Anybody else getting occasional audio pauses/silence (1/2 to 3 sec long
>> > at a rate of 2-5 times an hour) with recording from Prime dvb-t over the
>> > last 2-3 weeks?
>> >
>>
>> Now that you mention it, I did notice this in 'Mayday' that I watched
>> and was recorded on Prime.
>> I'll check my next recording from Prime and see if it happens again.
>>
>> > Both 0.24+fixes & 0.25 (2 weeks old) show this problem.
>> >
>> > Transcoding latm to AAC (libfacc) with latest ffmpeg plays fine , so
>> > does ancient VLC 1.0.6.
>> >
>>
>> If it transcodes correctly then it may be that our ALSA buffer is set
>> slightly too small.
>> Perhaps prime has moved from stereo to 5.1 sound and now the buffers
>> are sometimes
>> a little too small.
>>
>> I'll check tonight and again when Mayday records on Sunday night.
>>
>> Cheers,
>> Paul
>>
>
> I tried
> echo 512 | sudo tee /proc/asound/card0/pcm1p/sub0/prealloc
> and other much larger numbers; made no difference.
> Is this the same buffer you refer ?

Yes, that's the one I was talking about.

>
> mediainfo reports typical Prime as:
> 04/04/2012 as 2 ch HE-AAC/LC max 99Kbps
> 05/01/2012 much the same...
>

I have a recording from last night and was going to check this over easter.
I want to check to see that when it occurs if it is repeatable at the
same position
or if it is semi-random when it occurs.

What are your audio settings i.e. are you upmixing to 5.1 from this
stereo channel.
What is the upmixer set to, best, etc, (not at my machine so I cant
remember them off hand).
It may be that we can adjust these to work around the problem.

Like I said, I'll play around over easter and let you know.

> Thanks,
> Brett

Cheers,
Paul

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 4, 2012, 11:02 PM

Post #7 of 33 (2965 views)
Permalink
Re: audio pauses latm-aac [In reply to]

> Yes, that's the one I was talking about.
>
> >
> > mediainfo reports typical Prime as:
> > 04/04/2012 as 2 ch HE-AAC/LC max 99Kbps
> > 05/01/2012 much the same...
> >
>
> I have a recording from last night and was going to check this over easter.
> I want to check to see that when it occurs if it is repeatable at the
> same position
> or if it is semi-random when it occurs.
>
> What are your audio settings i.e. are you upmixing to 5.1 from this
> stereo channel.
> What is the upmixer set to, best, etc, (not at my machine so I cant
> remember them off hand).
> It may be that we can adjust these to work around the problem.
>
> Like I said, I'll play around over easter and let you know.
>
> Cheers,
> Paul
>

The fault is total repeatable/reproducible.
>From the playback logging to stdout it appears (to me) to be
parser/decoder error.
I'll find some examples & post the titles & time offset.

There is no error reported by ffmpeg (version N-38726-gad029c2) when
decoding.

I'm using iec958 output no upmix, no resampling, AC3/DTS as pass-thru'.

Thanks,
Brett


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


jyavenard at gmail

Apr 4, 2012, 11:46 PM

Post #8 of 33 (3005 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On 5 April 2012 16:02, Brett <mythicalbeast [at] slingshot> wrote:
> >From the playback logging to stdout it appears (to me) to be
> parser/decoder error.
> I'll find some examples & post the titles & time offset.
>
> There is no error reported by ffmpeg (version N-38726-gad029c2) when
> decoding.
>
> I'm using iec958 output no upmix, no resampling, AC3/DTS as pass-thru'.

I'm working on a AAC/LATM fix for 0.25...

On a particular sample, there's audio corruption every couple of
seconds, it sounds like a frame being repeated several times....
sample:
http://dl.dropbox.com/u/354653/1003_20120229090000.mpg

I wonder if it's the same issue you are seeing..

If someone is willing to try a patch

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


jyavenard at gmail

Apr 5, 2012, 12:57 AM

Post #9 of 33 (2947 views)
Permalink
Re: audio pauses latm-aac [In reply to]

The change is in:
https://github.com/MythTV/mythtv/commit/0840578348692387bcd86516487b019d841f5d16

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 1:25 AM

Post #10 of 33 (2966 views)
Permalink
Re: audio pauses latm-aac [In reply to]

Good candidate
Prime dvb-t
Secret Wars 04/04/2012
2:45 minutes in from start

2012-04-05 20:16:58.475 AFD Warning: Audio -76 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:16:58.515 AFD Warning: Audio -36 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:16:58.555 AFD Warning: Audio 4 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:16:58.635 AFD Warning: Audio -87 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:16:58.675 AFD Warning: Audio -47 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:16:58.715 AFD Warning: Audio -7 ms behind video but
already 180 video frames queued. AV-Sync might be broken.


Prime dvb-t
05/04/2012 Prime Spotlight: The Sinking of the Laconia
14 seconds from start..

2012-04-05 20:22:37.659 AFD Warning: Audio -90 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:22:37.698 AFD Warning: Audio -50 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:22:37.858 AFD Warning: Audio -60 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:22:37.898 AFD Warning: Audio -20 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
2012-04-05 20:22:37.938 AFD Warning: Audio 20 ms behind video but
already 180 video frames queued. AV-Sync might be broken.
etc etc..




_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 1:29 AM

Post #11 of 33 (2956 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Thu, 2012-04-05 at 17:57 +1000, Jean-Yves Avenard wrote:
> The change is in:
> https://github.com/MythTV/mythtv/commit/0840578348692387bcd86516487b019d841f5d16
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

I'll give it a try on secondary PC..it take me until tomorrow at least.

Thanks,
Brett


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


g8ecj at gilks

Apr 5, 2012, 1:47 AM

Post #12 of 33 (2998 views)
Permalink
Re: audio pauses latm-aac [In reply to]

> Good candidate
> Prime dvb-t
> Secret Wars 04/04/2012
> 2:45 minutes in from start
>
> 2012-04-05 20:16:58.475 AFD Warning: Audio -76 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:16:58.515 AFD Warning: Audio -36 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:16:58.555 AFD Warning: Audio 4 ms behind video but already
> 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:16:58.635 AFD Warning: Audio -87 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:16:58.675 AFD Warning: Audio -47 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:16:58.715 AFD Warning: Audio -7 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
>
>
> Prime dvb-t
> 05/04/2012 Prime Spotlight: The Sinking of the Laconia
> 14 seconds from start..
>
> 2012-04-05 20:22:37.659 AFD Warning: Audio -90 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:22:37.698 AFD Warning: Audio -50 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:22:37.858 AFD Warning: Audio -60 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:22:37.898 AFD Warning: Audio -20 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> 2012-04-05 20:22:37.938 AFD Warning: Audio 20 ms behind video but
> already 180 video frames queued. AV-Sync might be broken.
> etc etc..

Ditto.
Weekend Murders: Miss Marple from Sat 31st, this sample about 36 minutes in.
Really irritating that Prime Rocks: The Who on Monday night suffers the
same problem.

2012-04-05 20:21:08.878 ALSA, Error: WriteAudio: buffer underrun
2012-04-05 20:21:08.926 AFD Warning: Audio 347 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:08.983 AFD Warning: Audio 387 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.038 AFD Warning: Audio 427 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.097 AFD Warning: Audio 467 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.154 ALSA, Error: WriteAudio: buffer underrun
2012-04-05 20:21:09.157 AFD Warning: Audio 337 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.214 AFD Warning: Audio 206 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.266 AFD Warning: Audio 246 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.322 AFD Warning: Audio 286 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.380 AFD Warning: Audio 326 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.434 AFD Warning: Audio 366 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.496 ALSA, Error: WriteAudio: buffer underrun
2012-04-05 20:21:09.496 AFD Warning: Audio 235 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.549 AFD Warning: Audio 275 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.606 AFD Warning: Audio 315 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.662 AFD Warning: Audio 355 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.702 AFD Warning: Audio 395 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-05 20:21:09.761 ALSA, Error: WriteAudio: buffer underrun

/zotac/usr/bin/mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version : v0.24.2-15-gc29d36f
MythTV Branch : fixes/0.24
Network Protocol : 63
Library API : 0.24.20110505-1
QT Version : 4.7.4
Options compiled in:
linux profile using_alsa using_oss using_backend using_bindings_perl
using_bindings_python using_dvb using_frontend using_hdhomerun
using_hdpvr using_iptv using_ivtv using_lirc using_mheg
using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit
using_v4l using_x11 using_xrandr using_xv using_bindings_perl
using_bindings_python using_mythtranscode using_opengl using_vdpau
using_ffmpeg_threads using_live using_mheg

Built Feb 25 10:01, Alsa 1.0.25 was emerged on 18th March on the Zotac
frontend (6th Mar on the AMD box), but this problem I've only noticed in
the last week and a bit.

One other data point - my Zotac ION has dropouts of 2-10 seconds at a time
but my 8200 motherboard with the AMD 5050 CPU only drops out for 1/2 a
second at a time.

--
Robin Gilks



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 3:16 AM

Post #13 of 33 (2963 views)
Permalink
Re: audio pauses latm-aac [In reply to]

> Weekend Murders: Miss Marple from Sat 31st, this sample about 36 minutes in.
> Really irritating that Prime Rocks: The Who on Monday night suffers the
> same problem.
>


> One other data point - my Zotac ION has dropouts of 2-10 seconds at a time
> but my 8200 motherboard with the AMD 5050 CPU only drops out for 1/2 a
> second at a time.
>
The 8200 chipset mobo supports VDPAU doesn't it ?

The end of "The Who part 1" was bad..haven't watched the 2nd part yet..

One way to skin a dead cat:
ffmpeg -i /path/recordings/1010_prime-filename.mpg -map 0:1 -c:v:0 copy
-map 0:2 -c:a:0 libfaac -b:a:0 320k -f matroska Watchable.mkv

copy into Videos folder.

HandBrake should achieve the same result.



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 2:09 PM

Post #14 of 33 (2942 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Thu, 2012-04-05 at 17:57 +1000, Jean-Yves Avenard wrote:
> The change is in:
> https://github.com/MythTV/mythtv/commit/0840578348692387bcd86516487b019d841f5d16
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

The above commit does not fix the problem but it has changed/improved
the playback..
Instead of complete silence there is some stuttered audio which is
reasonably intelligible.
The audio dropouts occur in same place/time as pre-commit & same
place/time as with 0.24+fixes.
Same errors in log.

Thanks,
Brett


PS: The dropouts in "The Sinking of the Laconia" Prime 05/04/2012
were in the schedule overrun of previous program "The Secret War".
Not all Prime prgms are affected.




_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


jyavenard at gmail

Apr 5, 2012, 3:24 PM

Post #15 of 33 (2943 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On 6 April 2012 07:09, Brett <mythicalbeast [at] slingshot> wrote:

> The above commit does not fix the problem but it has changed/improved
> the playback..
> Instead of complete silence there is some stuttered audio which is
> reasonably  intelligible.
> The audio dropouts occur in same place/time as pre-commit & same
> place/time as with 0.24+fixes.
> Same errors in log.

Ever thought that it could be a broadcasting issue?

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


jyavenard at gmail

Apr 5, 2012, 3:26 PM

Post #16 of 33 (2937 views)
Permalink
Re: audio pauses latm-aac [In reply to]

BTW, the only way to fix this is with a sample where the glitch occur
and proper log with -v audio,playback

Without this information, everything is moot

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 4:08 PM

Post #17 of 33 (2945 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, 2012-04-06 at 08:26 +1000, Jean-Yves Avenard wrote:
> BTW, the only way to fix this is with a sample where the glitch occur
> and proper log with -v audio,playback
>
> Without this information, everything is moot
>
Most of my recording problems have been with Kordia which is the combo
multiplex of all the oddball channels. Includes MTS, Prime (SKY) &
other.
The 2 other dvb-t multiplexes are: one broadcaster==one
multiplex ..always clean problem free.

I have a 10MB sample that captures this problem well..just finding a
suitable place to put it..



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 5, 2012, 4:19 PM

Post #18 of 33 (2920 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, Apr 6, 2012 at 10:26 AM, Jean-Yves Avenard <jyavenard [at] gmail> wrote:
> BTW, the only way to fix this is with a sample where the glitch occur
> and proper log with -v audio,playback
>
> Without this information, everything is moot
>

Heres a proper log (from 0.24-fixes).
I'll see what I can do about uploading a part of the sample.
BTW I'm going to try a build with a larger buffer than the 180 frames
(360) to see if that fixes it.

Cheers,
PK
Attachments: frontend.log (73.6 KB)


mythicalbeast at slingshot

Apr 5, 2012, 5:10 PM

Post #19 of 33 (2936 views)
Permalink
Re: audio pauses latm-aac [In reply to]

A 10MB sample Prime dvb-t h264 576i50

http://www.2shared.com/video/RXttmT6s/part1.html

Part of log -v audio
misleading AV sync warnings from dropped audio data?

2012-04-06 11:07:09.618918 W AFD: Audio 268 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-06 11:07:09.627481 I ALSA: WriteAudio: buffer underrun
2012-04-06 11:07:09.658991 W AFD: Audio 308 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-06 11:07:09.698043 W AFD: Audio 348 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-06 11:07:09.738542 W AFD: Audio 388 ms behind video but already
180 video frames queued. AV-Sync might be broken.
2012-04-06 11:07:09.779534 W AFD: Audio 257 ms behind video but already
180 video frames queued. AV-Sync might be broken.

Thanks,
Brett


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 5, 2012, 5:34 PM

Post #20 of 33 (2936 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, Apr 6, 2012 at 11:19 AM, Paul Kendall <pkendall64 [at] gmail> wrote:
> On Fri, Apr 6, 2012 at 10:26 AM, Jean-Yves Avenard <jyavenard [at] gmail> wrote:
>> BTW, the only way to fix this is with a sample where the glitch occur
>> and proper log with -v audio,playback
>>
>> Without this information, everything is moot
>>
>
> Heres a proper log (from 0.24-fixes).
> I'll see what I can do about uploading a part of the sample.
> BTW I'm going to try a build with a larger buffer than the 180 frames
> (360) to see if that fixes it.
>
> Cheers,
> PK

After applying this patch it seems better

diff --git a/mythtv/libs/libmythtv/avformatdecoder.cpp
b/mythtv/libs/libmythtv/avformatdecoder.cpp
index ff19d00..cd0598b 100644
--- a/mythtv/libs/libmythtv/avformatdecoder.cpp
+++ b/mythtv/libs/libmythtv/avformatdecoder.cpp
@@ -77,7 +77,7 @@ extern void ff_read_frame_flush(AVFormatContext *s);

static const float eps = 1E-5;

-static const int max_video_queue_size = 180;
+static const int max_video_queue_size = 360;

static int cc608_parity(uint8_t byte);
static int cc608_good_parity(const int *parity_table, uint16_t data);

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 6:03 PM

Post #21 of 33 (2934 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, 2012-04-06 at 12:10 +1200, Brett wrote:
> A 10MB sample Prime dvb-t h264 576i50
>
> http://www.2shared.com/video/RXttmT6s/part1.html
>
complete log file start to end playback of sample..
mythfrontend --loglevel debug -v audio >dump2.txt

http://www.2shared.com/document/qGYlIWyi/dump2.html



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mythicalbeast at slingshot

Apr 5, 2012, 6:20 PM

Post #22 of 33 (2930 views)
Permalink
Re: audio pauses latm-aac [In reply to]

> After applying this patch it seems better
>
> diff --git a/mythtv/libs/libmythtv/avformatdecoder.cpp
> b/mythtv/libs/libmythtv/avformatdecoder.cpp
> index ff19d00..cd0598b 100644
> --- a/mythtv/libs/libmythtv/avformatdecoder.cpp
> +++ b/mythtv/libs/libmythtv/avformatdecoder.cpp
> @@ -77,7 +77,7 @@ extern void ff_read_frame_flush(AVFormatContext *s);
>
> static const float eps = 1E-5;
>
> -static const int max_video_queue_size = 180;
> +static const int max_video_queue_size = 360;
>
> static int cc608_parity(uint8_t byte);
> static int cc608_good_parity(const int *parity_table, uint16_t data);
>

Yes that fixes the problem..there is only one AFD warning at the very
end because of the file stream cutting.

Didn't see any easter eggs..

Does the patch suggest that Prime has a greater offset between audio &
video packets ?

Thanks very much,
Brett


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 5, 2012, 6:43 PM

Post #23 of 33 (2926 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, Apr 6, 2012 at 1:20 PM, Brett <mythicalbeast [at] slingshot> wrote:
>> After applying this patch it seems better
>>
>> diff --git a/mythtv/libs/libmythtv/avformatdecoder.cpp
>> b/mythtv/libs/libmythtv/avformatdecoder.cpp
>> index ff19d00..cd0598b 100644
>> --- a/mythtv/libs/libmythtv/avformatdecoder.cpp
>> +++ b/mythtv/libs/libmythtv/avformatdecoder.cpp
>> @@ -77,7 +77,7 @@ extern void ff_read_frame_flush(AVFormatContext *s);
>>
>>  static const float eps = 1E-5;
>>
>> -static const int max_video_queue_size = 180;
>> +static const int max_video_queue_size = 360;
>>
>>  static int cc608_parity(uint8_t byte);
>>  static int cc608_good_parity(const int *parity_table, uint16_t data);
>>
>
> Yes that fixes the problem..there is only one AFD warning at the very
> end because of the file stream cutting.
>

Awesome. My wife is happy now she can watch her show without the
audio silences :-)

> Didn't see any easter eggs..
>
> Does the patch suggest that Prime has a greater offset between audio &
> video packets ?
>
> Thanks very much,
> Brett
>

That's a question for someone more in the know than me. I just made an
educated guess at the patch from the log messages I got.

Cheers,
PK

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


jyavenard at gmail

Apr 5, 2012, 7:48 PM

Post #24 of 33 (2922 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On 6 April 2012 10:34, Paul Kendall <pkendall64 [at] gmail> wrote:
> -static const int max_video_queue_size = 180;
> +static const int max_video_queue_size = 360;

What value does it start playing okay for you?

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


pkendall64 at gmail

Apr 5, 2012, 8:02 PM

Post #25 of 33 (2930 views)
Permalink
Re: audio pauses latm-aac [In reply to]

On Fri, Apr 6, 2012 at 2:48 PM, Jean-Yves Avenard <jyavenard [at] gmail> wrote:
> On 6 April 2012 10:34, Paul Kendall <pkendall64 [at] gmail> wrote:
>> -static const int max_video_queue_size = 180;
>> +static const int max_video_queue_size = 360;
>
> What value does it start playing okay for you?
>

200, was ok, but there messages in the log, 220 no problems, nothing in the log.

Cheers,
PK

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

First page Previous page 1 2 Next page Last page  View All MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.