Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Mythtvnz

tv_grab_nz-py set up

 

 

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded


paulgir at gmail

Jan 21, 2012, 1:53 PM

Post #1 of 19 (3358 views)
Permalink
tv_grab_nz-py set up

I have installed this script as per this thread:
http://www.gossamer-threads.com/lists/mythtv/mythtvnz/491620?search_string=tv_grab_nz-py;#491620

In myth backend set up >video sources>configure
the messages indicate it is downloading the data successfully.
The data does not appear in the schedule.
I have also tried tv_grab_nz-py --configure in a terminal.
Also, I don't have a /home/myth/.xmltv/tv_grab_nz-py.conf file..

In normal operation,does tv_grab_nz-py run automatically?If not how
is it normally run? Via myth backend set up?

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 21, 2012, 3:04 PM

Post #2 of 19 (3291 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 22 January 2012 10:53, Paulgir <paulgir [at] gmail> wrote:
>
>
> I have installed this script as per this thread:
> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/491620?search_string=tv_grab_nz-py;#491620
>
> In myth backend set up >video sources>configure
> the messages indicate it is downloading the data successfully.
> The data does not appear in the schedule.
> I have also tried  tv_grab_nz-py --configure in a terminal.
> Also, I don't have a /home/myth/.xmltv/tv_grab_nz-py.conf file..
>
> In normal operation,does tv_grab_nz-py run automatically?If not how
> is it normally run? Via myth backend set up?
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

There's a recent thread with some infomation you might find useful,
including a simple bash script I wrote to pull the epg data and run
mythfilldatabase automagically (once you cron it).

http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread\

I personally couldn't get the tv_grab_nz-py script to work for me, and
after a few frustrating days took matters into my own hands.

http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


paulgir at gmail

Jan 22, 2012, 12:42 PM

Post #3 of 19 (3295 views)
Permalink
tv_grab_nz-py set up [In reply to]

>> mythtvnz mailing list
>> mythtvnz [at] lists
>> http://lists.ourshack.com/mailman/listinfo/mythtvnz
>> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>
> There's a recent thread with some infomation you might find useful,
> including a simple bash script I wrote to pull the epg data and run
> mythfilldatabase automagically (once you cron it).
>
> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread\
>
> I personally couldn't get the tv_grab_nz-py script to work for me, and
> after a few frustrating days took matters into my own hands.
>
> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread
>
>
Do you put the script in any particular location?

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 22, 2012, 1:56 PM

Post #4 of 19 (3294 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23 January 2012 09:42, Paulgir <paulgir [at] gmail> wrote:
>
>
> >> mythtvnz mailing list
> >> mythtvnz [at] lists
> >> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> >> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
> >
> > There's a recent thread with some infomation you might find useful,
> > including a simple bash script I wrote to pull the epg data and run
> > mythfilldatabase automagically (once you cron it).
> >
> > http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread\
> >
> > I personally couldn't get the tv_grab_nz-py script to work for me, and
> > after a few frustrating days took matters into my own hands.
> >
> > http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread
> >
> >
> Do you put the script in any particular location?
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

It needs to go into a distribution-specific location if you want cron
to run it (check your distro's documentation with respect to cron
jobs). But no, otherwise it can be run from anywhere.

You can check the script is working by running it from a terminal e.g.
"./updateEPG.sh". You should see it download the EPG data and run
mythfilldatabase. Then check to see it has worked by checking your
myth Programme Guide.

Sorry, I can't recall the exact details of how I set mine up as a cron
job at 3am (I run Arch Linux), but it's pretty straighforward.

Good luck!

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


paulgir at gmail

Jan 22, 2012, 2:33 PM

Post #5 of 19 (3287 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On Mon, 23 Jan 2012 09:42:24 +1300, Paulgir <paulgir [at] gmail> wrote:

>
>>> mythtvnz mailing list
>>> mythtvnz [at] lists
>>> http://lists.ourshack.com/mailman/listinfo/mythtvnz
>>> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>>
>> There's a recent thread with some infomation you might find useful,
>> including a simple bash script I wrote to pull the epg data and run
>> mythfilldatabase automagically (once you cron it).
>>
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread\
>>
>> I personally couldn't get the tv_grab_nz-py script to work for me, and
>> after a few frustrating days took matters into my own hands.
>>
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread
>>
>>
> Do you put the script in any particular location?

I put the script in the Home directory and executed it manually.
Didn't see any effect on the schedule.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Jan 22, 2012, 3:58 PM

Post #6 of 19 (3290 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

> I put the script in the Home directory and executed it manually.
> Didn't see any effect on the schedule.
I did the same.

TO be sure this is the script I used...


STARTS
#! /bin/bash
wget http://nzepg.org/freeview.xml.gz
gunzip freeview.xml.gz
mythfilldatabase --file 1 freeview.xml --update
rm freeview.xml
exit
STOPS

I see no schedule information. But the 'mythweb/status' page says:

Last mythfilldatabase run started on 2012-01-22 12:10:12 and ended on
2012-01-22 12:10:31. Successful.
There's guide data until 2012-01-29 19:00 (6 days).

FYI here is the output of the script...

$ ./updateEPG.sh
--2012-01-23 12:56:48-- http://nzepg.org/freeview.xml.gz
Resolving nzepg.org... 74.207.253.88
Connecting to nzepg.org|74.207.253.88|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 197214 (193K) [application/x-gzip]
Saving to: `freeview.xml.gz'

100%[======================================>] 197,214 148K/s in 1.3s

2012-01-23 12:56:51 (148 KB/s) - `freeview.xml.gz' saved [197214/197214]

2012-01-23 12:56:52.665 Bypassing grabbers, reading directly from file
2012-01-23 12:56:52.678 Using runtime prefix = /usr
2012-01-23 12:56:52.678 Using configuration directory = /home/lounge/.mythtv
2012-01-23 12:56:52.713 Empty LocalHostName.
2012-01-23 12:56:52.713 Using localhost value of mythdu
2012-01-23 12:56:52.757 New DB connection, total: 1
2012-01-23 12:56:52.762 Connected to database 'mythconverg' at host:
localhost
2012-01-23 12:56:52.786 Closing DB connection named 'DBManager0'
2012-01-23 12:56:52.787 Connected to database 'mythconverg' at host:
localhost
2012-01-23 12:56:52.790 Current locale en_NZ
2012-01-23 12:56:52.812 No locale defaults file for en_NZ, skipping
2012-01-23 12:56:52.847 Loading en_us translation for module mythfrontend
2012-01-23 12:56:52.871 Current MythTV Schema Version (DBSchemaVer): 1264
2012-01-23 12:56:53.198 New DB connection, total: 2
2012-01-23 12:56:53.198 Connected to database 'mythconverg' at host:
localhost
2012-01-23 12:56:53.752 IconData: Updating icons for sourceid: 1
2012-01-23 12:56:53.891 New DB connection, total: 3
2012-01-23 12:56:53.891 Connected to database 'mythconverg' at host:
localhost
2012-01-23 12:57:03.414 Updated programs: 749 Unchanged programs: 2498
2012-01-23 12:57:03.448 Adjusting program database end times.
2012-01-23 12:57:03.527 0 replacements made
2012-01-23 12:57:03.527 Marking generic episodes.
2012-01-23 12:57:03.568 Found 111
2012-01-23 12:57:03.568 Fudging non-unique programids with multiple parts.
2012-01-23 12:57:03.579 Found 0
2012-01-23 12:57:03.579 Marking repeats.
2012-01-23 12:57:03.612 Found 0
2012-01-23 12:57:03.612 Unmarking new episode rebroadcast repeats.
2012-01-23 12:57:03.616 Found 0
2012-01-23 12:57:03.723 Marking episode first showings.
2012-01-23 12:57:05.311 Found 1416
2012-01-23 12:57:05.312 Marking episode last showings.
2012-01-23 12:57:06.880 Found 1416
2012-01-23 12:57:06.883
===============================================================
| Attempting to contact the master backend for rescheduling. |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted. |
===============================================================
2012-01-23 12:57:06.890 MythCoreContext: Connecting to backend server:
192.168.1.14:6543 (try 1 of 1)
2012-01-23 12:57:06.892 Using protocol version 63
2012-01-23 12:57:07.126 Received a remote 'Clear Cache' request
2012-01-23 12:57:08.125 mythfilldatabase run complete.
2012-01-23 12:57:08.140 DataDirect: Deleting temporary files

--
Foo!


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


mike.brady at devnull

Jan 22, 2012, 8:51 PM

Post #7 of 19 (3279 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

Quoting Paulgir <paulgir [at] gmail>:

>
>>> mythtvnz mailing list
>>> mythtvnz [at] lists
>>> http://lists.ourshack.com/mailman/listinfo/mythtvnz
>>> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>>
>> There's a recent thread with some infomation you might find useful,
>> including a simple bash script I wrote to pull the epg data and run
>> mythfilldatabase automagically (once you cron it).
>>
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread\
>>
>> I personally couldn't get the tv_grab_nz-py script to work for me, and
>> after a few frustrating days took matters into my own hands.
>>
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/494548?page=unread#unread
>>
>>
> Do you put the script in any particular location?
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>

These are the notes that I made when I setup my system last year on
Centos 6. Your mileage may vary.

1) Download tv_grab_nz-py from http://nice.net.nz/tv_grab_nz-py/

2) Copy tv_grab_nz-py to /usr/bin. Make sure that it is executable.

3) Configure it. Note that the configuration file name must match that
name of the video source configured in mythtv-setup for the
mythbackend/mythfilldatabase to use this grabber.
tv_grab_nz-py --configure --config-file ~/.mythtv/<video sources name>.xmltv

4) To see if the xmltv side of things works run
tv_find_grabbers

This should return a list of all the installed grabbers, which should
just be tv_grab_nz-py.

5) To see if the myth side of things works run
mythfilldatabase
Pay close attention to the output of this. If it looks like it worked,
the MythWeb status page should also show a successful run.

6) On the master backend run mythsetup and
a) In Video Sources set "New Zealand (py)" as the grabber for your
Video Source.
b) In General, on the Mythfilldatabase page (its the last page) enable
"Automatically run mythfilldatabase". Configure time, frequency, etc
to suite. Now Myth should use tv_grab_nz-py to update EPG
periodically. The MythWeb status page shows when it was last run and
what the results were.

Hope that this is useful.

Regards

Mike


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


hads at nice

Jan 22, 2012, 8:57 PM

Post #8 of 19 (3280 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23/01/12 17:51, Mike Brady wrote:
> Hope that this is useful.

Good summary Mike. The only thing I would add is if it doesn't work you
can use mythfilldatabase -v xmltv to get more debugging output.

hads
--
http://nicegear.co.nz

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 22, 2012, 9:14 PM

Post #9 of 19 (3284 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23 January 2012 12:58, Worik Stanton <worik.stanton [at] gmail> wrote:
>
>> I put the script in the Home directory and executed it manually.
>> Didn't see any effect on the schedule.
> I did the same.
>
> TO be sure this is the script I used...
>
>
> STARTS
> #! /bin/bash
> wget http://nzepg.org/freeview.xml.gz
> gunzip freeview.xml.gz
> mythfilldatabase --file 1 freeview.xml --update
> rm freeview.xml
> exit
> STOPS
>
> I see no schedule information.  But the 'mythweb/status' page says:
>
> Last mythfilldatabase run started on 2012-01-22 12:10:12 and ended on
> 2012-01-22 12:10:31. Successful.
> There's guide data until 2012-01-29 19:00 (6 days).
>
> FYI here is the output of the script...
>
> $ ./updateEPG.sh
> --2012-01-23 12:56:48--  http://nzepg.org/freeview.xml.gz
> Resolving nzepg.org... 74.207.253.88
> Connecting to nzepg.org|74.207.253.88|:80... connected.
> HTTP request sent, awaiting response... 200 OK
> Length: 197214 (193K) [application/x-gzip]
> Saving to: `freeview.xml.gz'
>
> 100%[======================================>] 197,214      148K/s   in 1.3s
>
> 2012-01-23 12:56:51 (148 KB/s) - `freeview.xml.gz' saved [197214/197214]
>
> 2012-01-23 12:56:52.665 Bypassing grabbers, reading directly from file
> 2012-01-23 12:56:52.678 Using runtime prefix = /usr
> 2012-01-23 12:56:52.678 Using configuration directory = /home/lounge/.mythtv
> 2012-01-23 12:56:52.713 Empty LocalHostName.
> 2012-01-23 12:56:52.713 Using localhost value of mythdu
> 2012-01-23 12:56:52.757 New DB connection, total: 1
> 2012-01-23 12:56:52.762 Connected to database 'mythconverg' at host:
> localhost
> 2012-01-23 12:56:52.786 Closing DB connection named 'DBManager0'
> 2012-01-23 12:56:52.787 Connected to database 'mythconverg' at host:
> localhost
> 2012-01-23 12:56:52.790 Current locale en_NZ
> 2012-01-23 12:56:52.812 No locale defaults file for en_NZ, skipping
> 2012-01-23 12:56:52.847 Loading en_us translation for module mythfrontend
> 2012-01-23 12:56:52.871 Current MythTV Schema Version (DBSchemaVer): 1264
> 2012-01-23 12:56:53.198 New DB connection, total: 2
> 2012-01-23 12:56:53.198 Connected to database 'mythconverg' at host:
> localhost
> 2012-01-23 12:56:53.752 IconData: Updating icons for sourceid: 1
> 2012-01-23 12:56:53.891 New DB connection, total: 3
> 2012-01-23 12:56:53.891 Connected to database 'mythconverg' at host:
> localhost
> 2012-01-23 12:57:03.414 Updated programs: 749 Unchanged programs: 2498
> 2012-01-23 12:57:03.448 Adjusting program database end times.
> 2012-01-23 12:57:03.527     0 replacements made
> 2012-01-23 12:57:03.527 Marking generic episodes.
> 2012-01-23 12:57:03.568     Found 111
> 2012-01-23 12:57:03.568 Fudging non-unique programids with multiple parts.
> 2012-01-23 12:57:03.579     Found 0
> 2012-01-23 12:57:03.579 Marking repeats.
> 2012-01-23 12:57:03.612     Found 0
> 2012-01-23 12:57:03.612 Unmarking new episode rebroadcast repeats.
> 2012-01-23 12:57:03.616     Found 0
> 2012-01-23 12:57:03.723 Marking episode first showings.
> 2012-01-23 12:57:05.311     Found 1416
> 2012-01-23 12:57:05.312 Marking episode last showings.
> 2012-01-23 12:57:06.880     Found 1416
> 2012-01-23 12:57:06.883
> ===============================================================
> | Attempting to contact the master backend for rescheduling.  |
> | If the master is not running, rescheduling will happen when |
> | the master backend is restarted.                            |
> ===============================================================
> 2012-01-23 12:57:06.890 MythCoreContext: Connecting to backend server:
> 192.168.1.14:6543 (try 1 of 1)
> 2012-01-23 12:57:06.892 Using protocol version 63
> 2012-01-23 12:57:07.126 Received a remote 'Clear Cache' request
> 2012-01-23 12:57:08.125 mythfilldatabase run complete.
> 2012-01-23 12:57:08.140 DataDirect: Deleting temporary files
>
> --
> Foo!
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

Your output looks OK, it looks as though the script is running as it
should, and updating the database. THe status says you have EPG data
for seven days, which is encouraging.

I suspect that if you're not seeing anything in the program guide,
then the channels aren't set up in the same way mine are in your
mythtv-setup's channel editor. Can you go the the channel editor,
select TV ONE and let me know what the settings are?

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Jan 22, 2012, 9:33 PM

Post #10 of 19 (3275 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23/01/12 18:14, Curtis Walker wrote:
> Your output looks OK, it looks as though the script is running as it
> should, and updating the database. THe status says you have EPG data
> for seven days, which is encouraging.
>
> I suspect that if you're not seeing anything in the program guide,
> then the channels aren't set up in the same way mine are in your
> mythtv-setup's channel editor. Can you go the the channel editor,
> select TV ONE and let me know what the settings are?

Yep. Note that below "Use on air guide: Not ticked" I changed it to be
ticked

Channel name: One
Channel Number: <No entry>
Callsign: ONE
Visible: Ticked
Video Source: Nova-T
TV Format: Defalt
Priority: 0
Icon: <Path to icon>
Use on air guide: Not ticked
XMLTV ID: tv1.freeviewnz.tv
DataDire...... <Obscured>: 0

Helpful?

cheers
Worik

--
Foo!


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Jan 22, 2012, 9:43 PM

Post #11 of 19 (3279 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23/01/12 17:51, Mike Brady wrote:
> 6) On the master backend run mythsetup and
> a) In Video Sources set "New Zealand (py)" as the grabber for your
> Video Source.
> b) In General, on the Mythfilldatabase page (its the last page) enable
> "Automatically run mythfilldatabase". Configure time, frequency, etc
> to suite. Now Myth should use tv_grab_nz-py to update EPG
> periodically. The MythWeb status page shows when it was last run and
> what the results were.
>
On that page the "mythfilldatabase program:" is set to
"/usr/bin/mythfilldatabase". Is that OK?

Under "Video Source Setup" for Nova-T the "Listings Grabber:" "New
Zealand (py) (xmltv)". So should be cool?

cheers
Worik

--
Foo!


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 22, 2012, 11:21 PM

Post #12 of 19 (3277 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23 January 2012 18:43, Worik Stanton <worik.stanton [at] gmail> wrote:
> On 23/01/12 17:51, Mike Brady wrote:
>> 6) On the master backend run mythsetup and
>> a) In Video Sources set "New Zealand (py)" as the grabber for your
>> Video Source.
>> b) In General, on the Mythfilldatabase page (its the last page) enable
>> "Automatically run mythfilldatabase". Configure time, frequency, etc
>> to suite. Now Myth should use tv_grab_nz-py to update EPG
>> periodically. The MythWeb status page shows when it was last run and
>> what the results were.
>>
> On that page the "mythfilldatabase program:" is set to
> "/usr/bin/mythfilldatabase".  Is that OK?
>
> Under "Video Source Setup" for Nova-T the "Listings Grabber:" "New
> Zealand (py) (xmltv)".  So should be cool?
>
> cheers
> Worik
>
> --
> Foo!
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

It doesn't matter, since we're calling mythfilldatabase manually using
the script. We're also not using the listings grabber, so it doesn't
matter what you have there.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 22, 2012, 11:52 PM

Post #13 of 19 (3285 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 23 January 2012 18:33, Worik Stanton <worik.stanton [at] gmail> wrote:
> On 23/01/12 18:14, Curtis Walker wrote:
>> Your output looks OK, it looks as though the script is running as it
>> should, and updating the database. THe status says you have EPG data
>> for seven days, which is encouraging.
>>
>> I suspect that if you're not seeing anything in the program guide,
>> then the channels aren't set up in the same way mine are in your
>> mythtv-setup's channel editor. Can you go the the channel editor,
>> select TV ONE and let me know what the settings are?
>
> Yep.  Note that below "Use on air guide: Not ticked" I changed it to be
> ticked
>
> Channel name: One
> Channel Number: <No entry>
> Callsign: ONE
> Visible: Ticked
> Video Source: Nova-T
> TV Format: Defalt
> Priority: 0
> Icon: <Path to icon>
> Use on air guide: Not ticked
> XMLTV ID: tv1.freeviewnz.tv
> DataDire...... <Obscured>: 0
>
> Helpful?
>
> cheers
> Worik
>
> --
> Foo!
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

Mine:

Channel name: TV ONE
Channel Number: 1
Callsign: TV ONE
Visible: Ticked
Video Source: FreeviewHD (my input source - obviously you labelled
yours 'NOVA-T')
TV Format: Defalt
Priority: 0
Icon: /home/user/.mythtv/channelicons/one.jpg (your path will be
different - but use this instead of inputting an http location - it
will stop the lag while you set your channels up in the channel
editor)
Use 'over the air' programme listings: Not ticked
XMLTV ID: tv1.freeviewnz.tv

I basically manually added the channels into the channel editor using
the above format.

My channel names are all the same as my callsigns which may make a
difference - I can't remember, as it's been a while since I set this
all up!

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Jan 23, 2012, 1:43 PM

Post #14 of 19 (3281 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

Bingo!

On 23/01/12 20:52, Curtis Walker wrote:
[snip]

My setup in channel editor
>> Channel name: One
>> Channel Number:<No entry>
>> Callsign: ONE
>> Visible: Ticked
>> Video Source: Nova-T
>> TV Format: Defalt
>> Priority: 0
>> Icon:<Path to icon>
>> Use on air guide: Not ticked
>> XMLTV ID: tv1.freeviewnz.tv
>> DataDire......<Obscured>: 0
[snip]

Curtis' setup
> Channel name: TV ONE
> Channel Number: 1
> Callsign: TV ONE
> Visible: Ticked
> Video Source: FreeviewHD (my input source - obviously you labelled
> yours 'NOVA-T')
> TV Format: Defalt
> Priority: 0
> Icon: /home/user/.mythtv/channelicons/one.jpg (your path will be
> different - but use this instead of inputting an http location - it
> will stop the lag while you set your channels up in the channel
> editor)
> Use 'over the air' programme listings: Not ticked
> XMLTV ID: tv1.freeviewnz.tv
>

When I changed the "channel number" to be "1" I get listings for TV1.

After work (Uhem, I should be working now....) I'll work on the channel
numbers for the other channels.

But so far so good, looking like I will succeed, thank you very much for
your help and patience!

cheers
W

> I basically manually added the channels into the channel editor using
> the above format.
>
> My channel names are all the same as my callsigns which may make a
> difference - I can't remember, as it's been a while since I set this
> all up!
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>


--
Foo!


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Jan 24, 2012, 1:04 AM

Post #15 of 19 (3257 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 24/01/12 10:43, Worik Stanton wrote:
> Bingo!
Almost. I live in Dunedin and the powers that be have changed the
channel frequencies. So I had to do a rescan.

Now I have data for one day for most channels. I have no data for TV2
or TV7.

I have channel numbers for all channels.

TV2 and TV7 do not have logos automatically found but I cannot see why
that should matter.

All channels have on screen information about what is playing

I have run Curtis' script as the mythtv user.

I am unsure what other information could be useful.

cheers
Worik


--
Foo!


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 24, 2012, 2:09 AM

Post #16 of 19 (3258 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 24 January 2012 22:04, Worik Stanton <worik.stanton [at] gmail> wrote:

> On 24/01/12 10:43, Worik Stanton wrote:
> > Bingo!
> Almost. I live in Dunedin and the powers that be have changed the
> channel frequencies. So I had to do a rescan.
>
> Now I have data for one day for most channels. I have no data for TV2
> or TV7.
>
> I have channel numbers for all channels.
>
> TV2 and TV7 do not have logos automatically found but I cannot see why
> that should matter.
>
> All channels have on screen information about what is playing
>
> I have run Curtis' script as the mythtv user.
>
> I am unsure what other information could be useful.
>
> cheers
> Worik
>
>
Not so close, I'm afraid. The one-day data indicates it's pulled
over-the-air data, which does provide you with one day's programme
scheduling and information. If your 'status' shows that mythfilldatabase
ran successfully and there is data for 6 or 7 days (indicating the script
has run properly), but you only have one day's prgramme stuff, there is
still some errant setting causing a mismatch. Not sure what, but will have
a bit of a think on it and get back if I come up with something (or someone
else will).

That said, with the good step-by-step instructions posted for the
tv_grab_nz-py script, you may also want to try that route.

Good hunting!


tortise at paradise

Jan 24, 2012, 2:43 AM

Post #17 of 19 (3258 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 24/01/2012 10:04 p.m., Worik Stanton wrote:

> I am unsure what other information could be useful.

Much of this is not new and has been well covered in the list before.

As per the footer: Archives
http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

Search archives for "SQL" and "MultiRec Turned Off?" for examples of
related issues worked through in detail showing what your tables should
align to.

The archives have a wealth of information therein.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


paulgir at gmail

Jan 24, 2012, 12:47 PM

Post #18 of 19 (3257 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On Tue, 24 Jan 2012 23:43:34 +1300, tortise <tortise [at] paradise>
wrote:

> On 24/01/2012 10:04 p.m., Worik Stanton wrote:
>
>> I am unsure what other information could be useful.
>
> Much of this is not new and has been well covered in the list before.
>
> As per the footer: Archives
> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>
> Search archives for "SQL" and "MultiRec Turned Off?" for examples of
> related issues worked through in detail showing what your tables should
> align to.
>
> The archives have a wealth of information therein.
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

Many thanks for the help to get this sorted.
I went through the video sources set up again,then edited the channels as
per
this guide: http://wiki.linux.net.nz/FreeViewHDMythTvNotes
Mike Brady's instructions helped me get the grabber installed and working.

At the moment I don't have a permanent network connection to the myth box.
I had a full 8 days of schedule data but it disappeared,I think< when the
grabber did
a scheduled grab with no LAN connection.I will turn the scheduled grab off
and just
do manual ones once a week till I get a permanent ethernet line to the box.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


sultanoswing at gmail

Jan 24, 2012, 2:43 PM

Post #19 of 19 (3251 views)
Permalink
Re: tv_grab_nz-py set up [In reply to]

On 25/01/2012, Paulgir <paulgir [at] gmail> wrote:
> On Tue, 24 Jan 2012 23:43:34 +1300, tortise <tortise [at] paradise>
> wrote:
>
>> On 24/01/2012 10:04 p.m., Worik Stanton wrote:
>>
>>> I am unsure what other information could be useful.
>>
>> Much of this is not new and has been well covered in the list before.
>>
>> As per the footer: Archives
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>>
>> Search archives for "SQL" and "MultiRec Turned Off?" for examples of
>> related issues worked through in detail showing what your tables should
>> align to.
>>
>> The archives have a wealth of information therein.
>>
>> _______________________________________________
>> mythtvnz mailing list
>> mythtvnz [at] lists
>> http://lists.ourshack.com/mailman/listinfo/mythtvnz
>> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>
> Many thanks for the help to get this sorted.
> I went through the video sources set up again,then edited the channels as
> per
> this guide: http://wiki.linux.net.nz/FreeViewHDMythTvNotes
> Mike Brady's instructions helped me get the grabber installed and working.
>
> At the moment I don't have a permanent network connection to the myth box.
> I had a full 8 days of schedule data but it disappeared,I think< when the
> grabber did
> a scheduled grab with no LAN connection.I will turn the scheduled grab off
> and just
> do manual ones once a week till I get a permanent ethernet line to the box.
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>

Yeah, it's good stuff, that guide. I now recall that is what I used to
set my channels up. The only difference was that I couldn't get the py
script to work, so set up my own bash script as a cron job (as per the
other thread on this topic at present).

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.