Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Mythtvnz

local and master backend settings

 

 

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded


roger.searle at gmail

Sep 17, 2011, 2:21 PM

Post #1 of 10 (1279 views)
Permalink
local and master backend settings

This will teach me... I have messed up my FE/BE setup by thinking I
could set up a static IP address on the box and putting that address in
the backend general settings page. The FE wouldn't then run so I set
about trying to go back, and have the local backend and master backend
both as 127.0.0.1 in the BE general settings screen. Here's some of the
output from running the frontend from a terminal, seems I've got
multiple database connection attempts too, any assistance would be
appreciated:

roger [at] gemin ~/.mythtv $ mythfrontend
2011-09-18 08:59:24.017 mythfrontend version: fixes/0.24
[v0.24-243-g9ba3ece] www.mythtv.org
2011-09-18 08:59:24.017 Using runtime prefix = /usr
2011-09-18 08:59:24.017 Using configuration directory = /home/roger/.mythtv

2011-09-18 08:59:24.783 Using localhost value of gemini
2011-09-18 08:59:24.800 New DB connection, total: 1
2011-09-18 08:59:24.806 Connected to database 'mythconverg' at host:
127.0.0.1

2011-09-18 08:59:25.589 New DB connection, total: 2
2011-09-18 08:59:25.589 New DB connection, total: 3
2011-09-18 08:59:25.590 New DB connection, total: 4
2011-09-18 08:59:25.590 Current MythTV Schema Version (DBSchemaVer): 1264
2011-09-18 08:59:25.590 Connected to database 'mythconverg' at host:
127.0.0.1
2011-09-18 08:59:25.590 Connected to database 'mythconverg' at host:
127.0.0.1
2011-09-18 08:59:25.591 Connected to database 'mythconverg' at host:
127.0.0.1

2011-09-18 08:59:26.652 MythCoreContext: Connecting to backend server:
127.0.0.1:6543 (try 1 of 1)
2011-09-18 08:59:26.652 Connection to master server timed out.
Either the server is down or the master server settings
in mythtv-settings does not contain the proper IP address

2011-09-18 08:59:26.652 Unable to determine master backend time zone
settings. If those settings differ from local settings, some
functionality will fail.
2011-09-18 08:59:35.033 MythCoreContext: Connecting to backend server:
127.0.0.1:6543 (try 1 of 1)
2011-09-18 08:59:35.033 Connection to master server timed out.
Either the server is down or the master server settings
in mythtv-settings does not contain the proper IP address

Cheers,
Roger

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


solorvox at epic

Sep 17, 2011, 3:29 PM

Post #2 of 10 (1269 views)
Permalink
Re: local and master backend settings [In reply to]

On Sun, September 18, 2011 09:21, Roger Searle wrote:
>
> This will teach me... I have messed up my FE/BE setup by thinking I
> could set up a static IP address on the box and putting that address in
> the backend general settings page. The FE wouldn't then run so I set
> about trying to go back, and have the local backend and master backend
> both as 127.0.0.1 in the BE general settings screen. Here's some of the
> output from running the frontend from a terminal, seems I've got
> multiple database connection attempts too, any assistance would be
> appreciated:
>

First thing, you have backups right? :)

If you are running MythWeb on your BE, you can change the settings in the
"settings" option. Otherwise, you'll need to directly edit your database
on your BE.

Using your mysql tool of choice, verify/change settings in the
"mythconverg" database, "settings" table.

Keys to note:
MasterServerIP and BackendServerIP.

That's for the BE, now for the FE, check out the ~/.mythtv/config.xml and
mysql.txt then change the DBHostName key if needed.


Hope this helps.
sV

--
Zebra Craft http://www.zebracraft.co.nz
Personalized gifts, engraving, laser cut prototype boxes


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


nick.rout at gmail

Sep 17, 2011, 3:40 PM

Post #3 of 10 (1274 views)
Permalink
Re: local and master backend settings [In reply to]

On Sun, Sep 18, 2011 at 9:21 AM, Roger Searle <roger.searle [at] gmail> wrote:
> This will teach me... I have messed up my FE/BE setup by thinking I
> could set up a static IP address on the box and putting that address in
> the backend general settings page.  The FE wouldn't then run so I set
> about trying to go back, and have the local backend and master backend
> both as 127.0.0.1 in the BE general settings screen.


This works but you will be sorry when you go to run a remote frontend.

But in your present case your quickest fix is to set the backend back
to 127.0.0.1. Run mythtv-setup.

> Here's some of the
> output from running the frontend from a terminal, seems I've got
> multiple database connection attempts too, any assistance would be
> appreciated:
>
> roger [at] gemin ~/.mythtv $ mythfrontend
> 2011-09-18 08:59:24.017 mythfrontend version: fixes/0.24
> [v0.24-243-g9ba3ece] www.mythtv.org
> 2011-09-18 08:59:24.017 Using runtime prefix = /usr
> 2011-09-18 08:59:24.017 Using configuration directory = /home/roger/.mythtv
>
> 2011-09-18 08:59:24.783 Using localhost value of gemini
> 2011-09-18 08:59:24.800 New DB connection, total: 1
> 2011-09-18 08:59:24.806 Connected to database 'mythconverg' at host:
> 127.0.0.1
>
> 2011-09-18 08:59:25.589 New DB connection, total: 2
> 2011-09-18 08:59:25.589 New DB connection, total: 3
> 2011-09-18 08:59:25.590 New DB connection, total: 4
> 2011-09-18 08:59:25.590 Current MythTV Schema Version (DBSchemaVer): 1264
> 2011-09-18 08:59:25.590 Connected to database 'mythconverg' at host:
> 127.0.0.1
> 2011-09-18 08:59:25.590 Connected to database 'mythconverg' at host:
> 127.0.0.1
> 2011-09-18 08:59:25.591 Connected to database 'mythconverg' at host:
> 127.0.0.1
>
> 2011-09-18 08:59:26.652 MythCoreContext: Connecting to backend server:
> 127.0.0.1:6543 (try 1 of 1)
> 2011-09-18 08:59:26.652 Connection to master server timed out.
>             Either the server is down or the master server settings
>             in mythtv-settings does not contain the proper IP address
>
> 2011-09-18 08:59:26.652 Unable to determine master backend time zone
> settings.  If those settings differ from local settings, some
> functionality will fail.
> 2011-09-18 08:59:35.033 MythCoreContext: Connecting to backend server:
> 127.0.0.1:6543 (try 1 of 1)
> 2011-09-18 08:59:35.033 Connection to master server timed out.
>             Either the server is down or the master server settings
>             in mythtv-settings does not contain the proper IP address
>
> Cheers,
> Roger
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


roger.searle at gmail

Sep 18, 2011, 12:09 AM

Post #4 of 10 (1261 views)
Permalink
Re: local and master backend settings [In reply to]

On 18/09/11 10:40, Nick Rout wrote:
> On Sun, Sep 18, 2011 at 9:21 AM, Roger Searle<roger.searle [at] gmail> wrote:
>> This will teach me... I have messed up my FE/BE setup by thinking I
>> could set up a static IP address on the box and putting that address in
>> the backend general settings page. The FE wouldn't then run so I set
>> about trying to go back, and have the local backend and master backend
>> both as 127.0.0.1 in the BE general settings screen.
>
> This works but you will be sorry when you go to run a remote frontend.
>
> But in your present case your quickest fix is to set the backend back
> to 127.0.0.1. Run mythtv-setup.
No idea why, but having them both as 127.0.0.1 just would not work (for
the FE connecting to the BE). And now with them set to the box's static
address, the FE is happy (whereas it wasn't previously). One of the
reasons I set it like this originally was for when I can have a separate
FE (at some point soon I hope). So I'm happy, and thanks for both the
replies.

Cheers,
Roger

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


tortise at paradise

Sep 18, 2011, 2:32 AM

Post #5 of 10 (1252 views)
Permalink
Re: local and master backend settings [In reply to]

On 18/09/2011 7:09 p.m., Roger Searle wrote:
> No idea why, but having them both as 127.0.0.1 just would not work (for
> the FE connecting to the BE). And now with them set to the box's static
> address, the FE is happy (whereas it wasn't previously).

I can probably answer that - the Frontend needs to know where to go to
connect to the Backend, Frontend needs to know Backend's IP
address...does that help? (Sending the Frontend to itself using
127.0.0.1 is going to fail cause its not the backend!)



_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


roger.searle at gmail

Sep 18, 2011, 3:46 AM

Post #6 of 10 (1251 views)
Permalink
Re: local and master backend settings [In reply to]

On 18/09/11 21:32, tortise wrote:
> On 18/09/2011 7:09 p.m., Roger Searle wrote:
>> No idea why, but having them both as 127.0.0.1 just would not work (for
>> the FE connecting to the BE). And now with them set to the box's static
>> address, the FE is happy (whereas it wasn't previously).
> I can probably answer that - the Frontend needs to know where to go to
> connect to the Backend, Frontend needs to know Backend's IP
> address...does that help? (Sending the Frontend to itself using
> 127.0.0.1 is going to fail cause its not the backend!)
>
I may have not been clear in what I was setting, I was referring to the
local and master server IP addresses as set on the backend. The
defaults are as per this:

http://www.mythtv.org/wiki/User_Manual:Detailed_configuration_Backend#Host_Address_Backend_Setup

Anyway, I've now got it set with the static IP address of the box, given
I intend having a separate front end at some point. I have EPG
populated again and some schedules set up, mythweb backend status is
telling me I have a scheduled programme recording right now, and I am
smiling :)

I'll be looking into sV's database backup comment when I have a chance,
I see there is a script, and I have the wiki page open in my browser for
reading asap...

Cheers,
Roger


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


nick.rout at gmail

Sep 18, 2011, 12:57 PM

Post #7 of 10 (1245 views)
Permalink
Re: local and master backend settings [In reply to]

On Sun, Sep 18, 2011 at 10:46 PM, Roger Searle <roger.searle [at] gmail> wrote:
> On 18/09/11 21:32, tortise wrote:
>> On 18/09/2011 7:09 p.m., Roger Searle wrote:
>>> No idea why, but having them both as 127.0.0.1 just would not work (for
>>> the FE connecting to the BE).  And now with them set to the box's static
>>> address, the FE is happy (whereas it wasn't previously).
>> I can probably answer that - the Frontend needs to know where to go to
>> connect to the Backend, Frontend needs to know Backend's IP
>> address...does that help?  (Sending the Frontend to itself using
>> 127.0.0.1 is going to fail cause its not the backend!)
>>
> I may have not been clear in what I was setting, I was referring to the
> local and master server IP addresses as set on the backend.  The
> defaults are as per this:
>
> http://www.mythtv.org/wiki/User_Manual:Detailed_configuration_Backend#Host_Address_Backend_Setup
>
> Anyway, I've now got it set with the static IP address of the box, given
> I intend having a separate front end at some point.  I have EPG
> populated again and some schedules set up, mythweb backend status is
> telling me I have a scheduled programme recording right now, and I am
> smiling :)
>
> I'll be looking into sV's database backup comment when I have a chance,
> I see there is a script, and I have the wiki page open in my browser for
> reading asap...

if you are using mythbuntu it is backed up automatically out of a the
script /etc/cron.weekly/mythtv-database.

I move mine to /etc/cron.daily and bump the maximum to be held as two
weeks worth.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


dmoo1790 at ihug

Sep 18, 2011, 4:44 PM

Post #8 of 10 (1242 views)
Permalink
Re: local and master backend settings [In reply to]

On 18/09/11 22:46, Roger Searle wrote:
> On 18/09/11 21:32, tortise wrote:
>> On 18/09/2011 7:09 p.m., Roger Searle wrote:
>>> No idea why, but having them both as 127.0.0.1 just would not work (for
>>> the FE connecting to the BE). And now with them set to the box's static
>>> address, the FE is happy (whereas it wasn't previously).
>> I can probably answer that - the Frontend needs to know where to go to
>> connect to the Backend, Frontend needs to know Backend's IP
>> address...does that help? (Sending the Frontend to itself using
>> 127.0.0.1 is going to fail cause its not the backend!)
>>
> I may have not been clear in what I was setting, I was referring to the
> local and master server IP addresses as set on the backend. The
> defaults are as per this:
>
> http://www.mythtv.org/wiki/User_Manual:Detailed_configuration_Backend#Host_Address_Backend_Setup
>
> Anyway, I've now got it set with the static IP address of the box, given
> I intend having a separate front end at some point...

I'm running a combined FE/BE on the same box and using the loopback
address 127.0.0.1 for both MasterServerIP and BackendServerIP works fine
as you would expect it to for FE and BE on the _same_ machine.

I suspect Roger's problem using the loopback address might have been in
the FE config, not the BE config.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


david at daveshep

Sep 18, 2011, 8:48 PM

Post #9 of 10 (1239 views)
Permalink
Re: local and master backend settings [In reply to]

> On 18/09/11 22:46, Roger Searle wrote:
>> On 18/09/11 21:32, tortise wrote:
>>> On 18/09/2011 7:09 p.m., Roger Searle wrote:
>>>> No idea why, but having them both as 127.0.0.1 just would not work
>>>> (for
>>>> the FE connecting to the BE). And now with them set to the box's
>>>> static
>>>> address, the FE is happy (whereas it wasn't previously).
>>> I can probably answer that - the Frontend needs to know where to go to
>>> connect to the Backend, Frontend needs to know Backend's IP
>>> address...does that help? (Sending the Frontend to itself using
>>> 127.0.0.1 is going to fail cause its not the backend!)
>>>
>> I may have not been clear in what I was setting, I was referring to the
>> local and master server IP addresses as set on the backend. The
>> defaults are as per this:
>>
>> http://www.mythtv.org/wiki/User_Manual:Detailed_configuration_Backend#Host_Address_Backend_Setup
>>
>> Anyway, I've now got it set with the static IP address of the box, given
>> I intend having a separate front end at some point...
>
> I'm running a combined FE/BE on the same box and using the loopback
> address 127.0.0.1 for both MasterServerIP and BackendServerIP works fine
> as you would expect it to for FE and BE on the _same_ machine.
>
> I suspect Roger's problem using the loopback address might have been in
> the FE config, not the BE config.
>

I've got a combined FE/BE and two remote FEs. The FE/BE has a fixed IP
address which I enter in both fields in the backend. And I've found I've
got to set it the frontend also. You could also check the config files in
the ~/.mythtv directory, ones a .txt and ones a .xml file (sorry not in
front of system so can't be more specific)




_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


roger.searle at gmail

Sep 19, 2011, 12:25 PM

Post #10 of 10 (1232 views)
Permalink
Re: local and master backend settings [In reply to]

On 18/09/2011 7:09 p.m., Roger Searle wrote:
>>>> No idea why, but having them both as 127.0.0.1 just would not work (for
>>>> the FE connecting to the BE). And now with them set to the box's static
>>>> address, the FE is happy (whereas it wasn't previously).
>>> I can probably answer that - the Frontend needs to know where to go to
>>> connect to the Backend, Frontend needs to know Backend's IP
>>> address...does that help? (Sending the Frontend to itself using
>>> 127.0.0.1 is going to fail cause its not the backend!)
>>>
>> I may have not been clear in what I was setting, I was referring to the
>> local and master server IP addresses as set on the backend. The
>> defaults are as per this:
>>
>> http://www.mythtv.org/wiki/User_Manual:Detailed_configuration_Backend#Host_Address_Backend_Setup
>>
>> Anyway, I've now got it set with the static IP address of the box, given
>> I intend having a separate front end at some point...
> I'm running a combined FE/BE on the same box and using the loopback
> address 127.0.0.1 for both MasterServerIP and BackendServerIP works fine
> as you would expect it to for FE and BE on the _same_ machine.
>
> I suspect Roger's problem using the loopback address might have been in
> the FE config, not the BE config.
Such was my learning curve (I'm still in week 1 using mythtv) I didn't
even realise then that there was also such a setting in the FE. It is
currently 127.0.0.1. Given things work now I'm reluctant to mess with
it, though this seems simple enough to try. Still, for what ever
reason, when BE Master and Backend were both 127.0.0.1, was no go. I
suspect I would have seen something different in mysql had I looked in
the settings table. Before I needed to go there, and with the box's
static address set in the BE, it's operational again.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.