Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Mythtvnz

MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel

 

 

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded


drtimlockyer at gmail

Aug 18, 2011, 3:49 PM

Post #1 of 11 (1201 views)
Permalink
MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel

MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel



Up to last Saturday had a perfectly working Mythbuntu 10.10. In a moment of
insanity I decided to upgrade to 11.04.



From that point on the MCEUSB IR Blaster stopped working. After trying a
number of solutions I finally did a fresh installation of Mythbuntu 11.04 -
still no luck.



irsend -d /dev/lircd SEND_ONCE sky 1 works perfectly (Note this is a New
Zealand Sky box)

/usr/share/lirc/extras/transmitters/sky/general.conf 01 does not work and
produces a page of errors saying that says in part:



… line 13: begin: command not found

… Line 15: name: Command not found

… Line 16: bit command not found

… Line 17: CONST_LENGTH: command not found



After many hours of reading it seems like the MCEUSB is now part of the
Kernel and that there are two instances running at the same time. And
because the two are running it is causing a conflict.



This seems evident by entering the following in the terminal:



$ irsend LIST “” “”

Sky

mceusb



I have found some information on turning off one
http://ubuntuforums.org/archive/index.php/t-1594799.html but it is too
complex for me to follow all of the steps, and I do not want to try
something and have to install everything again. Or even go back to Ubuntu
10.10.



My questions are:



Does it look like I have correctly identified the problem?

Has anyone got basic instructions on turning one off?

If I keep the Kernel mceusb where do I put the general.conf? (This is
necessary for the New Zealand Box)


ross at inertia

Aug 18, 2011, 5:16 PM

Post #2 of 11 (1152 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

> From that point on the MCEUSB IR Blaster stopped working. After
> trying
> a number of solutions I finally did a fresh installation of Mythbuntu
> 11.04 - still no luck.

I had huge issues with IR in general after upgrading to 11.04 (actually
a fresh copy). It would respond to the MCEUSB remote but completely
stopped receiving IR commands for any other remote (important as I also
use it as an IR sender to equipment in another building). IR blasting
appeared to work however.

irw failed to see any of the keypresses. I fiddled with config and
kernel modules and settings and lirc versions for about 6 hours before
giving up and going back to 10.10 with latest mythtv ppa. The same
config on there worked perfectly, first time.

They appear to have done significant work to how IR works in the latest
kernel and I would suspect this is the reason.

Sorry I can't be of more help, but I've been there and it is somewhat
fresh in my memory as being a very painful experience. I'll be very
interested if you find a solution as obviously I can't stay on old
versions forever.

Ross

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


lockyer at waikato

Aug 18, 2011, 5:23 PM

Post #3 of 11 (1143 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

Ross

Thanks - I am thinking of going back to 10.10 - but it is such a lot of
work.

Tim

On 19 August 2011 12:16, Ross Williamson <ross [at] inertia> wrote:

> > From that point on the MCEUSB IR Blaster stopped working. After
> > trying
> > a number of solutions I finally did a fresh installation of Mythbuntu
> > 11.04 - still no luck.
>
> I had huge issues with IR in general after upgrading to 11.04 (actually
> a fresh copy). It would respond to the MCEUSB remote but completely
> stopped receiving IR commands for any other remote (important as I also
> use it as an IR sender to equipment in another building). IR blasting
> appeared to work however.
>
> irw failed to see any of the keypresses. I fiddled with config and
> kernel modules and settings and lirc versions for about 6 hours before
> giving up and going back to 10.10 with latest mythtv ppa. The same
> config on there worked perfectly, first time.
>
> They appear to have done significant work to how IR works in the latest
> kernel and I would suspect this is the reason.
>
> Sorry I can't be of more help, but I've been there and it is somewhat
> fresh in my memory as being a very painful experience. I'll be very
> interested if you find a solution as obviously I can't stay on old
> versions forever.
>
> Ross
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>



--
Dr Tim Lockyer
Department of Tourism and Hospitality Management
University of Waikato
+64 7 838 4466 Ext 6321


worik.stanton at gmail

Aug 18, 2011, 5:38 PM

Post #4 of 11 (1148 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

I have been extremely dissatisfied with Ubuntu 11.04. I have to use it
for my new laptop for the drivers, but I do not use it for my MythTV box
(I use whatever the last one was, MythBuntu 10.10 I think). Canonical
is going in unfortunate directions, IMO.

Sorry to be unhelpful. But if you can, use 10.10

cheers
Worik

On 19/08/11 10:49, tim Lockyer wrote:
>
> MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel
>
> Up to last Saturday had a perfectly working Mythbuntu 10.10. In a
> moment of insanity I decided to upgrade to 11.04.
>
> From that point on the MCEUSB IR Blaster stopped working. After trying
> a number of solutions I finally did a fresh installation of Mythbuntu
> 11.04 - still no luck.
>
> irsend -d /dev/lircd SEND_ONCE sky 1works perfectly (Note this is a
> New Zealand Sky box)
>
> /usr/share/lirc/extras/transmitters/sky/general.conf 01 does not work
> and produces a page of errors saying that says in part:
>
> … line 13: begin: command not found
>
> … Line 15: name: Command not found
>
> … Line 16: bit command not found
>
> … Line 17: CONST_LENGTH: command not found
>
> After many hours of reading it seems like the MCEUSB is now part of
> the Kernel and that there are two instances running at the same time.
> And because the two are running it is causing a conflict.
>
> This seems evident by entering the following in the terminal:
>
> $ irsend LIST “” “”
>
> Sky
>
> mceusb
>
> I have found some information on turning off one
> http://ubuntuforums.org/archive/index.php/t-1594799.htmlbut it is too
> complex for me to follow all of the steps, and I do not want to try
> something and have to install everything again. Or even go back to
> Ubuntu 10.10.
>
> My questions are:
>
> Does it look like I have correctly identified the problem?
>
> Has anyone got basic instructions on turning one off?
>
> If I keep the Kernel mceusb where do I put the general.conf? (This is
> necessary for the New Zealand Box)
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


--
The hippies were right


stephen_agent at jsw

Aug 18, 2011, 6:40 PM

Post #5 of 11 (1147 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

On Fri, 19 Aug 2011 10:49:30 +1200, you wrote:

>MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel
>
>
>
>Up to last Saturday had a perfectly working Mythbuntu 10.10. In a moment of
>insanity I decided to upgrade to 11.04.
>
>
>
>From that point on the MCEUSB IR Blaster stopped working. After trying a
>number of solutions I finally did a fresh installation of Mythbuntu 11.04 -
>still no luck.
>
>
>
>irsend -d /dev/lircd SEND_ONCE sky 1 works perfectly (Note this is a New
>Zealand Sky box)
>
>/usr/share/lirc/extras/transmitters/sky/general.conf 01 does not work and
>produces a page of errors saying that says in part:
>
>
>
>… line 13: begin: command not found
>
>… Line 15: name: Command not found
>
>… Line 16: bit command not found
>
>… Line 17: CONST_LENGTH: command not found
>
>
>
>After many hours of reading it seems like the MCEUSB is now part of the
>Kernel and that there are two instances running at the same time. And
>because the two are running it is causing a conflict.
>
>
>
>This seems evident by entering the following in the terminal:
>
>
>
>$ irsend LIST “” “”
>
> Sky
>
> mceusb
>
>
>
>I have found some information on turning off one
>http://ubuntuforums.org/archive/index.php/t-1594799.html but it is too
>complex for me to follow all of the steps, and I do not want to try
>something and have to install everything again. Or even go back to Ubuntu
>10.10.
>
>
>
>My questions are:
>
>
>
>Does it look like I have correctly identified the problem?
>
>Has anyone got basic instructions on turning one off?
>
>If I keep the Kernel mceusb where do I put the general.conf? (This is
>necessary for the New Zealand Box)

I am using 11.04 (clean install), but I never had any problems with my
MCEUSB ir blaster other than having to install the Sky configuration.
I did that by copying my 10.04 working general.conf to:

/usr/share/lirc/extras/transmitters/skynz

and then adding it to the list of supported hardware in:

/usr/share/lirc/extras/transmitter.hwdb

like this:

[SkyTV New Zealand]
Serial Port (UART) : SkyTV New Zealand;serial;lirc_dev
lirc_serial;hw_default;skynz/general.conf
Microsoft Windows Media Center V2 (usb) : SkyTV New
Zealand;none;lirc_dev mceusb;hw_default;skynz/general.conf
Command IR : Sky Satellite Receiver;none;lirc_dev
lirc_cmdir;hw_default;skynz/general.conf
USB-UIRT2 : SkyTV New
Zealand;uirt2_raw;none;hw_uirt2_raw;skynz/general.conf


Then I used the Mythbuntu Control Centre to add Sky as an IR
transmitter.

I have only one lircd running. As best I can tell, it is still run
from /etc/init.d/lirc - I checked the initctl list output and there is
no lirc support there yet.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


drtimlockyer at gmail

Aug 18, 2011, 10:41 PM

Post #6 of 11 (1132 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

Thanks for the suggestions. Nothing seemed to work. I then installed 10.10
exactly the same problem irsend LIST shows Sky and mceusb. Do I have to go
back to 10.04? Plus I now have an error saying that the database I restored
has a newer TV schema than expected.

Tim

On Fri, Aug 19, 2011 at 12:16 PM, Ross Williamson <ross [at] inertia>wrote:

> > From that point on the MCEUSB IR Blaster stopped working. After
> > trying
> > a number of solutions I finally did a fresh installation of Mythbuntu
> > 11.04 - still no luck.
>
> I had huge issues with IR in general after upgrading to 11.04 (actually
> a fresh copy). It would respond to the MCEUSB remote but completely
> stopped receiving IR commands for any other remote (important as I also
> use it as an IR sender to equipment in another building). IR blasting
> appeared to work however.
>
> irw failed to see any of the keypresses. I fiddled with config and
> kernel modules and settings and lirc versions for about 6 hours before
> giving up and going back to 10.10 with latest mythtv ppa. The same
> config on there worked perfectly, first time.
>
> They appear to have done significant work to how IR works in the latest
> kernel and I would suspect this is the reason.
>
> Sorry I can't be of more help, but I've been there and it is somewhat
> fresh in my memory as being a very painful experience. I'll be very
> interested if you find a solution as obviously I can't stay on old
> versions forever.
>
> Ross
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>


stephen_agent at jsw

Aug 18, 2011, 10:58 PM

Post #7 of 11 (1134 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

On Fri, 19 Aug 2011 17:41:21 +1200, you wrote:

>Thanks for the suggestions. Nothing seemed to work. I then installed 10.10
>exactly the same problem irsend LIST shows Sky and mceusb. Do I have to go
>back to 10.04? Plus I now have an error saying that the database I restored
>has a newer TV schema than expected.
>
>Tim

You will need to update the MythTV version on 10.10 or 10.04 to 0.24.1
to get your database to work. To do that, you need to install the
Mythbuntu-repos package and then run an update.

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


drtimlockyer at gmail

Aug 21, 2011, 2:23 PM

Post #8 of 11 (1107 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

Thank you for your very helpful response. I first installed 10.10 and the
MCEUSB did not work. I then installed 10.04 and it worked perfectly and I
was back where I was a week ago. It was really helpful to know about the
Mythbuntu-repos I had not realised that you could update Mythtv without
updating Mythbuntu. After updating mythtv to .24 I was able to load my
database. This whole exercise has probably used about 30 or 40 hours – it is
a great shame that Mythbuntu should make such a major change to the kernel
so that it has such an impact on users. If I knew how to contact them I
would email them to tell them the problem they have caused (probably they
would not be interested). Well the time is not all lost, I now know a lot
more about Mythbuntu than I knew before

I did want to thank whoever wrote epgsnoop it is so good. I would be happy
to make a donation if there was a way to do it.

Tim


On Fri, Aug 19, 2011 at 5:58 PM, Stephen Worthington <
stephen_agent [at] jsw> wrote:

> On Fri, 19 Aug 2011 17:41:21 +1200, you wrote:
>
> >Thanks for the suggestions. Nothing seemed to work. I then installed 10.10
> >exactly the same problem irsend LIST shows Sky and mceusb. Do I have to go
> >back to 10.04? Plus I now have an error saying that the database I
> restored
> >has a newer TV schema than expected.
> >
> >Tim
>
> You will need to update the MythTV version on 10.10 or 10.04 to 0.24.1
> to get your database to work. To do that, you need to install the
> Mythbuntu-repos package and then run an update.
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>


nick.rout at gmail

Aug 22, 2011, 1:02 PM

Post #9 of 11 (1095 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

On Mon, Aug 22, 2011 at 9:23 AM, tim Lockyer <drtimlockyer [at] gmail> wrote:
> Thank you for your very helpful response. I first installed 10.10 and the
> MCEUSB did not work. I then installed 10.04 and it worked perfectly and I
> was back where I was a week ago. It was really helpful to know about the
> Mythbuntu-repos I had not realised that you could update Mythtv without
> updating Mythbuntu. After updating mythtv to .24 I was able to load my
> database. This whole exercise has probably used about 30 or 40 hours – it is
> a great shame that Mythbuntu should make such a major change to the kernel
> so that it has such an impact on users. If I knew how to contact them I
> would email them to tell them the problem they have caused (probably they
> would not be interested).

Its the "ubuntu" kernel, not the "mythbuntu" kernel. Perhaps you
should email linus torvalkds :)

>Well the time is not all lost, I now know a lot
> more about Mythbuntu than I knew before
>
> I did want to thank whoever wrote epgsnoop it is so good. I would be happy
> to make a donation if there was a way to do it.
>
> Tim
>
>
> On Fri, Aug 19, 2011 at 5:58 PM, Stephen Worthington
> <stephen_agent [at] jsw> wrote:
>>
>> On Fri, 19 Aug 2011 17:41:21 +1200, you wrote:
>>
>> >Thanks for the suggestions. Nothing seemed to work. I then installed
>> > 10.10
>> >exactly the same problem irsend LIST shows Sky and mceusb. Do I have to
>> > go
>> >back to 10.04? Plus I now have an error saying that the database I
>> > restored
>> >has a newer TV schema than expected.
>> >
>> >Tim
>>
>> You will need to update the MythTV version on 10.10 or 10.04 to 0.24.1
>> to get your database to work.  To do that, you need to install the
>> Mythbuntu-repos package and then run an update.
>>
>> _______________________________________________
>> mythtvnz mailing list
>> mythtvnz [at] lists
>> http://lists.ourshack.com/mailman/listinfo/mythtvnz
>> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>
>

_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


worik.stanton at gmail

Aug 25, 2011, 4:40 PM

Post #10 of 11 (1072 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

On 23/08/11 08:02, Nick Rout wrote:
> Its the "ubuntu" kernel, not the "mythbuntu" kernel. Perhaps you
> should email linus torvalkds:)
That would be the Linux kernel....

W

--
The hippies were right


_______________________________________________
mythtvnz mailing list
mythtvnz [at] lists
http://lists.ourshack.com/mailman/listinfo/mythtvnz
Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/


drtimlockyer at gmail

Aug 25, 2011, 5:08 PM

Post #11 of 11 (1079 views)
Permalink
Re: MCEUSB IR Blaster problem after upgrade to Mythbuntu 11.04 and Kernel [In reply to]

Today I ordered a USB IR Transceiver from
http://iguanaworks.net/product1.psp. They guarantee it will work with
Mythbuntu 11.04. It is not very expensive the CommandIR is about twice the
cost. Once I receive it I will post a review.

Tim

On Fri, Aug 26, 2011 at 11:40 AM, Worik Stanton <worik.stanton [at] gmail>wrote:

> On 23/08/11 08:02, Nick Rout wrote:
> > Its the "ubuntu" kernel, not the "mythbuntu" kernel. Perhaps you
> > should email linus torvalkds:)
> That would be the Linux kernel....
>
> W
>
> --
> The hippies were right
>
>
> _______________________________________________
> mythtvnz mailing list
> mythtvnz [at] lists
> http://lists.ourshack.com/mailman/listinfo/mythtvnz
> Archives http://www.gossamer-threads.com/lists/mythtv/mythtvnz/
>

MythTV mythtvnz RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.