Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Dev
Problem changing channels after upgrade to 0.25
 

Index | Next | Previous | View Flat


lists at bibleboy

Jan 24, 2012, 5:51 PM


Views: 1026
Permalink
Problem changing channels after upgrade to 0.25

I recently upgraded my Mythbuntu system to 11.10 and just last night I
decided to upgrade to the 0.25 branch using mythbuntu-repos (see below
for more information on versions, etc). Since the upgrade I have not
been able to change channels from one tuner to the same tuner which is
connected to a Dish Network receiver. When I attempt to do so the
system hangs for about 10-30 seconds and then usually returns back to
the main menu with "Error opening jump program file". This happens
every single time that I switch a channel from dish network to another
dish network channel. I also have 2 tuners connected to analog cable
and if I first switch to a channel from that source and then switch back
to a dish network channel everything works fine. In order to rule out a
delay in signal lock because of the receiver needing to change channels
I disabled the change channel script so that the receiver was constantly
broadcasting out of the composite display and this made no difference.

I have been doing a lot of searching and googling and I'm wondering if
this is related to this change:
https://github.com/MythTV/mythtv/commit/4e8d935

From what I have been seeing there have been people that experienced
this issue with earlier versions of myth but never with 0.24 with the
exception of 0.24-fixes. My assumption is that this change was back
ported to 0.24. I also saw that in 0.22 the ringbuffer was changed to
10 seconds rather than the 2 seconds. My thoughts are that prior to
upgrading to 0.25 when changing a channel my system was taking longer
than 2 seconds to start writing the mpg file to disk but since the
timeout was 10 seconds this wasn't an issue but now it is becoming an
issue. I will admit I'm not a developer so I may be way off base but I
wanted to get some feedback on this issue before filing a bug report (if
that becomes required), etc.

System information:
2 front ends, 1 backend
Backend machine is a dual CPU AMD Opteron system with 8GB of RAM
(running 32bit) and is running Mythbuntu 11.10. Machine has 3 PCI
PVR-150 tuner cards installed (one is connected to a dish network
receiver and 2 others connected to analog cable). Hard drives are all
on a 3ware RAID controller with multiple RAID arrays configured (2 are
recordings directories and each of those are on their own dedicated
array). Both front end machines are Dell Pentium 4 systems. One has a
Nvidia GeForce 6200 and the other has an older Nvidia card. Both front
end machines are connected via 10/100 ethernet.

I can gather up applicable log files but I wanted to get an initial
opinion from the developer community and possibly get better direction
as to which log files I need to pay attention to.

Backend version:
Please attach all output as a file in bug reports.
MythTV Version : v0.25pre-4084-g867d96a
MythTV Branch : master
Network Protocol : 71
Library API : 0.25.20120120-1
QT Version : 4.7.4
Options compiled in:
linux profile use_hidesyms using_alsa using_oss using_pulse
using_pulseoutput using_backend using_bindings_perl
using_bindings_python using_bindings_php using_crystalhd using_dvb
using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr
using_iptv using_ivtv using_joystick_menu using_lirc using_mheg
using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2
using_x11 using_xrandr using_xv using_bindings_perl
using_bindings_python using_bindings_php using_mythtranscode
using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live
using_mheg

Frontend version:
Please attach all output as a file in bug reports.
MythTV Version : v0.25pre-4084-g867d96a
MythTV Branch : master
Network Protocol : 71
Library API : 0.25.20120120-1
QT Version : 4.7.4
Options compiled in:
linux profile use_hidesyms using_alsa using_oss using_pulse
using_pulseoutput using_backend using_bindings_perl
using_bindings_python using_bindings_php using_crystalhd using_dvb
using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr
using_iptv using_ivtv using_joystick_menu using_lirc using_mheg
using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2
using_x11 using_xrandr using_xv using_bindings_perl
using_bindings_python using_bindings_php using_mythtranscode
using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live
using_mheg


_______________________________________________
mythtv-dev mailing list
mythtv-dev [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-dev

Subject User Time
Problem changing channels after upgrade to 0.25 lists at bibleboy Jan 24, 2012, 5:51 PM
    Re: Problem changing channels after upgrade to 0.25 simon at koala Jan 25, 2012, 3:40 AM
        Re: Problem changing channels after upgrade to 0.25 (#9830) lists at bibleboy Jan 26, 2012, 2:11 PM

  Index | Next | Previous | View Flat
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.