Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Commits

Ticket #10642: Audio stops/starts/seeks a second after video

 

 

MythTV commits RSS feed   Index | Next | Previous | View Threaded


noreply at mythtv

Apr 22, 2012, 1:19 AM

Post #1 of 8 (200 views)
Permalink
Ticket #10642: Audio stops/starts/seeks a second after video

#10642: Audio stops/starts/seeks a second after video
------------------------------------+--------------------------------------
Reporter: Josh Triplett <josh@…> | Type: Bug Report - General
Status: new | Priority: major
Milestone: unknown | Component: MythTV - General
Version: 0.25 | Severity: medium
Keywords: | Ticket locked: 0
------------------------------------+--------------------------------------
In 0.25, when pausing, unpausing, or seeking in a recorded show or live
TV, the video pauses/unpauses/seeks instantly, but the audio takes a
second or so. This proves particularly problematic when unpausing or
seeking, because it effectively leaves the video muted for the first
second or so, causing users to have to rewind a bit to hear the audio.

I did not observe this problem in 0.22.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 7:38 AM

Post #2 of 8 (175 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+-------------------------
Reporter: Josh Triplett <josh@…> | Owner:
Type: Bug Report - General | Status: new
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
------------------------------------+-------------------------

Comment (by jyavenard):

Are you using HDMI?

HDMI can take a little,while to get a lock on. Especially when using
digital audio

Nothing to do with myth, and all to do with the amplifier used.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:1>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 7:39 AM

Post #3 of 8 (172 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+---------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: assigned
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
------------------------------------+---------------------------
Changes (by jyavenard):

* owner: => jyavenard
* status: new => assigned


--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:2>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 12:46 PM

Post #4 of 8 (172 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+---------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: assigned
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
------------------------------------+---------------------------

Comment (by Josh Triplett <josh@…>):

No. This occurs both on laptops (with built-in video and audio) and on
dedicated MythTV frontends (using VGA/DVI and a separate headphone-style
audio cable). This represents a regression from 0.22, which
paused/resumed/seeked audio in sync with video.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:3>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 3:03 PM

Post #5 of 8 (170 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+----------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: infoneeded
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
------------------------------------+----------------------------
Changes (by jyavenard):

* status: assigned => infoneeded


Comment:

So please provide details.. Audio settings, version of myth used, computer
used.

I certainly have never seen this on any of my machines, and you would
think that if it was a global issue, we would have heard about it.

0.22 was released a very long time ago... so whatever it did is of little
relevance. I doubt you are running the same hardware/OS as you did when
you were using 0.22

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:4>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 3:27 PM

Post #6 of 8 (167 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+----------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: infoneeded
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution:
Keywords: | Ticket locked: 0
------------------------------------+----------------------------

Comment (by Josh Triplett <josh@…>):

> So please provide details.. Audio settings, version of myth used,
computer used.

Audio settings: ALSA:default and the stock MythTV defaults. I've tested
with a completely fresh set of client settings and still encountered the
problem.

MythTV 0.25.

Client: ThinkPad X220, ThinkPad T42, custom frontend with an Intel
D945GSEJT Atom board, take your pick. They all have some variation of an
Intel HDA audio chipset.

> I certainly have never seen this on any of my machines, and you would
think that if it was a global issue, we would have heard about it.

This represents a subtle issue; if you didn't otherwise have reason to pay
close attention to the audio, you could easily not notice it. You'll
notice it more easily if it takes your setup a longer time to seek, pause,
or unpause. Effectively, the video starts changing immediately, but the
audio doesn't switch over until after the video finishes changing. So,
however long it takes to seek, the audio that would have played if you
hadn't seeked will play while you seek. In former versions of MythTV, the
audio would instead immediately stop playing while the operation happened,
and start back up again with the correct audio after the operation
finishes.

> I doubt you are running the same hardware/OS as you did when you were
using 0.22

Exactly the same hardware; OS upgraded from Debian 5 to Debian 6.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:5>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 4:12 PM

Post #7 of 8 (165 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+---------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: closed
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution: Won't Fix
Keywords: | Ticket locked: 0
------------------------------------+---------------------------
Changes (by jyavenard):

* status: infoneeded => closed
* resolution: => Won't Fix


Comment:

I see...

We add to reset the audio buffer as otherwise, audio corruption could
occur under some circumstances...

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:6>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Jun 17, 2012, 6:26 PM

Post #8 of 8 (166 views)
Permalink
Re: Ticket #10642: Audio stops/starts/seeks a second after video [In reply to]

#10642: Audio stops/starts/seeks a second after video
------------------------------------+---------------------------
Reporter: Josh Triplett <josh@…> | Owner: jyavenard
Type: Bug Report - General | Status: closed
Priority: major | Milestone: unknown
Component: MythTV - General | Version: 0.25
Severity: medium | Resolution: Won't Fix
Keywords: | Ticket locked: 0
------------------------------------+---------------------------

Comment (by Josh Triplett <josh@…>):

Sure, that makes sense. However, could you mute the audio at the start of
an operation, and unmute it afterward? Or, could you avoid transitioning
the video until the audio had finished transitioning? The oddity occurs
because the audio and video transitions occur at noticeably different
times.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10642#comment:7>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits

MythTV commits RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.