Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Commits

Ticket #10609: xv-blit video playback setting results in green purple tine

 

 

MythTV commits RSS feed   Index | Next | Previous | View Threaded


noreply at mythtv

Apr 15, 2012, 8:34 PM

Post #1 of 12 (320 views)
Permalink
Ticket #10609: xv-blit video playback setting results in green purple tine

#10609: xv-blit video playback setting results in green purple tine
-----------------------------+--------------------------------------
Reporter: spamoften2008@… | Type: Bug Report - General
Status: new | Priority: major
Milestone: 0.25.1 | Component: MythTV - General
Version: 0.25-fixes | Severity: medium
Keywords: xv-blit | Ticket locked: 0
-----------------------------+--------------------------------------
Since upgrading to mythtv 0.25, the xv-blit video setting shows incorrect
hues.
Upgraded Unbuntu 10.04 to 12.04
Upgraded MythTv 0.24 to 0.25


Mplayer configured to use xv-blit on the exact same videos shows proper
color.

This is almost certainly due to a colorspace conversion problem in the
default internal mythtv player.

The issue happens for recordings (720p, 1080i), and videos (xvid, mp4).

Using stock linux driver for
Video hardware (LSPCI output):
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS480
[Radeon Xpress 200G Series]

Prior to my upgrade, video was perfect for 2 years...

The workaround to use opengl does not work as mythfrontend hangs and then
comes back in a few minutes saying that it could not initialize video.

Workaround to use xshm results in stuttered video that is not acceptable,
and uses all CPU on the system.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Apr 18, 2012, 3:06 PM

Post #2 of 12 (304 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
----------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: new
Priority: major | Milestone: 0.25.1
Component: MythTV - General | Version: 0.25-fixes
Severity: medium | Resolution:
Keywords: xv-blit | Ticket locked: 0
----------------------------------+----------------------------

Comment (by spamoften2008@…):

Rebuilt from Mythbuntu 11.10 and then upgraded to myth 0.25 repository.
Problem no longer exists.
I will not be upgrading to ubuntu 12.04 as I am concerned the issue is
linux kernel / driver related.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:1>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

Apr 20, 2012, 2:49 PM

Post #3 of 12 (301 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Invalid
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+----------------------------
Changes (by danielk):

* priority: major => minor
* resolution: => Invalid
* status: new => closed
* component: MythTV - General => MythTV - Video Playback
* severity: medium => low


Comment:

Closing as invalid as reporter is not going to reproduce. If someone else
has this problem please reopen.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:2>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 3, 2012, 12:49 AM

Post #4 of 12 (278 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: new
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution:
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+----------------------------
Changes (by simons.philippe@…):

* status: closed => new
* resolution: Invalid =>


Comment:

having the same issue

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:3>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 3, 2012, 11:42 AM

Post #5 of 12 (277 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+--------------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution:
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+--------------------------------
Changes (by danielk):

* status: new => infoneeded_new


Comment:

Simons, please attach the output of xvinfo and a log from "mythfrontend -v
playback" from the playback of a short clip.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:4>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 3, 2012, 5:19 PM

Post #6 of 12 (282 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+--------------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution:
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+--------------------------------

Comment (by mdean):

Please also attach a file with the output of:

mythfrontend --version > $HOME/mythfrontend_version.txt 2>&1

This may have been fixed by b2657a1a3f8a

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:5>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 5, 2012, 11:31 AM

Post #7 of 12 (277 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+--------------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: infoneeded_new
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution:
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+--------------------------------

Comment (by simons.philippe@…):

looks like I found what's happening

mythtv is setting the XV_HUE attribute to -1000 (which correspond to 0% in
the Internal player)
when setting the Hue to 50% in the Internal player, XV_HUE attribute is
set back to 0 and colors are corrects.

and yes looks like my build is previous to b2657a1a3f8a

you can close this one for me.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:6>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 5, 2012, 11:40 AM

Post #8 of 12 (278 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Fixed
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+----------------------------
Changes (by wagnerrp):

* status: infoneeded_new => closed
* resolution: => Fixed


--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:7>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 25, 2012, 12:37 AM

Post #9 of 12 (257 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Fixed
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+----------------------------

Comment (by micha@…):

It seems I do have this problem. Could this please be backported to the
0.25/fixes branch?

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:8>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 30, 2012, 8:04 AM

Post #10 of 12 (249 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Fixed
Keywords: xv-blit | Ticket locked: 0
-------------------------------------+----------------------------

Comment (by ted@…):

A quick workaround for anyone else who has the problem is during playback
hit the F key to cycle thru video controls until you get to HUE (it will
be set to 0%, if you have the problem) then set it to 50%, with the arrow
keys. When I did this the current OSD didn't indicate which setting I was
adjusting I just kept hitting F until it showed one at 0%.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:9>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 30, 2012, 8:19 AM

Post #11 of 12 (252 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Fixed
Keywords: xv-blit | Ticket locked: 1
-------------------------------------+----------------------------
Changes (by mdean):

* mlocked: 0 => 1


Comment:

Both b2657a1a3f8a (via 0f8476995f ) and 0c00c0ac9 (via 2e7722d43 ) are in
0.25-fixes. Anyone who is seeing this issue should update to current
0.25-fixes, but may still need to fix old/broken values for the settings
using the Playback Picture Controls UI (hit F during playback), as
described.

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:10>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits


noreply at mythtv

May 30, 2012, 11:33 AM

Post #12 of 12 (253 views)
Permalink
Re: Ticket #10609: xv-blit video playback setting results in green purple tine [In reply to]

#10609: xv-blit video playback setting results in green purple tine
-------------------------------------+----------------------------
Reporter: spamoften2008@… | Owner:
Type: Bug Report - General | Status: closed
Priority: minor | Milestone: 0.25.1
Component: MythTV - Video Playback | Version: 0.25-fixes
Severity: low | Resolution: Fixed
Keywords: xv-blit | Ticket locked: 1
-------------------------------------+----------------------------

Comment (by stuartm):

Picture controls are accessible via the OSD menu as well:

Menu > Video > Adjust Picture > Hue

--
Ticket URL: <http://code.mythtv.org/trac/ticket/10609#comment:11>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center
_______________________________________________
mythtv-commits mailing list
mythtv-commits [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-commits

MythTV commits RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.