Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: ModPerl: ModPerl

Cannot get mod_perl 2.0.6 to compile with apache 2.2.22 under perl 5.16.0

 

 

ModPerl modperl RSS feed   Index | Next | Previous | View Threaded


dhunt at ucar

May 29, 2012, 11:07 AM

Post #1 of 3 (608 views)
Permalink
Cannot get mod_perl 2.0.6 to compile with apache 2.2.22 under perl 5.16.0

Hi mod_perl list!

I've been using Apache and mod_perl for a long time on our web site, but
I'm having troubles getting it to compile under the most recent Apache,
mod_perl and perl.

I'm working under CentOS 6.2 on an x86_64 system.

I'm trying to do a static Apache/mod_perl compile:

-----------------------------------------------------------------------------
tar -xvzf mod_perl-2.0.6.tar.gz
tar -xvzf httpd-2.2.22.tar.gz
cd httpd-2.2.22
./configure --with-mpm=prefork --prefix=/path/to/install/apache --with-included-apr
make
make install
cd ../mod_perl-2.0.6
perl Makefile.PL PREFIX=/path/to/install MP_APXS=/path/to/install/apache/bin/apxs
make
-------------------------------------------------------------------------------

This is about the 10th combination of compiling apache, apr, apr_util,
and mod_perl I've tried!

This recipe leads me to this error, which seems to concern perl internals:

------------------------------------------------------------------------

...

cc -I/home/rpmbuild/rpm/BUILD/mod_perl-2.0.6/src/modules/perl
-I/home/rpmbuild/rpm/BUILD/mod_perl-2.0.6/xs
-I/home/rpmbuild/rpm/aReallyLongNameForOps/tools/apache/include
-I/home/rpmbuild/rpm/aReallyLongNameForOps/tools/apache/include
-I/home/rpmbuild/rpm/aReallyLongNameForOps/tools/apache/include
-DPERL_RELOCATABLE_INCPUSH -fno-strict-aliasing -pipe -fstack-protector
-I/usr/local/include
-I/home/rpmbuild/rpm/aReallyLongNameForOps/tools/lib/perl5/5.16.0/x86_64-linux/CORE
-DMOD_PERL -DMP_COMPAT_1X -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -O2 -fPIC \
-c modperl_perl.c && mv modperl_perl.o modperl_perl.lo
modperl_perl.c: In function 'modperl_perl_init_ids':
modperl_perl.c:105: error: 'PL_uid' undeclared (first use in this
function)
modperl_perl.c:105: error: (Each undeclared identifier is reported only
once
modperl_perl.c:105: error: for each function it appears in.)
modperl_perl.c:106: error: 'PL_euid' undeclared (first use in this
function)
modperl_perl.c:107: error: 'PL_gid' undeclared (first use in this
function)
modperl_perl.c:108: error: 'PL_egid' undeclared (first use in this
function)
make[1]: *** [modperl_perl.lo] Error 1
make[1]: Leaving directory
`/home/rpmbuild/rpm/BUILD/mod_perl-2.0.6/src/modules/perl'
make: *** [modperl_lib] Error 2
--------------------------------------------------------------------------------

Any ideas or help would be appreciated!

Regards,

Doug Hunt

dhunt [at] ucar
Software Engineer
UCAR - COSMIC, Tel. (303) 497-2611


badalex at gmail

May 29, 2012, 12:36 PM

Post #2 of 3 (569 views)
Permalink
Re: Cannot get mod_perl 2.0.6 to compile with apache 2.2.22 under perl 5.16.0 [In reply to]

On Tue, May 29, 2012 at 12:07 PM, Doug Hunt <dhunt [at] ucar> wrote:
> Hi mod_perl list!
>
> I've been using Apache and mod_perl for a long time on our web site, but I'm
> having troubles getting it to compile under the most recent Apache, mod_perl
> and perl.
>
> I'm working under CentOS 6.2 on an x86_64 system.
>
> I'm trying to do a static Apache/mod_perl compile:

Try with this patch: https://rt.cpan.org/Public/Bug/Display.html?id=77129


dhunt at ucar

May 29, 2012, 1:31 PM

Post #3 of 3 (572 views)
Permalink
Re: Cannot get mod_perl 2.0.6 to compile with apache 2.2.22 under perl 5.16.0 [In reply to]

Thanks, Alex!

I figured that patch out separately by looking at perldelta for perl
5.16.0 right after I sent in the email. I've finally got mod_perl
to build, but I had to also apply another patch (attached) to get it to work.

There was a compile bug in modperl_exports.c in which
'modperl_thx_interp_set' and 'modperl_thx_interp_get' were not defined.
I had to apply a similar patch several years ago when I last upgraded my
mod_perl configuration.

Regards,

Doug Hunt

dhunt [at] ucar
Software Engineer
UCAR - COSMIC, Tel. (303) 497-2611

On Tue, 29 May 2012, Alex Hunsaker wrote:

> On Tue, May 29, 2012 at 12:07 PM, Doug Hunt <dhunt [at] ucar> wrote:
>> Hi mod_perl list!
>>
>> I've been using Apache and mod_perl for a long time on our web site, but I'm
>> having troubles getting it to compile under the most recent Apache, mod_perl
>> and perl.
>>
>> I'm working under CentOS 6.2 on an x86_64 system.
>>
>> I'm trying to do a static Apache/mod_perl compile:
>
> Try with this patch: https://rt.cpan.org/Public/Bug/Display.html?id=77129
>
Attachments: mod_perl_thx_interp_2012.patch (0.61 KB)

ModPerl modperl RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.