Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: ModPerl: Embperl

Installing Embperl 2.4 on Debian Squeeze

 

 

ModPerl embperl RSS feed   Index | Next | Previous | View Threaded


neil at nilspace

Mar 26, 2012, 11:04 AM

Post #1 of 8 (1112 views)
Permalink
Installing Embperl 2.4 on Debian Squeeze

I was not able to download from ftp://ftp.dev.ecos.de/pub/perl/embperl,
always seem to get network timeouts. So I downloaded instead from CPAN,
seems to be 2.4.

Building new workstation around Debian Squeeze, AMD64.

It compiles ok, but when I run make test, I get:

root [at] de:/usr/src/Embperl-2.4.0# make test
make[1]: Entering directory `/usr/src/Embperl-2.4.0/xs'
make[2]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
make[2]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl'
make[1]: Leaving directory `/usr/src/Embperl-2.4.0/xs'
PERL_DL_NONLAZY=0 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl

loading... Name "main::SAVEERR" used only once:
possible typo at test.pl line 1985.
ok

Testing offline mode...

#0 ascii... ok
#1 pure.htm... ok
#2 nooutput.htm... ok
#3 nooutput.htm... ok
#4 plain.htm... ok
#5 plain.htm... ok
#6 plain.htm... ok
#7 plainblock.htm... ok
#8 plainblock.htm... ok
#15 error.htm...

Expected 4 more error(s) in logfile


ERRORS detected! NOT all tests have been passed successfully

cat: test/tmp/httpd.pid: No such file or directory
make: *** [test_dynamic] Error 1
root [at] de:/usr/src/Embperl-2.4.0#

When I try make install just to see what happens, it puts everything
under /root for some reason, rather than in the perl lib directories:

root [at] de:/usr/src/Embperl-2.4.0# make install
make[1]: Entering directory `/usr/src/Embperl-2.4.0/xs'
make[2]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
make[4]: Entering directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
make[4]: Leaving directory
`/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
make[2]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl'
make[1]: Leaving directory `/usr/src/Embperl-2.4.0/xs'
Files found in blib/arch: installing files in blib/lib into architecture
dependent library tree
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/auto/Embperl/Embperl.so
Installing /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl.pod
Installing /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Faq.pod
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Mail.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Constant.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Log.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/App.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Inline.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/TOC.pod
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/TipsAndTricks.pod
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Out.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Object.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Util.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Run.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/EmbperlLibXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/EmbperlPODXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/LibXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/EmbperlXalanXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/XalanXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/XSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/EmbperlXSLT.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe/Embperl.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/Perl.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/Mail.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/HTML.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/SSI.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/ASP.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/MsgIdExtract.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/POD.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/Text.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/EmbperlBlocks.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/RTF.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax/Embperl.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/DataSource.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/ControlMultValue.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/TimeHHMM.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/Select.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/Integer.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/FQDN_IPAddr.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/Default.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/TimeHHMMSS.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/Number.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/IPAddr_Mask.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/EMail.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/EMailRFC.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Validate/IPAddr.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/addremove.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/inputlist.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/password.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/displaylink.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/selectdyn.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/textarea.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/dump.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/line.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/blank.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/datetime.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/price.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/file.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/checkboxes.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/radio.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/inputjoin.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/grid.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/input.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/mult.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/transparent.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/hidden.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/submit.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/display.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/number.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/info.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/select.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/label.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/scriptcode.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/tabs.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/duration.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/checkbox.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/table.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/button.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/tinymce.pm
Installing
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form/Control/show.pm
Installing /root/perl5/man/man1/embpmsgid.pl.1p
Installing /root/perl5/man/man1/embpexec.pl.1p
Installing /root/perl5/man/man3/Embperl.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::password.3pm
Installing /root/perl5/man/man3/Embperl::Features.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::displaylink.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::checkboxes.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::input.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::selectdyn.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::transparent.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::inputlist.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::submit.3pm
Installing /root/perl5/man/man3/Embperl::Form.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::button.3pm
Installing /root/perl5/man/man3/Embperl::Mail.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::Mail.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::label.3pm
Installing /root/perl5/man/man3/Embperl::Recipe::EmbperlXSLT.3pm
Installing /root/perl5/man/man3/Embperl::Faq.3pm
Installing /root/perl5/man/man3/Embperl::Recipe::XSLT.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::grid.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::hidden.3pm
Installing /root/perl5/man/man3/Embperl::Recipe::Embperl.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::Embperl.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::inputjoin.3pm
Installing /root/perl5/man/man3/Embperl::TipsAndTricks.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::mult.3pm
Installing /root/perl5/man/man3/Embperl::Form::DataSource.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::MsgIdExtract.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::ASP.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::table.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::file.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::tabs.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::info.3pm
Installing /root/perl5/man/man3/Embperl::Syntax.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::RTF.3pm
Installing /root/perl5/man/man3/Embperl::TOC.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::addremove.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::EmbperlHTML.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::EmbperlBlocks.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::price.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::textarea.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::datetime.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::display.3pm
Installing /root/perl5/man/man3/Embperl::Config.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::scriptcode.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::duration.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::tinymce.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::dump.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::checkbox.3pm
Installing /root/perl5/man/man3/Embperl::Object.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::Text.3pm
Installing /root/perl5/man/man3/IntroEmbperlObject.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::line.3pm
Installing /root/perl5/man/man3/Embperl::Form::ControlMultValue.3pm
Installing /root/perl5/man/man3/Embperl::Intro.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::blank.3pm
Installing /root/perl5/man/man3/Embperl::Form::Validate.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::show.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::POD.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::number.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::HTML.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::select.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::SSI.3pm
Installing /root/perl5/man/man3/Embperl::FeaturesD.3pm
Installing /root/perl5/man/man3/Embperl::Form::Control::radio.3pm
Installing /root/perl5/man/man3/Embperl::Syntax::Perl.3pm
Installing /root/perl5/man/man3/Embperl::Inline.3pm
Installing /root/perl5/man/man3/Embperl::SVN.3pm
Installing /root/perl5/man/man3/Embperl::Recipe.3pm
Installing /root/perl5/man/man3/Embperl::Session.3pm
Installing /root/perl5/man/man3/Embperl::App.3pm
Installing /root/perl5/bin/embpexec.pl
Installing /root/perl5/bin/embpmsgid.pl
Appending installation info to
/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/perllocal.pod

Any ideas how I can fix this?

Thanks,

Neil

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


richter at ecos

Mar 26, 2012, 11:53 AM

Post #2 of 8 (1050 views)
Permalink
RE: Installing Embperl 2.4 on Debian Squeeze [In reply to]

Hi Neil,

use www.embperl.org/downloads, but on CPAN it's the same version.

Which Perl Version you are using?

Gerald


> -----Original Message-----
> From: Neil Gunton [mailto:neil [at] nilspace]
> Sent: Monday, March 26, 2012 8:04 PM
> To: embperl [at] perl
> Subject: Installing Embperl 2.4 on Debian Squeeze
>
> I was not able to download from ftp://ftp.dev.ecos.de/pub/perl/embperl,
> always seem to get network timeouts. So I downloaded instead from CPAN,
> seems to be 2.4.
>
> Building new workstation around Debian Squeeze, AMD64.
>
> It compiles ok, but when I run make test, I get:
>
> root [at] de:/usr/src/Embperl-2.4.0# make test
> make[1]: Entering directory `/usr/src/Embperl-2.4.0/xs'
> make[2]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
> make[3]: Entering directory `/usr/src/Embperl-
> 2.4.0/xs/Embperl/Component'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
> make[2]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl'
> make[1]: Leaving directory `/usr/src/Embperl-2.4.0/xs'
> PERL_DL_NONLAZY=0 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
>
> loading... Name "main::SAVEERR" used only once:
> possible typo at test.pl line 1985.
> ok
>
> Testing offline mode...
>
> #0 ascii... ok
> #1 pure.htm... ok
> #2 nooutput.htm... ok
> #3 nooutput.htm... ok
> #4 plain.htm... ok
> #5 plain.htm... ok
> #6 plain.htm... ok
> #7 plainblock.htm... ok
> #8 plainblock.htm... ok
> #15 error.htm...
>
> Expected 4 more error(s) in logfile
>
>
> ERRORS detected! NOT all tests have been passed successfully
>
> cat: test/tmp/httpd.pid: No such file or directory
> make: *** [test_dynamic] Error 1
> root [at] de:/usr/src/Embperl-2.4.0#
>
> When I try make install just to see what happens, it puts everything under
> /root for some reason, rather than in the perl lib directories:
>
> root [at] de:/usr/src/Embperl-2.4.0# make install
> make[1]: Entering directory `/usr/src/Embperl-2.4.0/xs'
> make[2]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App/Config'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/App'
> make[3]: Entering directory `/usr/src/Embperl-
> 2.4.0/xs/Embperl/Component'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Config'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Output'
> make[4]: Entering directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.4.0/xs/Embperl/Component/Param'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Component'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Config'
> make[4]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
> make[4]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req/Param'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Req'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Syntax'
> make[3]: Entering directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
> make[3]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl/Thread'
> make[2]: Leaving directory `/usr/src/Embperl-2.4.0/xs/Embperl'
> make[1]: Leaving directory `/usr/src/Embperl-2.4.0/xs'
> Files found in blib/arch: installing files in blib/lib into architecture dependent
> library tree Installing /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/auto/Embperl/Embperl.so
> Installing /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl.pod
> Installing /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Faq.pod
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Mail.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Constant.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Log.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/App.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Recipe.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Form.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Inline.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/TOC.pod
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/TipsAndTricks.pod
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Out.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Object.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Syntax.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Util.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Embperl/Run.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/EmbperlLibXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/EmbperlPODXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/LibXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/EmbperlXalanXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/XalanXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/XSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/EmbperlXSLT.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Recipe/Embperl.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/Perl.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/Mail.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/HTML.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/SSI.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/ASP.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/MsgIdExtract.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/POD.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/Text.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/EmbperlBlocks.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/RTF.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Syntax/Embperl.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/DataSource.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/ControlMultValue.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/TimeHHMM.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/Select.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/Integer.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/FQDN_IPAddr.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/Default.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/TimeHHMMSS.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/Number.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/IPAddr_Mask.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/EMail.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/EMailRFC.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Validate/IPAddr.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/addremove.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/inputlist.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/password.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/displaylink.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/selectdyn.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/textarea.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/dump.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/line.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/blank.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/datetime.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/price.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/file.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/checkboxes.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/radio.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/inputjoin.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/grid.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/input.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/mult.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/transparent.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/hidden.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/submit.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/display.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/number.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/info.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/select.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/label.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/scriptcode.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/tabs.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/duration.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/checkbox.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/table.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/button.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/tinymce.pm
> Installing
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-
> multi/Embperl/Form/Control/show.pm
> Installing /root/perl5/man/man1/embpmsgid.pl.1p
> Installing /root/perl5/man/man1/embpexec.pl.1p
> Installing /root/perl5/man/man3/Embperl.3pm Installing
> /root/perl5/man/man3/Embperl::Form::Control::password.3pm
> Installing /root/perl5/man/man3/Embperl::Features.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::displaylink.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::checkboxes.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::input.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::selectdyn.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::transparent.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::inputlist.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::submit.3pm
> Installing /root/perl5/man/man3/Embperl::Form.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::button.3pm
> Installing /root/perl5/man/man3/Embperl::Mail.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::Mail.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::label.3pm
> Installing /root/perl5/man/man3/Embperl::Recipe::EmbperlXSLT.3pm
> Installing /root/perl5/man/man3/Embperl::Faq.3pm
> Installing /root/perl5/man/man3/Embperl::Recipe::XSLT.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::grid.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::hidden.3pm
> Installing /root/perl5/man/man3/Embperl::Recipe::Embperl.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::Embperl.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::inputjoin.3pm
> Installing /root/perl5/man/man3/Embperl::TipsAndTricks.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::mult.3pm
> Installing /root/perl5/man/man3/Embperl::Form::DataSource.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::MsgIdExtract.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::ASP.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::table.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::file.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::tabs.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::info.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::RTF.3pm
> Installing /root/perl5/man/man3/Embperl::TOC.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::addremove.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::EmbperlHTML.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::EmbperlBlocks.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::price.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::textarea.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::datetime.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::display.3pm
> Installing /root/perl5/man/man3/Embperl::Config.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::scriptcode.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::duration.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::tinymce.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::dump.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::checkbox.3pm
> Installing /root/perl5/man/man3/Embperl::Object.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::Text.3pm
> Installing /root/perl5/man/man3/IntroEmbperlObject.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::line.3pm
> Installing /root/perl5/man/man3/Embperl::Form::ControlMultValue.3pm
> Installing /root/perl5/man/man3/Embperl::Intro.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::blank.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Validate.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::show.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::POD.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::number.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::HTML.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::select.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::SSI.3pm
> Installing /root/perl5/man/man3/Embperl::FeaturesD.3pm
> Installing /root/perl5/man/man3/Embperl::Form::Control::radio.3pm
> Installing /root/perl5/man/man3/Embperl::Syntax::Perl.3pm
> Installing /root/perl5/man/man3/Embperl::Inline.3pm
> Installing /root/perl5/man/man3/Embperl::SVN.3pm
> Installing /root/perl5/man/man3/Embperl::Recipe.3pm
> Installing /root/perl5/man/man3/Embperl::Session.3pm
> Installing /root/perl5/man/man3/Embperl::App.3pm
> Installing /root/perl5/bin/embpexec.pl
> Installing /root/perl5/bin/embpmsgid.pl
> Appending installation info to
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/perllocal.pod
>
> Any ideas how I can fix this?
>
> Thanks,
>
> Neil
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe [at] perl
> For additional commands, e-mail: embperl-help [at] perl



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


neil at nilspace

Mar 26, 2012, 12:07 PM

Post #3 of 8 (1045 views)
Permalink
Re: Installing Embperl 2.4 on Debian Squeeze [In reply to]

richter [at] ecos wrote:
> Hi Neil,
>
> use www.embperl.org/downloads, but on CPAN it's the same version.
>
> Which Perl Version you are using?

Hi Gerald, I'm using what comes with Debian Squeeze (testing):

root [at] de:~# perl --version

This is perl 5, version 14, subversion 2 (v5.14.2) built for
x86_64-linux-gnu-thread-multi
(with 59 registered patches, see perl -V for more detail)

Let me know if you need more info on that...

Thanks,

Neil

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


dom at earth

Mar 26, 2012, 12:12 PM

Post #4 of 8 (1054 views)
Permalink
Re: Installing Embperl 2.4 on Debian Squeeze [In reply to]

On Mon, Mar 26, 2012 at 12:07:50PM -0700, Neil Gunton wrote:
> richter [at] ecos wrote:
> >Hi Neil,
> >
> >use www.embperl.org/downloads, but on CPAN it's the same version.
> >
> >Which Perl Version you are using?
>
> Hi Gerald, I'm using what comes with Debian Squeeze (testing):
>
> root [at] de:~# perl --version
>
> This is perl 5, version 14, subversion 2 (v5.14.2) built for
> x86_64-linux-gnu-thread-multi
> (with 59 registered patches, see perl -V for more detail)
>
> Let me know if you need more info on that...

Hi,

That isn't the perl from squeeze - it looks like you've upgraded
to the perl from wheezy or sid (which probably meant a wholesale
dist-upgrade to wheezy or sid). This may not be quite relevant to
your question, but I thought it was worth pointing out in case you
wanted to be running a squeeze system.

Dominic.

--
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


neil at nilspace

Mar 26, 2012, 12:26 PM

Post #5 of 8 (1043 views)
Permalink
Re: Installing Embperl 2.4 on Debian Squeeze [In reply to]

Dominic Hargreaves wrote:
> Hi,
>
> That isn't the perl from squeeze - it looks like you've upgraded
> to the perl from wheezy or sid (which probably meant a wholesale
> dist-upgrade to wheezy or sid). This may not be quite relevant to
> your question, but I thought it was worth pointing out in case you
> wanted to be running a squeeze system.
>
> Dominic.

Ah, crap - you are absolutely right, I've been using Squeeze for so long
now that I typed it automatically. The upgrade I just did was to Wheezy,
sorry for the mistake. This was a clean install, not an upgrade.

Once again, my apologies, silly mistake. For some reason I keep mixing
up the Squeeze and Wheezy names...

:P

Neil

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


richter at ecos

Mar 26, 2012, 10:49 PM

Post #6 of 8 (1052 views)
Permalink
RE: Installing Embperl 2.4 on Debian Squeeze [In reply to]

Hi Neil,

you can ignore the message about missing errors. That's simply because the text of some error messages has changed in Perl 5.14.

Embperl 2.4 works fine with Perl 5.14, but automatically reloading of files when they have changed gives an error, because Perl internals have changed and I didn't found a way so far to get it working again. So for now you have to restart Apache when you have changed Embperl files (or you have to stick with Perl 5.12)

Gerald


> -----Original Message-----
> From: Neil Gunton [mailto:neil [at] nilspace]
> Sent: Monday, March 26, 2012 9:08 PM
> To: Gerald Richter - ECOS
> Cc: embperl [at] perl
> Subject: Re: Installing Embperl 2.4 on Debian Squeeze
>
> richter [at] ecos wrote:
> > Hi Neil,
> >
> > use www.embperl.org/downloads, but on CPAN it's the same version.
> >
> > Which Perl Version you are using?
>
> Hi Gerald, I'm using what comes with Debian Squeeze (testing):
>
> root [at] de:~# perl --version
>
> This is perl 5, version 14, subversion 2 (v5.14.2) built for x86_64-linux-gnu-
> thread-multi (with 59 registered patches, see perl -V for more detail)
>
> Let me know if you need more info on that...
>
> Thanks,
>
> Neil


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


dirk.melchers at nureg

Mar 27, 2012, 2:35 AM

Post #7 of 8 (1046 views)
Permalink
Re: Installing Embperl 2.4 on Debian Squeeze [In reply to]

Hello Gerald,

in Ubuntu 12.04, perl 5.14 will be used - and embperl is also included. Does this mean, the 12.04 will NOT work correctly or did the ubuntu maintainer fix something?

How much work would it be to make embperl work again with perl 5.14?


Am 27.03.2012 um 07:49 schrieb richter [at] ecos:

> Hi Neil,
>
> you can ignore the message about missing errors. That's simply because the text of some error messages has changed in Perl 5.14.
>
> Embperl 2.4 works fine with Perl 5.14, but automatically reloading of files when they have changed gives an error, because Perl internals have changed and I didn't found a way so far to get it working again. So for now you have to restart Apache when you have changed Embperl files (or you have to stick with Perl 5.12)
>
> Gerald
>

With best regards,

Dirk Melchers
/// IT/Software-Development ///

--
NUREG GmbH ///
Dorfäckerstraße 31 | 90427 Nürnberg | Germany
Tel. +49-911-32002-256 | Fax +49-911-32002-299
Mobil +49-172-9354670 | www.nureg.de
Nürnberg HRB 22653 | USt.ID DE 814 685 653
Geschäftsführer: Michael Schmidt, Stefan Boas


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl


dom at earth

Mar 27, 2012, 3:07 AM

Post #8 of 8 (1046 views)
Permalink
Re: Installing Embperl 2.4 on Debian Squeeze [In reply to]

On Tue, Mar 27, 2012 at 11:35:08AM +0200, Dirk Melchers wrote:
> Hello Gerald,
>
> in Ubuntu 12.04, perl 5.14 will be used - and embperl is also included. Does this mean, the 12.04 will NOT work correctly or did the ubuntu maintainer fix something?
>
> How much work would it be to make embperl work again with perl 5.14?

Ubuntu is shipping Embperl 2.3.0, although even that fails to build
in Debian unstable and has been removed from wheezy because of [1];
I don't know what Ubuntu's policy about that is, or how they got it to
build.

[1] <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624578>

--
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe [at] perl
For additional commands, e-mail: embperl-help [at] perl

ModPerl embperl RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.