Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: ModPerl: ASP

[patch]fix for modperl-2.0.0-0.rc5

 

 

ModPerl asp RSS feed   Index | Next | Previous | View Threaded


joel.reed at ddiworld

Jun 22, 2005, 7:36 AM

Post #1 of 3 (3559 views)
Permalink
[patch]fix for modperl-2.0.0-0.rc5

i needed to make the following change to get Apache::ASP 2.59 to
work with fedora core 4's mod_perl-2.0.0-0.rc5.3.

without it i see:

[Wed Jun 22 09:10:21 2005] [error] [client 127.0.0.1] Can't locate object
method "get" via package "APR::Table" at /usr/lib/perl5/site_perl/5.8.6/Apache
/ASP.pm line 2022.\n at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line 20
22\n\tApache::ASP::get_dir_config('APR::Table=HASH(0x80422a94)', 'Global')
called at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line
277\n\tApache::ASP::new('Apache::ASP', 'Apache2::RequestRec=SCALAR(0x8014fec4)',
'/usr/local/share/lm-4.0/web/status.asp') called at
/usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line 183\n\tApache::ASP::handler('Apache2::RequestRec=SCALAR(0x8014fec4)') called at -e line 0\n\teval {...} called at -e line 0\n

because $mod_perl2 is not set as it should be.

HTH,

jr

here's what worked for me:

--- /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm.orig 2005-06-22 10:10:37.000000000 -0400
+++ /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm 2005-06-22 10:13:13.000000000 -0400
@@ -63,7 +63,11 @@ unless($LoadModPerl++) {
}

if($ENV{MOD_PERL}) {
- $ModPerl2 = ($mod_perl::VERSION >= 1.99);
+ # release 1.999_22 of mod_perl seems to require
+ # using $ENV{MOD_PERL_API_VERSION} not $mod_perl::VERSION
+ my $ver = $mod_perl::VERSION;
+ if ($ver eq "") { $ver = $ENV{MOD_PERL_API_VERSION}; }
+ $ModPerl2 = ($ver >= 1.99);
if($ModPerl2) {
eval "use Apache::ASP::ApacheCommon ();";
die($@) if $@;

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe [at] perl
For additional commands, e-mail: asp-help [at] perl


bfbay315 at sbcglobal

Oct 11, 2005, 8:02 AM

Post #2 of 3 (3191 views)
Permalink
Re: [patch]fix for modperl-2.0.0-0.rc5 [In reply to]

--- In apache-asp [at] yahoogroups, joel reed <joel.reed [at] d> wrote:
>
> i needed to make the following change to get Apache::ASP 2.59 to
> work with fedora core 4's mod_perl-2.0.0-0.rc5.3.
>
> without it i see:
>
> [Wed Jun 22 09:10:21 2005] [error] [client 127.0.0.1] Can't locate
object
> method "get" via package "APR::Table" at
/usr/lib/perl5/site_perl/5.8.6/Apache
> /ASP.pm line 2022.\n at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm
line 20
> 22\n\tApache::ASP::get_dir_config('APR::Table=HASH(0x80422a94)',
'Global')
> called at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line
> 277\n\tApache::ASP::new('Apache::ASP',
'Apache2::RequestRec=SCALAR(0x8014fec4)',
> '/usr/local/share/lm-4.0/web/status.asp') called at
> /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line
183\n\tApache::ASP::handler('Apache2::RequestRec=SCALAR(0x8014fec4)')
called at -e line 0\n\teval {...} called at -e line 0\n
>
> because $mod_perl2 is not set as it should be.
>
> HTH,
>
> jr
>
> here's what worked for me:
>
> --- /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm.orig 2005-06-22
10:10:37.000000000 -0400
> +++ /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm 2005-06-22
10:13:13.000000000 -0400
> @@ -63,7 +63,11 @@ unless($LoadModPerl++) {
> }
>
> if($ENV{MOD_PERL}) {
> - $ModPerl2 = ($mod_perl::VERSION >= 1.99);
> + # release 1.999_22 of mod_perl seems to require
> + # using $ENV{MOD_PERL_API_VERSION} not $mod_perl::VERSION
> + my $ver = $mod_perl::VERSION;
> + if ($ver eq "") { $ver = $ENV{MOD_PERL_API_VERSION}; }
> + $ModPerl2 = ($ver >= 1.99);
> if($ModPerl2) {
> eval "use Apache::ASP::ApacheCommon ();";
> die($@) if $@;
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: asp-unsubscribe [at] p
> For additional commands, e-mail: asp-help [at] p
>


I am kind of confused by this solution...

you placed the following code in ASP.pm??

unless($LoadModPerl++) {
}

if($ENV{MOD_PERL}) {
$ModPerl2 = ($mod_perl::VERSION >= 1.99);
# release 1.999_22 of mod_perl seems to require
# using $ENV{MOD_PERL_API_VERSION} not $mod_perl::VERSION
my $ver = $mod_perl::VERSION;
if ($ver eq "") { $ver = $ENV{MOD_PERL_API_VERSION}; }
$ModPerl2 = ($ver >= 1.99);
if($ModPerl2) {
eval "use Apache::ASP::ApacheCommon ();";
die($@) if $@;


I am having the same error message as you had....Can't locate object
method "get" via package "APR::Table" at blah, blah, blah.

thanks,
Brian




---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe [at] perl
For additional commands, e-mail: asp-help [at] perl


bfbay315 at sbcglobal

Oct 11, 2005, 5:46 PM

Post #3 of 3 (3182 views)
Permalink
Re: [patch]fix for modperl-2.0.0-0.rc5 [In reply to]

--- In apache-asp [at] yahoogroups, joel reed <joel.reed [at] d> wrote:
>
> i needed to make the following change to get Apache::ASP 2.59 to
> work with fedora core 4's mod_perl-2.0.0-0.rc5.3.
>
> without it i see:
>
> [Wed Jun 22 09:10:21 2005] [error] [client 127.0.0.1] Can't locate
object
> method "get" via package "APR::Table" at
/usr/lib/perl5/site_perl/5.8.6/Apache
> /ASP.pm line 2022.\n at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm
line 20
> 22\n\tApache::ASP::get_dir_config('APR::Table=HASH(0x80422a94)',
'Global')
> called at /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line
> 277\n\tApache::ASP::new('Apache::ASP',
'Apache2::RequestRec=SCALAR(0x8014fec4)',
> '/usr/local/share/lm-4.0/web/status.asp') called at
> /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm line
183\n\tApache::ASP::handler('Apache2::RequestRec=SCALAR(0x8014fec4)')
called at -e line 0\n\teval {...} called at -e line 0\n
>
> because $mod_perl2 is not set as it should be.
>
> HTH,
>
> jr
>
> here's what worked for me:
>
> --- /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm.orig 2005-06-22
10:10:37.000000000 -0400
> +++ /usr/lib/perl5/site_perl/5.8.6/Apache/ASP.pm 2005-06-22
10:13:13.000000000 -0400
> @@ -63,7 +63,11 @@ unless($LoadModPerl++) {
> }
>
> if($ENV{MOD_PERL}) {
> - $ModPerl2 = ($mod_perl::VERSION >= 1.99);
> + # release 1.999_22 of mod_perl seems to require
> + # using $ENV{MOD_PERL_API_VERSION} not $mod_perl::VERSION
> + my $ver = $mod_perl::VERSION;
> + if ($ver eq "") { $ver = $ENV{MOD_PERL_API_VERSION}; }
> + $ModPerl2 = ($ver >= 1.99);
> if($ModPerl2) {
> eval "use Apache::ASP::ApacheCommon ();";
> die($@) if $@;
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: asp-unsubscribe [at] p
> For additional commands, e-mail: asp-help [at] p
>


Nevermind....

I figured it out based on your post

Thanks alot!

Brian




---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe [at] perl
For additional commands, e-mail: asp-help [at] perl

ModPerl asp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.