Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Maemo: Developers

Building a package for armel only

 

 

Maemo developers RSS feed   Index | Next | Previous | View Threaded


mardy at users

Jul 11, 2011, 11:30 PM

Post #1 of 3 (390 views)
Permalink
Building a package for armel only

Hi all,
is there a way to tell the community autobuilder that my package
should be built for Armel only? The i386 build fails, and I have no time
(and interested) to make it work, also given the fact that the
compilation takes ages.

I tried adding "Architecture: armel" in the debian/control file, but
that didn't seem to help:
https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/

Ciao,
Alberto

--
http://blog.mardy.it <- geek in un lingua international!
_______________________________________________
maemo-developers mailing list
maemo-developers [at] maemo
https://lists.maemo.org/mailman/listinfo/maemo-developers


gregor+maemo at comodo

Jul 11, 2011, 11:44 PM

Post #2 of 3 (383 views)
Permalink
Re: Building a package for armel only [In reply to]

On Tue, 12 Jul 2011 09:30:57 +0300, Alberto Mardegan wrote:

> The i386 build fails, and I have no time
> (and interested) to make it work, also given the fact that the
> compilation takes ages.

> https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/

Some random observations:

From https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/i386.root.log.OK.txt

[2011-07-11 23:52:46] Try to install alt dependencies: libgles1-sgx-img-dev
[2011-07-11 23:52:46] fakeroot apt-get -y -q -o APT::Get::AllowUnauthenticated=1 install --no-remove libgles1-sgx-img-dev </dev/null
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package libgles1-sgx-img-dev
[2011-07-11 23:52:46] Try to install alt dependencies: libgl-dev
[2011-07-11 23:52:46] fakeroot apt-get -y -q -o APT::Get::AllowUnauthenticated=1 install --no-remove libgl-dev </dev/null

While on armel libgles1-sgx-img-dev gets installed.

http://maemo.org/packages/view/libgles1-sgx-img-dev/ looks like the
package only exists on armel.

https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/i386.build.log.FAILED.txt
show a failure that seems related:

share/glext.h:29:21: error: GLES/gl.h: No such file or directory

Oh, and
https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/results/neverball_1.5.5-1.dsc
has "Architecture: any" (not "armel"), and a build dependency on
"libgles1-sgx-img-dev | libgl-dev"

Cheers,
gregor

--
.''`. Homepage: http://info.comodo.priv.at/ - PGP/GPG key ID: 0x8649AA06
: :' : Debian GNU/Linux user, admin, & developer - http://www.debian.org/
`. `' Member of VIBE!AT & SPI, fellow of Free Software Foundation Europe
`- Kirk to Enterprise -- beam down yeoman Rand and a six-pack.
_______________________________________________
maemo-developers mailing list
maemo-developers [at] maemo
https://lists.maemo.org/mailman/listinfo/maemo-developers


mardy at users

Jul 12, 2011, 1:34 AM

Post #3 of 3 (375 views)
Permalink
Re: Building a package for armel only [In reply to]

On 07/12/2011 09:44 AM, gregor herrmann wrote:
> Oh, and
> https://garage.maemo.org/builder/fremantle/neverball_1.5.5-1/results/neverball_1.5.5-1.dsc
> has "Architecture: any" (not "armel"), and a build dependency on
> "libgles1-sgx-img-dev | libgl-dev"

Specifying "armel" architecture for all packages did the trick, thanks!

Ciao,
Alberto

--
http://blog.mardy.it <- geek in un lingua international!
_______________________________________________
maemo-developers mailing list
maemo-developers [at] maemo
https://lists.maemo.org/mailman/listinfo/maemo-developers

Maemo developers RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.