Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Linux Virtual Server: Users

[lvs-users] LVS-DR on Xen Server loopback problem

 

 

Linux Virtual Server users RSS feed   Index | Next | Previous | View Threaded


darrena at cavecreek

Jun 17, 2012, 7:13 PM

Post #1 of 1 (293 views)
Permalink
[lvs-users] LVS-DR on Xen Server loopback problem

I have a problem with LVS-DR and loopback interfaces.



I have three xen servers each with a Centos 6.2 VM running apache for the real servers. On xenserver01 I have a Centos 6.2 vm that is the primary load balancer. On xenserver02 there is a Centos 6.2 vm that is the backup load balancer. I am running LVS in DR. I have arp disabled on all the real servers using the arp_announce and arp_ignore parameters in /etc/sysctl.conf.



I can do DR just fine using postrouting rules in iptables with no loopback interfaces configured for VIPs on real servers. This works fine using name based virtual hosts. My client requires ip based virtualhosts. In order for apache to respond to requests on the VIP I need to configure loopback interfaces for each of my 26 VIPs. When I configure the local loopback interfaces the VIPs stop responding and the ipvs table shows all connections as InActConn.



I can connect to the loopback interface and port locally from the real server. The loadbalancer can connect to the RIP and port. I can connect to the RIPS directly from a browser.



Is there a problem running IPVS on virtual machines?



Thanks in advance for any advice. I can provide much more detail about the environment if needed.
Attachments: PGP.sig (0.46 KB)

Linux Virtual Server users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.