Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Lucene: Java-Dev

[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.

 

 

Lucene java-dev RSS feed   Index | Next | Previous | View Threaded


jira at apache

Apr 24, 2012, 12:59 PM

Post #1 of 10 (146 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13260889#comment-13260889 ]

Robert Muir commented on LUCENE-4016:
-------------------------------------

{quote}
ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
{quote}

What is the effect of this on javadocs? I intentionally added checks to flush out 'secret' javadocs for packages that had no classes, because its a sign they should really be in overview.html or restructured somehow (http://svn.apache.org/viewvc?rev=1328844&view=rev). Will this break that?

I know, its funky how the check works, by *allowing* it (includenosourcepackages="true"), we cause a javadocs warning
to occur as a side effect (versus silently discarding the documentation), failing the build :)


> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK ? ? ?
> jar-checksums OK ? ? ?
> validate OK ? ? ?
> test OK ? ? ?
> lucene/
> clover ? ? ? ?
> documentation ? ? ? ?
> javadocs ? ? ? ?
> package-tgz ? ? ? ?
> package-zip ? ? ? ?
> package-tgz-src ? ? ? ?
> package-all-b* ? ? ? ?
> solr/
> clover ? ? ? ?
> create-package ? ? ? ?
> dist ? ? ? ?
> example ? ? ? ?
> javadocs ? ? ? ?
> package-src-tgz ? ? ? ?
> run-example ? ? ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 24, 2012, 1:48 PM

Post #2 of 10 (145 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13260996#comment-13260996 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

I only see "package-info.class" generated for source files like spatial\src\java\org\apache\lucene\spatial\package-info.java. This is generated with Ant 1.8 but is not with Ant 1.7.

There are no other differences other than timestamps (builds executed at different time).

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK ? ? ?
> jar-checksums OK ? ? ?
> validate OK ? ? ?
> test OK ? ? ?
> lucene/
> clover ? ? ? ?
> documentation ? ? ? ?
> javadocs ? ? ? ?
> package-tgz ? ? ? ?
> package-zip ? ? ? ?
> package-tgz-src ? ? ? ?
> package-all-b* ? ? ? ?
> solr/
> clover ? ? ? ?
> create-package ? ? ? ?
> dist ? ? ? ?
> example ? ? ? ?
> javadocs ? ? ? ?
> package-src-tgz ? ? ? ?
> run-example ? ? ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 24, 2012, 1:54 PM

Post #3 of 10 (145 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261003#comment-13261003 ]

Robert Muir commented on LUCENE-4016:
-------------------------------------

So that means if i have a package, with only a package.html and no classes... that its package.html is now visible?

I'm just trying to think about how my checker will cope :)

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK ? ? ?
> jar-checksums OK ? ? ?
> validate OK ? ? ?
> test OK ? ? ?
> lucene/
> clover ? ? ? ?
> prepare-relea* OK ? ? ?
> solr/
> clover ? ? ? ?
> run-example ? ? ? ?
> prepare-relea* ? ? ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 24, 2012, 2:00 PM

Post #4 of 10 (143 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261008#comment-13261008 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

We misunderstood each other. These package-info.class files are generated for package-info.java (which are a way to put annotations on a package). There are three such files in Lucene (in spatial).

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK ? ? ?
> jar-checksums OK ? ? ?
> validate OK ? ? ?
> test OK ? ? ?
> lucene/
> clover ? ? ? ?
> prepare-relea* OK ? ? ?
> solr/
> clover ? ? ? ?
> run-example ? ? ? ?
> prepare-relea* ? ? ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 24, 2012, 2:42 PM

Post #5 of 10 (141 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261052#comment-13261052 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

I'll check Ubuntu tomorrow. If anybody wants to give Mac a try, go ahead. I don't think there will be any differences, really -- if it passed without any glitches on my Windows machine I don't expect any problems on other platforms (typically it's windows that causes problems).


> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK ? ? ?
> jar-checksums OK ? ? ?
> validate OK ? ? ?
> test OK ? ? ?
> lucene/
> prepare-relea* OK ? ? ?
> solr/
> prepare-relea* OK ? ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 25, 2012, 11:14 AM

Post #6 of 10 (140 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261873#comment-13261873 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

I'm planning on switching Ubuntu's symlinks to ant 1.8.2 and let it run for a while. So far nothing's been different (I still don't have a confirmation from a mac, but I bet it's identical there). Report any problems, please.

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK OK ? ?
> jar-checksums OK OK ? ?
> validate OK OK ? ?
> test OK OK ? ?
> lucene/
> prepare-relea* OK OK ? ?
> solr/
> prepare-relea* OK OK ? ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 25, 2012, 2:28 PM

Post #7 of 10 (138 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13262130#comment-13262130 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

Jenkins is running ant 1.8.2. Everything seems to work identically to ant 1.7. I've attached a patch that enforces ant 1.8.2 or later so if you have an older ant, the build will fail for you with a message saying you need to upgrade.

Explanation -- ant 1.8.2 is available by default on macs and 1.8.3 is relatively new so I decided to make 1.8.2 a required version. Everything works fine with 1.8.3 as well so you can use the latest one too.

If there are no objections, I'll commit it shortly.

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
> Attachments: LUCENE-4016.patch
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK OK OK ?
> jar-checksums OK OK OK ?
> validate OK OK OK ?
> test OK OK OK OK
> lucene/
> prepare-relea* OK OK OK ?
> solr/
> prepare-relea* OK OK OK ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 26, 2012, 3:04 PM

Post #8 of 10 (135 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13263187#comment-13263187 ]

Michael McCandless commented on LUCENE-4016:
--------------------------------------------

As far as I can tell, I can't reproduce the output truncation I was seeing before.

Before, it reproduced easily (1.7.1 worked, 1.8.3 truncated)... I never got to the bottom of it.

So I think the recent changes to the test infra must've worked around the problem?

So I'm fine w/ requiring 1.8.x.

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
> Attachments: LUCENE-4016.patch
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK OK OK ?
> jar-checksums OK OK OK ?
> validate OK OK OK ?
> test OK OK OK OK
> lucene/
> prepare-relea* OK OK OK ?
> solr/
> prepare-relea* OK OK OK ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 26, 2012, 3:11 PM

Post #9 of 10 (146 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13263192#comment-13263192 ]

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

I'm sure it's switching to junit4 - it's a different runner and different type of buffering. Not everything is smooth (there are issues with jvm debugging options, jvm warnings, etc.) but I'm working on these.

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
> Attachments: LUCENE-4016.patch
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK OK OK ?
> jar-checksums OK OK OK ?
> validate OK OK OK ?
> test OK OK OK OK
> lucene/
> prepare-relea* OK OK OK ?
> solr/
> prepare-relea* OK OK OK ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene


jira at apache

Apr 26, 2012, 4:14 PM

Post #10 of 10 (136 views)
Permalink
[jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform. [In reply to]

[ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13263237#comment-13263237 ]

Robert Muir commented on LUCENE-4016:
-------------------------------------

patch looks good.

Thanks for doing all this testing!

> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: LUCENE-4016
> URL: https://issues.apache.org/jira/browse/LUCENE-4016
> Project: Lucene - Java
> Issue Type: Task
> Components: general/build
> Reporter: Dawid Weiss
> Assignee: Dawid Weiss
> Priority: Trivial
> Fix For: 4.0
>
> Attachments: LUCENE-4016.patch
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target Windows Ubuntu Mac Jenkins
> ------------------------------------------------
> /
> ivy-bootstrap OK OK OK ?
> jar-checksums OK OK OK ?
> validate OK OK OK ?
> test OK OK OK OK
> lucene/
> prepare-relea* OK OK OK ?
> solr/
> prepare-relea* OK OK OK ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.
> - manifest timestamps are slightly different (Created-By - jvm version is formatted differently, I think more human-friendly in 1.8).
> {noformat}
> 1.7: Created-By: 22.1-b02 (Oracle Corporation)
> 1.8: Created-By: 1.7.0_03-b05 (Oracle Corporation)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe [at] lucene
For additional commands, e-mail: dev-help [at] lucene

Lucene java-dev RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.