Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: ivtv: devel

AverMedia Ultra 116 Card

 

 

ivtv devel RSS feed   Index | Next | Previous | View Threaded


hiemanshu at fedoraproject

Oct 8, 2009, 7:59 AM

Post #1 of 2 (1928 views)
Permalink
AverMedia Ultra 116 Card

Hello,

I have an AverMedia Ultra 116 TV(M103) Card that uses ivtv module
(Auto detect by Fedora)
I am not able to get any display on it. Its not an hardware issue as
the card seems to be working just fine on Windows.
I tried to remove the AverMedia Sticker on the Tuner box and it read
FM1216, i couldn't see the rest as the sticker dint come out well.

Here is the lspci message

01:07.0 Multimedia video controller [0400]: Internext Compression Inc
iTVC16 (CX23416) MPEG-2 Encoder [4444:0016] (rev 01)

And here is the dmesg output while the computer boots.

ivtv: Start initialization, version 1.4.1
ivtv0: Initializing card 0
ivtv0: Unknown card: vendor/device: [4444:0016]
ivtv0: subsystem vendor/device: [1461:c01b]
ivtv0: cx23416 based
ivtv0: Defaulting to Hauppauge WinTV PVR-150 card
ivtv0: Please mail the vendor/device and subsystem vendor/device IDs
and what kind of
ivtv0: card you have to the ivtv-devel mailinglist (www.ivtvdriver.org)
ivtv0: Prefix your subject line with [UNKNOWN IVTV CARD].
ivtv 0000:01:07.0: PCI INT A -> Link[LNKC] -> GSI 16 (level, low) -> IRQ 16
ivtv0: Invalid EEPROM
cx25840 2-0044: cx25842-23 found @ 0x88 (ivtv i2c driver #0)
tuner 2-0043: chip found @ 0x86 (ivtv i2c driver #0)
tuner 2-0060: chip found @ 0xc0 (ivtv i2c driver #0)
wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #0)
IRQ 16/ivtv0: IRQF_DISABLED is not guaranteed on shared IRQs
ivtv0: Registered device video0 for encoder MPG (4096 kB)
ivtv0: Registered device video32 for encoder YUV (2048 kB)
ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
ivtv0: Registered device video24 for encoder PCM (320 kB)
ivtv0: Registered device radio0 for encoder radio
ivtv0: Initialized card: Hauppauge WinTV PVR-150
ivtv: End initialization
ivtv 0000:01:07.0: firmware: requesting v4l-cx2341x-enc.fw
ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
ivtv0: Encoder revision: 0x02060039

Please help me get it working and also let me know if you need any
more details at all.

--
Regards,

Hiemanshu Sharma.

_______________________________________________
ivtv-devel mailing list
ivtv-devel [at] ivtvdriver
http://ivtvdriver.org/mailman/listinfo/ivtv-devel


awalls at radix

Nov 13, 2009, 12:59 PM

Post #2 of 2 (1577 views)
Permalink
Re: AverMedia Ultra 116 Card [In reply to]

On Thu, 2009-10-08 at 19:59 +0500, Hiemanshu Sharma wrote:
> Hello,
>
> I have an AverMedia Ultra 116 TV(M103) Card that uses ivtv module
> (Auto detect by Fedora)
> I am not able to get any display on it. Its not an hardware issue as
> the card seems to be working just fine on Windows.
> I tried to remove the AverMedia Sticker on the Tuner box and it read
> FM1216, i couldn't see the rest as the sticker dint come out well.
>
> Here is the lspci message
>
> 01:07.0 Multimedia video controller [0400]: Internext Compression Inc
> iTVC16 (CX23416) MPEG-2 Encoder [4444:0016] (rev 01)
>
> And here is the dmesg output while the computer boots.
>
> ivtv: Start initialization, version 1.4.1
> ivtv0: Initializing card 0
> ivtv0: Unknown card: vendor/device: [4444:0016]
> ivtv0: subsystem vendor/device: [1461:c01b]
> ivtv0: cx23416 based
> ivtv0: Defaulting to Hauppauge WinTV PVR-150 card
> ivtv0: Please mail the vendor/device and subsystem vendor/device IDs
> and what kind of
> ivtv0: card you have to the ivtv-devel mailinglist (www.ivtvdriver.org)
> ivtv0: Prefix your subject line with [UNKNOWN IVTV CARD].
> ivtv 0000:01:07.0: PCI INT A -> Link[LNKC] -> GSI 16 (level, low) -> IRQ 16
> ivtv0: Invalid EEPROM
> cx25840 2-0044: cx25842-23 found @ 0x88 (ivtv i2c driver #0)
> tuner 2-0043: chip found @ 0x86 (ivtv i2c driver #0)
> tuner 2-0060: chip found @ 0xc0 (ivtv i2c driver #0)
> wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #0)
> IRQ 16/ivtv0: IRQF_DISABLED is not guaranteed on shared IRQs
> ivtv0: Registered device video0 for encoder MPG (4096 kB)
> ivtv0: Registered device video32 for encoder YUV (2048 kB)
> ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
> ivtv0: Registered device video24 for encoder PCM (320 kB)
> ivtv0: Registered device radio0 for encoder radio
> ivtv0: Initialized card: Hauppauge WinTV PVR-150
> ivtv: End initialization
> ivtv 0000:01:07.0: firmware: requesting v4l-cx2341x-enc.fw
> ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
> ivtv0: Encoder revision: 0x02060039
>
> Please help me get it working and also let me know if you need any
> more details at all.


Hiemanshu,

Sorry for the long delay in replying.

Your card is actually an AverMedia M113 variant. There is already an
M113 card supported by ivtv with only a different tuner. Please try as
root:

# modprobe -r ivtv

and

# modprobe ivtv cardtype=27 tuner=38 (FM1216ME_MK3 tuner)

or

# modprobe ivtv cardtype=27 tuner=79 (FM1216MK5)

and tell me which one performs better for you. I suspect the MK5 will.
I can then update the card entry in ivtv-cards.c to add your card's
tuner.

The Philips FM1216ME tuner on your card can handle B/G, I, D/K, and L/L'
TV systems. Your card is very similar to the version of the "AVerMedia
UltraTV 1500 MCE" which is also based on the M113 design, but that card
has an M/N TV system tuner.

Regards,
Andy


_______________________________________________
ivtv-devel mailing list
ivtv-devel [at] ivtvdriver
http://ivtvdriver.org/mailman/listinfo/ivtv-devel

ivtv devel RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.