Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: GnuPG: users

Errors when running the relative executables after compiling gnupg-2.0.18 on MinGW

 

 

GnuPG users RSS feed   Index | Next | Previous | View Threaded


chencg.hn at gmail

Mar 24, 2012, 10:19 PM

Post #1 of 3 (465 views)
Permalink
Errors when running the relative executables after compiling gnupg-2.0.18 on MinGW

Dear All,

I have managed to compile gnupg-2.0.18 on MinGW which is installed on my
Windows 7 PC. My steps to compile it are as below:
1. tar -jxvf gnupg-2.0.18.tar.bz2, then cd to the directory gnupg-2.0.18
2. run command './configure' to make configurations.
3. change the Makefile under the directory 'gnupg-2.0.18/g10' and
'gnupg-2.0.18/tools' to enable gcc to link the zlib library correctly, by
modified the flag 'ZLIBS' to 'ZLIBS = -lz -L/usr/local/lib
-I/usr/local/include' in the Makefile.
4. run command 'make'
5. run command 'make install'

That's all. And all goes well - the relative gnupg executables (gpg2.exe,
gpgsm.exe, gpgconf.exe, etc) are generated and copied to the
/usr/local/bin.
But when I cd to the directory /usr/local/bin and run command 'gpg2
--version' in the MingGW shell, then a window of appcrash is prompted,
showing that gpg2.exe is already stopped.
Results of running other executables are the same.

I don't know why this happen. Can anyone help me to go though it?

If you answer my question, please cc me back as I don't subscribe as a
member of gnupg-users.

Thank you


wk at gnupg

Mar 26, 2012, 9:49 PM

Post #2 of 3 (445 views)
Permalink
Re: Errors when running the relative executables after compiling gnupg-2.0.18 on MinGW [In reply to]

On Sun, 25 Mar 2012 07:19, chencg.hn [at] gmail said:

> I have managed to compile gnupg-2.0.18 on MinGW which is installed on my
> Windows 7 PC. My steps to compile it are as below:

Building GnuPG on Windows native is not supported. You need to
cross-build it using a Unix platform.


Salam-Shalom,

Werner

--
Die Gedanken sind frei. Ausnahmen regelt ein Bundesgesetz.


_______________________________________________
Gnupg-users mailing list
Gnupg-users [at] gnupg
http://lists.gnupg.org/mailman/listinfo/gnupg-users


chencg.hn at gmail

Mar 27, 2012, 4:42 AM

Post #3 of 3 (429 views)
Permalink
Re: Errors when running the relative executables after compiling gnupg-2.0.18 on MinGW [In reply to]

Yes, you're right![?]
I am able to cross-build it on my Ubuntu OS using command './autogen.sh
--build-w32' instead of './configure' at the first step.
Then run command 'make' to build the executables(gpg2.exe, gpgv2.exe,
gpgsm.exe, etc) for Microsoft Windows.

Now all the exes do work well on my Windows 7 PC.

Thank you.

2012/3/27 Werner Koch <wk [at] gnupg>

> On Sun, 25 Mar 2012 07:19, chencg.hn [at] gmail said:
>
> > I have managed to compile gnupg-2.0.18 on MinGW which is installed on my
> > Windows 7 PC. My steps to compile it are as below:
>
> Building GnuPG on Windows native is not supported. You need to
> cross-build it using a Unix platform.
>
>
> Salam-Shalom,
>
> Werner
>
> --
> Die Gedanken sind frei. Ausnahmen regelt ein Bundesgesetz.
>
>
Attachments: 330.gif (96 B)

GnuPG users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.