Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: User

Suspend, hibernate and mount stopped working as a regular user.

 

 

Gentoo user RSS feed   Index | Next | Previous | View Threaded


yohan.pereira at gmail

Jul 4, 2012, 4:47 AM

Post #1 of 3 (539 views)
Permalink
Suspend, hibernate and mount stopped working as a regular user.

Hi,
This happened after a recent world upgrade. I am currently using kde 4.8.4.
I can however suspend, hibernate using the pm-utils as root. Google has
lead me to believe this has something to do with consolekit. I found this
thread [1] which is more or less what I am experiencing (I can't mount
too). Running that dbus command gives me the same output mentioned
there.

yohan [at] powerslav ~ $ dbus-send --system --print-reply
--dest="org.freedesktop.UPower" /org/freedesktop/UPower
org.freedesktop.UPower.Suspend
Error org.freedesktop.UPower.GeneralError: not authorized

However I am not sure how to solve this. I don't have an .xinitrc file in my
home folder. So I looked at /etc/X11/xinit/xinitrc.d/, I tried removing
the file called 90-consolekit, which didn't help.

Anybody has any idea how to proceed in debugging this problem? any use
full output I can post?I have this feeling that I missed some important
piece of information from my portage log. I skimmed over summary.log
nothing caught my attention.

[1]https://bbs.archlinux.org/viewtopic.php?id=141337

--

- Yohan Pereira

The difference between a Miracle and a Fact is exactly the difference
between a mermaid and a seal.
-- Mark Twain


wonko at wonkology

Jul 4, 2012, 5:48 AM

Post #2 of 3 (446 views)
Permalink
Re: Suspend, hibernate and mount stopped working as a regular user. [In reply to]

Yohan Pereira writes:

> This happened after a recent world upgrade. I am currently using kde
> 4.8.4. I can however suspend, hibernate using the pm-utils as root.
> Google has lead me to believe this has something to do with consolekit.

Or maybe sys-auth/polkit? There were issues lately with a nonexisting
home directory, the elog message tells us to fix this with:

usermod -d "/var/lib/polkit-1" "polkitd"

Wonko


yohan.pereira at gmail

Jul 4, 2012, 6:29 AM

Post #3 of 3 (447 views)
Permalink
Re: Suspend, hibernate and mount stopped working as a regular user. [In reply to]

On 07/04/12 at 02:48pm, Alex Schuster wrote:
> Or maybe sys-auth/polkit? There were issues lately with a nonexisting
> home directory, the elog message tells us to fix this with:
>
> usermod -d "/var/lib/polkit-1" "polkitd"
>
> Wonko
>

Hi,
Thanks for the reply. Oddly the only polkit related message in my
summary.log is something about the user group wheel being changed to adm.
I ran your command though it says "no changes". The path is already set
in /etc/passwd.

--

- Yohan Pereira

The difference between a Miracle and a Fact is exactly the difference
between a mermaid and a seal.
-- Mark Twain

Gentoo user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.