pandu at poluan
Apr 24, 2012, 6:31 AM
Post #2 of 3
On Apr 24, 2012 8:11 PM, "Helmut Jarausch" <jarausch [at] igpm>
> a package at its 101st alpha version must be a bit crazy
> but it's probably me.
> Trying to emerge dev-python/xhtml2pdf I get the following message
> which I don't understand. They must be new in portage-2.2.0_alpha101 :
> !!! The ebuild selected to satisfy "dev-python/xhtml2pdf" has unmet
> - dev-python/xhtml2pdf-0.0.3::gentoo USE="(multilib)"
PYTHON_TARGETS="-python2_5 -python2_6 -python2_7"
> The following REQUIRED_USE flag constraints are unsatisfied:
> any-of ( python_targets_python2_5 python_targets_python2_6
> The package has been installed on 01/30/2012 for the first time but I
cannot reinstall it
> Normally all packages are installed for python:2.7 and python:3.2 here,
but this package
> seems to require python < 3.0 . Still, what can I do about it?
> Or is it an 'alpha feature' of portage?
> Many thanks for a hint,
The package wants you to specify which Python to target.
PYTHON_TARGETS="python2_7" emerge dev-python/xhtml2pdf