Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: User

portage slang - interpreter sought

 

 

Gentoo user RSS feed   Index | Next | Previous | View Threaded


jarausch at igpm

Apr 24, 2012, 6:06 AM

Post #1 of 3 (370 views)
Permalink
portage slang - interpreter sought

Hi,

a package at its 101st alpha version must be a bit crazy
but it's probably me.

Trying to emerge dev-python/xhtml2pdf I get the following message
which I don't understand. They must be new in portage-2.2.0_alpha101 :

!!! The ebuild selected to satisfy "dev-python/xhtml2pdf" has unmet
requirements.
- dev-python/xhtml2pdf-0.0.3::gentoo USE="(multilib)"
PYTHON_TARGETS="-python2_5 -python2_6 -python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
any-of ( python_targets_python2_5 python_targets_python2_6
python_targets_python2_7 )

The package has been installed on 01/30/2012 for the first time but I
cannot reinstall it
anymore.

Normally all packages are installed for python:2.7 and python:3.2 here,
but this package
seems to require python < 3.0 . Still, what can I do about it?

Or is it an 'alpha feature' of portage?

Many thanks for a hint,
Helmut.


pandu at poluan

Apr 24, 2012, 6:31 AM

Post #2 of 3 (358 views)
Permalink
Re: portage slang - interpreter sought [In reply to]

On Apr 24, 2012 8:11 PM, "Helmut Jarausch" <jarausch [at] igpm>
wrote:
>
> Hi,
>
> a package at its 101st alpha version must be a bit crazy
> but it's probably me.
>
> Trying to emerge dev-python/xhtml2pdf I get the following message
> which I don't understand. They must be new in portage-2.2.0_alpha101 :
>
> !!! The ebuild selected to satisfy "dev-python/xhtml2pdf" has unmet
requirements.
> - dev-python/xhtml2pdf-0.0.3::gentoo USE="(multilib)"
PYTHON_TARGETS="-python2_5 -python2_6 -python2_7"
>
> The following REQUIRED_USE flag constraints are unsatisfied:
> any-of ( python_targets_python2_5 python_targets_python2_6
python_targets_python2_7 )
>
> The package has been installed on 01/30/2012 for the first time but I
cannot reinstall it
> anymore.
>
> Normally all packages are installed for python:2.7 and python:3.2 here,
but this package
> seems to require python < 3.0 . Still, what can I do about it?
>
> Or is it an 'alpha feature' of portage?
>
> Many thanks for a hint,
> Helmut.
>

The package wants you to specify which Python to target.

Try:

PYTHON_TARGETS="python2_7" emerge dev-python/xhtml2pdf

Rgds,


keith at dartworks

Apr 24, 2012, 6:45 PM

Post #3 of 3 (357 views)
Permalink
Re: portage slang - interpreter sought [In reply to]

Re 1335272778.22356.0 [at] numa-i1335272778@numa-i, Pandu Poluan
said:
> PYTHON_TARGETS="python2_7" emerge dev-python/xhtml2pdf


You can also put

PYTHON_TARGETS="python2_7"

into your /etc/make.conf file.


-- Keith


--

-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Keith Dart <keith [at] dartworks>
public key: ID: 19017044
<http://www.dartworks.biz/>
=====================================================================

Gentoo user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.