Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: User
I want to play movies without hangs
 

Index | Next | Previous | View Flat


wonko at wonkology

Feb 16, 2012, 7:29 AM


Views: 1831
Permalink
I want to play movies without hangs

Hi there!

Strange things are going on here.

I've written here in the past about my performance problems. My dual-core
had trouble playing movies without stuttering when there was I/O. It was
mainly swapping that caused this, and 8 G were not enough for me running
KDE4.

Then my hardware broke, and I got new one, except for the system hard
drive and the PSU. It's an AMD FX-4100 quad-core with 3.6 GHz, 16 G of
RAM. Running gentoo-sources-3.2.1 as kernel. But it seems playing movies
got even worse!

The videos do not need to have high quality. When I do this, I get
interruptions, sometimes for more than a whole second:

# dd if=/dev/zero of=/tmp/argh bs=10M count=1000

My whole system is encrypted, but the same happens with unencrypted
partitions. All are on LVM. When I write to another drive, there is no
effect. Throughput is around 50-60 MB/s.

Any ideas where to look? I think I'll create a completely fresh
kernel .config with genkernel, maybe my own .config has some weird
problem. But I tried similar things in the past already, getting a kernel
from a live cd, to no effect.

I put cache = 10240 into .mplayer/config to get 10 MB of video cached,
but I see no effect.

Playing music with Amarok is no problem.

My SATA drives are in AHCI mode, here's some dmesg info about that:

ahci 0000:00:11.0: version 3.0
ahci 0000:00:11.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ahci 0000:00:11.0: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl SATA
mode
ahci 0000:00:11.0: flags: 64bit ncq sntf ilck led clo pmp pio slum part
ccc sxs
scsi0 : ahci
scsi1 : ahci
scsi2 : ahci
scsi3 : ahci
ata1: SATA max UDMA/133 abar m1024 [at] 0xff70b00 port 0xff70b100 irq 22
ata2: SATA max UDMA/133 abar m1024 [at] 0xff70b00 port 0xff70b180 irq 22
ata3: SATA max UDMA/133 abar m1024 [at] 0xff70b00 port 0xff70b200 irq 22
ata4: SATA max UDMA/133 abar m1024 [at] 0xff70b00 port 0xff70b280 irq 22
ahci 0000:02:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
ahci 0000:02:00.0: irq 43 for MSI/MSI-X
ahci: SSS flag set, parallel bus scan disabled
ahci 0000:02:00.0: AHCI 0001.0200 32 slots 2 ports 6 Gbps 0x3 impl SATA
mode
ahci 0000:02:00.0: flags: 64bit ncq sntf stag led clo pmp pio slum part
ccc sxs
ahci 0000:02:00.0: setting latency timer to 64
scsi4 : ahci
scsi5 : ahci
ata5: SATA max UDMA/133 abar m512 [at] 0xff60000 port 0xff600100 irq 43
ata6: SATA max UDMA/133 abar m512 [at] 0xff60000 port 0xff600180 irq 43
pata_atiixp 0000:00:14.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
scsi6 : pata_atiixp
scsi7 : pata_atiixp
ata7: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
ata8: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15

(ata7/8 is the additional PATA controller, seen with the pata_atiixp
driver. I have one drive there, but it is not being used.)

When my new girl-friend comes over and we want to watch a movie, and it
stutters... she will ask why I don't simply use Windows to get
better performance, her five year old PC would do this just fine. Wat do
I tell her? WHAT DO I TELL HER??


And then there's what happened yesterday. A world update was going on,
with libreoffice, firefox, wine and thunderbird emerging in parallel, all
big packages. I have the PORTAGE_TMPDIR on a 5GB tmpfs, only libreoffice
is being compiled on disk. Suddenly, my system became very unresponsive,
the mouse had disappeared, the KDE widgets did not update, and xosview
showed a load of 23. All 4 cores were at 100%, the type of usage was
io-wait. How can I find out in such a case which processes are waiting
for I/O? top showed nothing. The Ctrl-Esc task viewer of KDE showed some
processes being 'inactive on hard drive', does this men those are the
waiting tasks? They varied, they were mostly Akonadi stuff. I stopped
akonadi, and after a while the load dropped. But this may be a
coincidence.

After all had calmed down, I had 2G of swap in use. 16G total RAM, all
being used of course, but only 8G being needed according to the -/+
buffers/cache line in free -m, the other 8G are cache. Does my Linux
somehow prefer to have this much cache, even if tmpfs stuff gets put into
swap? I have vm.swappiness = 0 in /etc/sysctl.conf.

Is there a command to show me what processes the memory in swap belongs
to?

Wonko

Subject User Time
I want to play movies without hangs wonko at wonkology Feb 16, 2012, 7:29 AM
    Re: I want to play movies without hangs markknecht at gmail Feb 16, 2012, 8:04 AM
    Re: I want to play movies without hangs paul.hartman+gentoo at gmail Feb 16, 2012, 8:23 AM
    Re: I want to play movies without hangs wonko at wonkology Feb 16, 2012, 8:49 AM
        Re: I want to play movies without hangs paul.hartman+gentoo at gmail Feb 16, 2012, 9:21 AM
    Re: I want to play movies without hangs wonko at wonkology Feb 16, 2012, 9:34 AM
        Re: I want to play movies without hangs markknecht at gmail Feb 16, 2012, 9:45 AM
    Re: I want to play movies without hangs waltdnes at waltdnes Feb 17, 2012, 6:13 PM
        Re: I want to play movies without hangs wonko at wonkology Feb 17, 2012, 9:45 PM
            Re: I want to play movies without hangs jamesbroadhead at gmail Feb 18, 2012, 5:25 AM
    Re: I want to play movies without hangs wonko at wonkology Feb 17, 2012, 7:13 PM
    Re: I want to play movies without hangs wonko at wonkology Feb 18, 2012, 9:04 AM
        Re: I want to play movies without hangs u.schutz at bluewin Feb 18, 2012, 4:05 PM
            Re: I want to play movies without hangs wonko at wonkology Feb 18, 2012, 4:35 PM
                Re: I want to play movies without hangs wonko at wonkology May 7, 2012, 5:41 AM
                    Re: I want to play movies without hangs volkerarmin at googlemail May 7, 2012, 9:26 AM
                        Re: I want to play movies without hangs gentoo-user at hadt May 7, 2012, 9:44 AM
                            Re: I want to play movies without hangs volkerarmin at googlemail May 7, 2012, 10:14 AM
                                Re: I want to play movies without hangs gentoo-user at hadt May 7, 2012, 10:25 AM
                                    Re: I want to play movies without hangs volkerarmin at googlemail May 7, 2012, 10:39 AM
                                Re: I want to play movies without hangs w41ter at gmail May 7, 2012, 3:56 PM
                                    Re: Re: I want to play movies without hangs volkerarmin at googlemail May 7, 2012, 4:13 PM
                                        Re: I want to play movies without hangs w41ter at gmail May 7, 2012, 4:56 PM
                                            Re: Re: I want to play movies without hangs volkerarmin at googlemail May 8, 2012, 8:05 AM
                            Re: I want to play movies without hangs wonko at wonkology May 7, 2012, 11:52 AM
                    Re: I want to play movies without hangs markknecht at gmail May 7, 2012, 10:39 AM
                    Re: I want to play movies without hangs rdalek1967 at gmail May 7, 2012, 1:43 PM
                        Re: I want to play movies without hangs wonko at wonkology May 7, 2012, 2:09 PM
                        Re: I want to play movies without hangs stroller at stellar May 7, 2012, 2:16 PM
                        Re: I want to play movies without hangs turner25 at gmail May 8, 2012, 1:43 PM
    Re: I want to play movies without hangs wonko at wonkology May 7, 2012, 2:11 PM
        Re: I want to play movies without hangs wonko at wonkology May 9, 2012, 12:44 PM
            Re: I want to play movies without hangs neil at digimed May 9, 2012, 1:38 PM
                Re: I want to play movies without hangs wonko at wonkology May 9, 2012, 6:00 PM
                    Re: I want to play movies without hangs rdalek1967 at gmail May 9, 2012, 7:09 PM
                        Re: I want to play movies without hangs adamcarter3 at gmail May 9, 2012, 7:40 PM
                        Re: I want to play movies without hangs wonko at wonkology May 12, 2012, 5:34 PM
                            Re: I want to play movies without hangs mikemol at gmail May 12, 2012, 5:47 PM
                    Re: I want to play movies without hangs adamcarter3 at gmail May 9, 2012, 8:59 PM
                    Re: I want to play movies without hangs paul.hartman+gentoo at gmail May 10, 2012, 3:45 PM
            Re: I want to play movies without hangs [SOLVED, sort of] wonko at wonkology May 11, 2012, 6:40 PM
                Re: I want to play movies without hangs [SOLVED, sort of] invasivenorman at gmail May 12, 2012, 6:36 AM
                Re: I want to play movies without hangs [SOLVED, sort of] wonko at wonkology May 12, 2012, 8:05 AM
                    Re: I want to play movies without hangs [SOLVED, sort of] invasivenorman at gmail May 12, 2012, 8:41 AM
                Re: I want to play movies without hangs [SOLVED, sort of] alan.mckinnon at gmail May 13, 2012, 1:56 AM
                    Re: I want to play movies without hangs [SOLVED, sort of] mikemol at gmail May 13, 2012, 11:12 AM
                Re: I want to play movies without hangs [SOLVED, sort of] alan.mckinnon at gmail May 13, 2012, 1:53 PM
                    Re: I want to play movies without hangs [SOLVED, sort of] mikemol at gmail May 13, 2012, 2:01 PM
                Re: I want to play movies without hangs [SOLVED, sort of] alan.mckinnon at gmail May 13, 2012, 2:33 PM
                    Re: I want to play movies without hangs [SOLVED, sort of] mikemol at gmail May 13, 2012, 3:03 PM
                Re: I want to play movies without hangs [SOLVED, sort of] alan.mckinnon at gmail May 13, 2012, 4:27 PM
                    Re: I want to play movies without hangs [SOLVED, sort of] mikemol at gmail May 13, 2012, 4:54 PM
                Re: I want to play movies without hangs [SOLVED, sort of] paul.hartman+gentoo at gmail May 14, 2012, 3:28 PM
                Re: I want to play movies without hangs [SOLVED, sort of] wonko at wonkology May 15, 2012, 3:24 AM
    Re: I want to play movies without hangs rdalek1967 at gmail May 10, 2012, 12:53 AM
    Re: I want to play movies without hangs gentoo-user at hadt May 10, 2012, 1:02 AM
    Re: I want to play movies without hangs wonko at wonkology May 10, 2012, 4:23 PM
    Re: I want to play movies without hangs wonko at wonkology May 12, 2012, 5:58 PM
        Re: I want to play movies without hangs mikemol at gmail May 12, 2012, 6:04 PM
    Re: I want to play movies without hangs wonko at wonkology May 17, 2012, 6:21 AM
    Re: I want to play movies without hangs markknecht at gmail May 17, 2012, 6:51 AM
    Re: I want to play movies without hangs mikemol at gmail May 17, 2012, 7:13 AM
    Re: I want to play movies without hangs markknecht at gmail May 17, 2012, 9:05 AM
    Re: I want to play movies without hangs wonko at wonkology May 20, 2012, 2:35 AM

  Index | Next | Previous | View Flat
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.