Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: User

Rsync Failing with no route to host, when there is...

 

 

Gentoo user RSS feed   Index | Next | Previous | View Threaded


nevyn at anferny

Sep 28, 2009, 2:37 AM

Post #1 of 3 (5495 views)
Permalink
Rsync Failing with no route to host, when there is...

Hi,

I have a server that appears unable to rsync for emerge --sync.

When I try I get:

>>> Starting rsync with rsync://204.74.99.100/gentoo-portage...
>>> Checking server timestamp ...
rsync: failed to connect to 204.74.99.100: No route to host (113)
rsync error: error in socket IO (code 10) at clientserver.c(124)
[receiver=3.0.6]

So, i check the IP....

ping 204.74.99.100
PING 204.74.99.100 (204.74.99.100) 56(84) bytes of data.
64 bytes from 204.74.99.100: icmp_seq=1 ttl=55 time=90.7 ms
64 bytes from 204.74.99.100: icmp_seq=2 ttl=55 time=91.6 ms
^C
--- 204.74.99.100 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 90.792/91.241/91.691/0.541 ms

Not a great Ping time, but this is the main rotation, so that server
is in the US and I'm not. I get the same thing using the europeean
rotation....

I've re-emerged rsync, I've checked my world and system are all up
to date.... I've tried opening the firewall....Still nothing.... What
has gone wrong?

Regards

Nev
Attachments: signature.asc (0.25 KB)


wwong at math

Sep 28, 2009, 5:33 AM

Post #2 of 3 (5453 views)
Permalink
Re: Rsync Failing with no route to host, when there is... [In reply to]

On Mon, Sep 28, 2009 at 10:37:45AM +0100, Penguin Lover Nevynxxx squawked:
> I have a server that appears unable to rsync for emerge --sync.
>
> When I try I get:
>
> >>> Starting rsync with rsync://204.74.99.100/gentoo-portage...
> >>> Checking server timestamp ...
> rsync: failed to connect to 204.74.99.100: No route to host (113)
> rsync error: error in socket IO (code 10) at clientserver.c(124)
> [receiver=3.0.6]
>
> So, i check the IP....

Is the rsync server you are connecting to actually running an rsync
daemon? Should be port 873.

Hum, on second thought, host 204.74.99.100 resolves to
crs.ultradns.net which is a redirection service from UltraDNS. This
really suggests that the server you are trying to sync to is no-longer
in the rotation?

W
--
"When I say unbounded, I mean...not bounded."
~DeathMech, S. Sondhi. P-town PHY 205
Sortir en Pantoufles: up 1025 days, 11:17


nevyn at anferny

Sep 28, 2009, 5:52 AM

Post #3 of 3 (5450 views)
Permalink
Re: Rsync Failing with no route to host, when there is... [In reply to]

Willie Wong wrote:
> Is the rsync server you are connecting to actually running an rsync
> daemon? Should be port 873.
>
> Hum, on second thought, host 204.74.99.100 resolves to
> crs.ultradns.net which is a redirection service from UltraDNS. This
> really suggests that the server you are trying to sync to is no-longer
> in the rotation?
>
> W
>
Ah, looks like my mistake. I typed the sync line when I changed it to
the main rotation, and missed the "rsync." from before gentoo org.

Mirrorselect give me the proper list, and it now appears to be working
as it should.

Thanks anyway Willie!

Nev
Attachments: signature.asc (0.25 KB)

Gentoo user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.