Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: User

xterm fonts not loaded

 

 

Gentoo user RSS feed   Index | Next | Previous | View Threaded


val.gentoo at gmail

May 12, 2009, 8:27 AM

Post #1 of 5 (4681 views)
Permalink
xterm fonts not loaded

Hello,

After an update to xorg-1.5.3 (with hal), following the gentoo xorg 1.5
update guide doc, I get warnings when launching a simple xterm. Also
when trying to change the font size (ctrl+left_mouse_button) I get
additional warnings and no font change. Do I need to emerge font packages?

Thanks,

--
Valmor


Warning: Cannot convert string "nil2" to type FontStruct
xterm: cannot load font
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
xterm: cannot load font
-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso10646-1
xterm: cannot load font
-misc-fixed-medium-r-normal--13-120-75-75-c-80-iso10646-1
xterm: cannot load font
-misc-fixed-medium-r-normal--18-120-100-100-c-90-iso10646-1
xterm: cannot load font
-misc-fixed-medium-r-normal--20-200-75-75-c-100-iso10646-1
xterm: cannot load font
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1


val.gentoo at gmail

May 12, 2009, 8:39 AM

Post #2 of 5 (4641 views)
Permalink
Re: xterm fonts not loaded [In reply to]

Valmor de Almeida wrote:
> Hello,
>
> After an update to xorg-1.5.3 (with hal), following the gentoo xorg 1.5
> update guide doc, I get warnings when launching a simple xterm. Also
> when trying to change the font size (ctrl+left_mouse_button) I get
> additional warnings and no font change. Do I need to emerge font packages?
>
> Thanks,
>
> --
> Valmor
>
>
> Warning: Cannot convert string "nil2" to type FontStruct
> xterm: cannot load font
> -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
> Warning: Missing charsets in String to FontSet conversion
> Warning: Unable to load any usable fontset
> xterm: cannot load font
> -misc-fixed-medium-r-normal--14-130-75-75-c-70-iso10646-1
> xterm: cannot load font
> -misc-fixed-medium-r-normal--13-120-75-75-c-80-iso10646-1
> xterm: cannot load font
> -misc-fixed-medium-r-normal--18-120-100-100-c-90-iso10646-1
> xterm: cannot load font
> -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso10646-1
> xterm: cannot load font
> -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
>
>

Just to add to the info above; from Xorg.0.log

(WW) The directory "/usr/share/fonts/TTF/" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/TTF/" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
Entry deleted from font path.
(**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"


Thanks,

--
Valmor


paul.hartman+gentoo at gmail

May 12, 2009, 12:05 PM

Post #3 of 5 (4631 views)
Permalink
Re: xterm fonts not loaded [In reply to]

On Tue, May 12, 2009 at 10:27 AM, Valmor de Almeida
<val.gentoo [at] gmail> wrote:
>
> Hello,
>
> After an update to xorg-1.5.3 (with hal), following the gentoo xorg 1.5
> update guide doc, I get warnings when launching a simple xterm. Also
> when trying to change the font size (ctrl+left_mouse_button) I get
> additional warnings and no font change. Do I need to emerge font packages?

Maybe re-emerge the fonts that you have installed.


paul.hartman+gentoo at gmail

May 12, 2009, 12:11 PM

Post #4 of 5 (4639 views)
Permalink
Re: xterm fonts not loaded [In reply to]

On Tue, May 12, 2009 at 2:05 PM, Paul Hartman
<paul.hartman+gentoo [at] gmail> wrote:
> On Tue, May 12, 2009 at 10:27 AM, Valmor de Almeida
> <val.gentoo [at] gmail> wrote:
>>
>> Hello,
>>
>> After an update to xorg-1.5.3 (with hal), following the gentoo xorg 1.5
>> update guide doc, I get warnings when launching a simple xterm. Also
>> when trying to change the font size (ctrl+left_mouse_button) I get
>> additional warnings and no font change. Do I need to emerge font packages?
>
> Maybe re-emerge the fonts that you have installed.

And specifically make sure that media-fonts/font-misc-misc is not
having problems.


matpe at lysator

May 25, 2009, 8:01 AM

Post #5 of 5 (4582 views)
Permalink
Re: xterm fonts not loaded [In reply to]

Paul Hartman skrev:
> On Tue, May 12, 2009 at 2:05 PM, Paul Hartman
> <paul.hartman+gentoo [at] gmail> wrote:
>> On Tue, May 12, 2009 at 10:27 AM, Valmor de Almeida
>> <val.gentoo [at] gmail> wrote:
>>> Hello,
>>>
>>> After an update to xorg-1.5.3 (with hal), following the gentoo xorg 1.5
>>> update guide doc, I get warnings when launching a simple xterm. Also
>>> when trying to change the font size (ctrl+left_mouse_button) I get
>>> additional warnings and no font change. Do I need to emerge font packages?
>> Maybe re-emerge the fonts that you have installed.
>
> And specifically make sure that media-fonts/font-misc-misc is not
> having problems.
>

I had the same problem with fonts in xterm. I had the errors:
Warning: Cannot convert string "nil2" to type FontStruct
xterm: cannot load font 7x14

The solution for me was to emerge the media-fonts/font-misc-misc package.

It seems that xorg-server-1.5.3 doesn't depend on this, unlike older
xorg-server versions. The fonts dependencies has moved to the newer
x11-base/xorg-x11-7.4 package.

/Mats Persson

Gentoo user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.