Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: SPARC

gentoo on sun v210 running 2.6.x freezes at boot

 

 

Gentoo sparc RSS feed   Index | Next | Previous | View Threaded


peter at citynet

Nov 23, 2005, 7:44 AM

Post #1 of 5 (1138 views)
Permalink
gentoo on sun v210 running 2.6.x freezes at boot

Hi All,

I'm running a SUN v210 with 2.4.32 fine but I have to make an ethernet
bridge and bridge-utils requires 2.6.x
I have compiled a lot of 2.6.x kernels, with udev, with devfs, etc.. but
everytime if the 2.6.x is booting, it freezes at:

VFS: Mounted root (ext3 filesystem) readonly.

I don't see the usual INIT message, it doesn't start the boot runlevel.
It freezes very serious, I can reboot it only after a power-off.

But if I boot with the 2.4.32 then it works pretty well!!!

Have you met this problem earlier?
Any hints, ideas are welcome!
Best Regards,
Peter

--
gentoo-sparc [at] gentoo mailing list


squash at gentoo

Nov 23, 2005, 12:38 PM

Post #2 of 5 (1064 views)
Permalink
Re: gentoo on sun v210 running 2.6.x freezes at boot [In reply to]

Hi Peter,

We see the same problems with the V240 (same board, different case). Dave Miller
(the linux sparc kernel maintainer) does not have access to a similar box, so at
this point, Send Patches. We are having good luck with 2.4.32 except for a few
minor issues.

Josh




NADASI Peter wrote:
> Hi All,
>
> I'm running a SUN v210 with 2.4.32 fine but I have to make an ethernet
> bridge and bridge-utils requires 2.6.x
> I have compiled a lot of 2.6.x kernels, with udev, with devfs, etc.. but
> everytime if the 2.6.x is booting, it freezes at:
>
> VFS: Mounted root (ext3 filesystem) readonly.
>
> I don't see the usual INIT message, it doesn't start the boot runlevel.
> It freezes very serious, I can reboot it only after a power-off.
>
> But if I boot with the 2.4.32 then it works pretty well!!!
>
> Have you met this problem earlier?
> Any hints, ideas are welcome!
> Best Regards,
> Peter
>
Attachments: signature.asc (0.25 KB)


peter at citynet

Nov 23, 2005, 1:11 PM

Post #3 of 5 (1084 views)
Permalink
Re: gentoo on sun v210 running 2.6.x freezes at boot [In reply to]

> We see the same problems with the V240 (same board, different case). Dave Miller
> (the linux sparc kernel maintainer) does not have access to a similar box, so at
> this point, Send Patches. We are having good luck with 2.4.32 except for a few
> minor issues.
and can you make ethernet bridging with 2.4.3x ?
i compiled my kernel with the bridge support, downloaded the
bridge-utils v1.0.6 and it requires the 2.6.x series kernel headers :(((
since bridge-utils 1.x the 2.6.x kernel is needed... i think.
older 0.9.7 versions are compiled fine but i get this message:

#./brctl addbr bri
Get bridge indices failed: Operation not supported
can't setup bridge control: Operation not supported

if I compile it in module, i get the same :(

has anyone experience using bridge in 2.4.x?
Peter

> > I'm running a SUN v210 with 2.4.32 fine but I have to make an ethernet
> > bridge and bridge-utils requires 2.6.x
> > I have compiled a lot of 2.6.x kernels, with udev, with devfs, etc.. but
> > everytime if the 2.6.x is booting, it freezes at:
> >
> > VFS: Mounted root (ext3 filesystem) readonly.
> >
> > I don't see the usual INIT message, it doesn't start the boot runlevel.
> > It freezes very serious, I can reboot it only after a power-off.
> >
> > But if I boot with the 2.4.32 then it works pretty well!!!
> >
> > Have you met this problem earlier?
> > Any hints, ideas are welcome!
> > Best Regards,
> > Peter
> >
>
--
gentoo-sparc [at] gentoo mailing list


squash at gentoo

Nov 23, 2005, 1:26 PM

Post #4 of 5 (1064 views)
Permalink
Re: gentoo on sun v210 running 2.6.x freezes at boot [In reply to]

We are not doing bridging, no. I'd contemplate that the issues are with 32bit
interfaces not existing for it though. A solution would be to use a 64 bit
static brctl binary. I'll see if I still have a 64 bit userland around.

Josh


NADASI Peter wrote:
>>We see the same problems with the V240 (same board, different case). Dave Miller
>>(the linux sparc kernel maintainer) does not have access to a similar box, so at
>>this point, Send Patches. We are having good luck with 2.4.32 except for a few
>>minor issues.
>
> and can you make ethernet bridging with 2.4.3x ?
> i compiled my kernel with the bridge support, downloaded the
> bridge-utils v1.0.6 and it requires the 2.6.x series kernel headers :(((
> since bridge-utils 1.x the 2.6.x kernel is needed... i think.
> older 0.9.7 versions are compiled fine but i get this message:
>
> #./brctl addbr bri
> Get bridge indices failed: Operation not supported
> can't setup bridge control: Operation not supported
>
> if I compile it in module, i get the same :(
>
> has anyone experience using bridge in 2.4.x?
> Peter
>
>
>>>I'm running a SUN v210 with 2.4.32 fine but I have to make an ethernet
>>>bridge and bridge-utils requires 2.6.x
>>>I have compiled a lot of 2.6.x kernels, with udev, with devfs, etc.. but
>>>everytime if the 2.6.x is booting, it freezes at:
>>>
>>>VFS: Mounted root (ext3 filesystem) readonly.
>>>
>>>I don't see the usual INIT message, it doesn't start the boot runlevel.
>>>It freezes very serious, I can reboot it only after a power-off.
>>>
>>>But if I boot with the 2.4.32 then it works pretty well!!!
>>>
>>>Have you met this problem earlier?
>>>Any hints, ideas are welcome!
>>>Best Regards,
>>>Peter
>>>
>>
Attachments: signature.asc (0.25 KB)


peter at citynet

Nov 23, 2005, 1:44 PM

Post #5 of 5 (1064 views)
Permalink
Re: gentoo on sun v210 running 2.6.x freezes at boot [In reply to]

> We are not doing bridging, no. I'd contemplate that the issues are with 32bit
> interfaces not existing for it though. A solution would be to use a 64 bit
> static brctl binary. I'll see if I still have a 64 bit userland around.
how to make a 64bit static brctl binary at kernel 2.4.32?

I can't compile the current bridge-utils with 2.4.x :(
bye
peter

>
> Josh
>
>
> NADASI Peter wrote:
> >>We see the same problems with the V240 (same board, different case). Dave Miller
> >>(the linux sparc kernel maintainer) does not have access to a similar box, so at
> >>this point, Send Patches. We are having good luck with 2.4.32 except for a few
> >>minor issues.
> >
> > and can you make ethernet bridging with 2.4.3x ?
> > i compiled my kernel with the bridge support, downloaded the
> > bridge-utils v1.0.6 and it requires the 2.6.x series kernel headers :(((
> > since bridge-utils 1.x the 2.6.x kernel is needed... i think.
> > older 0.9.7 versions are compiled fine but i get this message:
> >
> > #./brctl addbr bri
> > Get bridge indices failed: Operation not supported
> > can't setup bridge control: Operation not supported
> >
> > if I compile it in module, i get the same :(
> >
> > has anyone experience using bridge in 2.4.x?
> > Peter
> >
> >
> >>>I'm running a SUN v210 with 2.4.32 fine but I have to make an ethernet
> >>>bridge and bridge-utils requires 2.6.x
> >>>I have compiled a lot of 2.6.x kernels, with udev, with devfs, etc.. but
> >>>everytime if the 2.6.x is booting, it freezes at:
> >>>
> >>>VFS: Mounted root (ext3 filesystem) readonly.
> >>>
> >>>I don't see the usual INIT message, it doesn't start the boot runlevel.
> >>>It freezes very serious, I can reboot it only after a power-off.
> >>>
> >>>But if I boot with the 2.4.32 then it works pretty well!!!
> >>>
> >>>Have you met this problem earlier?
> >>>Any hints, ideas are welcome!
> >>>Best Regards,
> >>>Peter
> >>>
> >>
>
--
gentoo-sparc [at] gentoo mailing list

Gentoo sparc RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.