Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: PPC-User

install ISO not bootable

 

 

Gentoo ppc-user RSS feed   Index | Next | Previous | View Threaded


cristiandeives at gmail

Sep 5, 2009, 10:05 AM

Post #1 of 7 (4527 views)
Permalink
install ISO not bootable

hi!

I want to install Gentoo on a PowerPC machine, but I can't find a
bootable ISO. I've tried install-powerpc-minimal-20090809 and
install-powerpc-universal-2008.0 but none of those files boot. where
can I find a bootable Gentoo image, or how can I make it bootable?

see you,

--
Crístian Deives dos Santos Viana [aka CD1]
Sent from Campinas, SP, Brazil


mattmatteh at mac

Sep 5, 2009, 11:10 AM

Post #2 of 7 (4319 views)
Permalink
Re: install ISO not bootable [In reply to]

On Sat, 5 Sep 2009, Crístian Viana wrote:

> hi!
>
> I want to install Gentoo on a PowerPC machine, but I can't find a
> bootable ISO. I've tried install-powerpc-minimal-20090809 and
> install-powerpc-universal-2008.0 but none of those files boot. where
> can I find a bootable Gentoo image, or how can I make it bootable?
>
> see you,

i thought something was broke with powerpc-minimal-20090809, there was
chat on irc about it.

try install-powerpc-minimal-2008.0.iso ? i dont remember if i used that
one or not.

what powerpc computer do you have ?

matt


cristiandeives at gmail

Sep 6, 2009, 6:48 AM

Post #3 of 7 (4338 views)
Permalink
Re: install ISO not bootable [In reply to]

I tried install-powerpc-minimal-2008.0, it didn't work too. I have an IBM
pSeries POWER4.

On Sat, Sep 5, 2009 at 3:10 PM, <mattmatteh [at] mac> wrote:

> On Sat, 5 Sep 2009, Crístian Viana wrote:
>
> hi!
>>
>> I want to install Gentoo on a PowerPC machine, but I can't find a
>> bootable ISO. I've tried install-powerpc-minimal-20090809 and
>> install-powerpc-universal-2008.0 but none of those files boot. where
>> can I find a bootable Gentoo image, or how can I make it bootable?
>>
>> see you,
>>
>
> i thought something was broke with powerpc-minimal-20090809, there was chat
> on irc about it.
>
> try install-powerpc-minimal-2008.0.iso ? i dont remember if i used that
> one or not.
>
> what powerpc computer do you have ?
>
> matt




--
Crístian Deives dos Santos Viana [aka CD1]


mattmatteh at mac

Sep 6, 2009, 11:42 AM

Post #4 of 7 (4321 views)
Permalink
Re: install ISO not bootable [In reply to]

On Sun, 6 Sep 2009, Crístian Viana wrote:

> I tried install-powerpc-minimal-2008.0, it didn't work too. I have an IBM
> pSeries POWER4.
>
>> try install-powerpc-minimal-2008.0.iso ? i dont remember if i used that
>> one or not.
>>
>> what powerpc computer do you have ?
>>
>> matt
>

i only have 2 ibooks here. not familiar with ibm hardware


cristiandeives at gmail

Sep 6, 2009, 12:52 PM

Post #5 of 7 (4329 views)
Permalink
Re: install ISO not bootable [In reply to]

is there any way I can boot the CD through yaboot? I'm not familiar with
this program. I googled about it and I found out I can type something like:

cd:1,/boot/yaboot

but that doesn't work for me. I guess it has something to do with the "boot"
directory on the ISO image, but I don't know if I can point to other file
(like /boot/ibmpower).

any other suggestion of how to boot will be appreciated, when the CD doesn't
boot itself. there's a Red Hat already installed on the machine, if it
helps. and I think the floppy drive isn't working, so I can't use it (it
shows input/output errors when I try to access some disks). so my options
are: use yaboot to boot the CD, do a network install (never done it) or use
the existing Linux. any idea?

see you,

On Sun, Sep 6, 2009 at 3:42 PM, <mattmatteh [at] mac> wrote:

> On Sun, 6 Sep 2009, Crístian Viana wrote:
>
> I tried install-powerpc-minimal-2008.0, it didn't work too. I have an IBM
>> pSeries POWER4.
>>
>> try install-powerpc-minimal-2008.0.iso ? i dont remember if i used that
>>> one or not.
>>>
>>> what powerpc computer do you have ?
>>>
>>> matt
>>>
>>
>>
> i only have 2 ibooks here. not familiar with ibm hardware




--
Crístian Deives dos Santos Viana [aka CD1]
Sent from Campinas, SP, Brazil


kahl at cas

Sep 6, 2009, 5:41 PM

Post #6 of 7 (4315 views)
Permalink
Re: install ISO not bootable [In reply to]

Cristian,
>
> any other suggestion of how to boot will be appreciated, when the CD doesn't
> boot itself. there's a Red Hat already installed on the machine, if it
> helps. and I think the floppy drive isn't working, so I can't use it (it
> shows input/output errors when I try to access some disks). so my options
> are: use yaboot to boot the CD, do a network install (never done it) or use
> the existing Linux. any idea?

Using the existing linux should definitely be an option --- you just use that
instead of the bood CD (I have done this once on AMD64 from ubuntu).

I.e., you login as root, make sure the network is working
and you have sufficient free partitions for your install
except that you must not use the partition of the existing linux,
and then you just go along the handbook from after partitioning:
unpack stages, chroot, continue install (and make sure you know
what you are doing at each step, in case you may have to adapt).

If possible, keep a terminal or console open in the original system
(outside the chroot) (and never confuse the two!), as sometimes
it might come in handy.

Find out what the bootloader installation is that boots RedHat ---
you can possibly hijack it and insert Gentoo either as another alternative
(preferable) or instead of RedHat.
Since you cannot boot from CD, the bootloader step is going to be the most
critical step of the whole install.


Good luck!



Wolfram


mattmatteh at mac

Sep 6, 2009, 9:37 PM

Post #7 of 7 (4324 views)
Permalink
Re: install ISO not bootable [In reply to]

you can add enablecdboot in yaboot.conf, but not sure if that works on
ibm.

matt

On Sun, 6 Sep 2009, Crístian Viana wrote:

> is there any way I can boot the CD through yaboot? I'm not familiar with
> this program. I googled about it and I found out I can type something like:
>
> cd:1,/boot/yaboot
>
> but that doesn't work for me. I guess it has something to do with the "boot"
> directory on the ISO image, but I don't know if I can point to other file
> (like /boot/ibmpower).
>
> any other suggestion of how to boot will be appreciated, when the CD doesn't
> boot itself. there's a Red Hat already installed on the machine, if it
> helps. and I think the floppy drive isn't working, so I can't use it (it
> shows input/output errors when I try to access some disks). so my options
> are: use yaboot to boot the CD, do a network install (never done it) or use
> the existing Linux. any idea?
>
> see you,
>
> On Sun, Sep 6, 2009 at 3:42 PM, <mattmatteh [at] mac> wrote:
>
>> On Sun, 6 Sep 2009, Crístian Viana wrote:
>>
>> I tried install-powerpc-minimal-2008.0, it didn't work too. I have an IBM
>>> pSeries POWER4.
>>>
>>> try install-powerpc-minimal-2008.0.iso ? i dont remember if i used that
>>>> one or not.
>>>>
>>>> what powerpc computer do you have ?
>>>>
>>>> matt
>>>>
>>>
>>>
>> i only have 2 ibooks here. not familiar with ibm hardware
>
>
>
>
> --
> Crístian Deives dos Santos Viana [aka CD1]
> Sent from Campinas, SP, Brazil
>

Gentoo ppc-user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.