Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: PPC-User

"yabootconfig: /dev/ROOT: No such file or directory" why?

 

 

Gentoo ppc-user RSS feed   Index | Next | Previous | View Threaded


mv1001 at gmail

Jun 30, 2009, 3:25 PM

Post #1 of 3 (3858 views)
Permalink
"yabootconfig: /dev/ROOT: No such file or directory" why?

Hi,
I have a problem here. I follow everything step by step from handbook. but
it always stopped here. I tried many time and searched it in google. but
Can't find answers.
the problem is:
After I install yaboot in chroot environment. then I exit it, and try
"yabootconfig --chroot /mnt/gentoo". but I got "yabootconfig: /dev/ROOT: No
such file or directory". I guess it's fstab problem, but how to mount
Apple_Bootstrap in fstab?
Anyone can help me?

Thanks in Adv.

James
--
View this message in context: http://www.nabble.com/%22yabootconfig%3A--dev-ROOT%3A-No-such-file-or-directory%22-why--tp24280943p24280943.html
Sent from the gentoo-ppc-user mailing list archive at Nabble.com.


markknecht at gmail

Jun 30, 2009, 3:54 PM

Post #2 of 3 (3682 views)
Permalink
Re: "yabootconfig: /dev/ROOT: No such file or directory" why? [In reply to]

On Tue, Jun 30, 2009 at 3:25 PM, mv.1001<mv1001 [at] gmail> wrote:
>
> Hi,
> I have a problem here. I follow everything step by step from handbook. but
> it always stopped here. I tried many time and searched it in google. but
> Can't find answers.
> the problem is:
> After I install yaboot in chroot environment. then I exit it, and try
> "yabootconfig --chroot /mnt/gentoo". but I got "yabootconfig: /dev/ROOT: No
> such file or directory". I guess it's fstab problem, but how to mount
> Apple_Bootstrap in fstab?
> Anyone can help me?
>
> Thanks in Adv.
>
> James
> --
> View this message in context: http://www.nabble.com/%22yabootconfig%3A--dev-ROOT%3A-No-such-file-or-directory%22-why--tp24280943p24280943.html
> Sent from the gentoo-ppc-user mailing list archive at Nabble.com.
>
>
>

Sounds to me like you didn't update fstab. Here's my fstab and
yaboot.conf files from my Mac Mini MythTV backend server. If you make
changes to yaboot.conf by hand remember to run ybin -v.

Hope this helps,
Mark

MacMini ~ # cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts>
<dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda4 / ext3 noatime 0 1
/dev/hda3 none swap sw 0 0
/dev/cdrom /mnt/cdrom audo noauto,ro 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
shm /dev/shm tmpfs
nodev,nosuid,noexec 0 0

#/dev/sda1 /video ext3 auto,rw 0 2
MacMini ~ #



MacMini ~ # cat /etc/yaboot.conf
boot=/dev/hda2

device=/pci [at] f400000/ata-6@d/disk@0:2

partition=4

delay=5

default=2.6.28-gentoo-r5
timeout=300
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/kernel-2.6.28-gentoo-r5
label=2.6.28-gentoo-r5
root=/dev/hda4
partition=4
append="video=radeonfb:1024x768-8 [at] 6"
read-only

image=/boot/kernel-2.6.24-gentoo-r3
label=2.6.24-gentoo-r3
root=/dev/hda4
partition=4
append="video=radeonfb:1024x768-8 [at] 6"
read-only
MacMini ~ #


josejx at gentoo

Jun 30, 2009, 6:53 PM

Post #3 of 3 (3667 views)
Permalink
Re: "yabootconfig: /dev/ROOT: No such file or directory" why? [In reply to]

mv.1001 wrote:
> Hi,
> I have a problem here. I follow everything step by step from handbook. but
> it always stopped here. I tried many time and searched it in google. but
> Can't find answers.
> the problem is:
> After I install yaboot in chroot environment. then I exit it, and try
> "yabootconfig --chroot /mnt/gentoo". but I got "yabootconfig: /dev/ROOT: No
> such file or directory". I guess it's fstab problem, but how to mount
> Apple_Bootstrap in fstab?
> Anyone can help me?
>
> Thanks in Adv.
>
> James
>
You're close with suspecting that it's an fstab issue, but the issue is
actually that you haven't defined your root partition in the fstab. This
is set to a nonsense value of "/dev/ROOT" by default and it must be
changed before running yabootconfig. With the default partition layout
shown in the handbook, the root partition line would be changed to say
"/dev/hda3".

Hope that helps,
-Joe

Gentoo ppc-user RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.