Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201207-09 ] mod_fcgid: Multiple vulnerabilities

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Jul 9, 2012, 4:50 PM

Post #1 of 1 (167 views)
Permalink
[ GLSA 201207-09 ] mod_fcgid: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201207-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: mod_fcgid: Multiple vulnerabilities
Date: July 09, 2012
Bugs: #344685, #409373
ID: 201207-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in mod_fcgid, allowing
execution of arbitrary code or Denial of Service.

Background
==========

mod_fcgid is a binary-compatible alternative to mod_fastcgi with better
process management.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-apache/mod_fcgid < 2.3.7 >= 2.3.7

Description
===========

Multiple vulnerabilities have been found in mod_fcgid:

* An error in the "fcgid_header_bucket_read()" function in
fcgid_bucket.c could cause a stack-based buffer overflow
(CVE-2010-3872).
* An error in the "is_spawn_allowed() function in fcgid_spawn_ctl.c
prevents Apache from recognizing the FcgidMaxProcessesPerClass
directive for a virtual host (CVE-2012-1181).

Impact
======

A local attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.
Furthermore, a remote attacker could send specially crafted HTTP
requests, possibly resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All mod_fcgid users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apache/mod_fcgid-2.3.7"

References
==========

[ 1 ] CVE-2010-3872
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3872
[ 2 ] CVE-2012-1181
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1181

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201207-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.