Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201206-16 ] TagLib: Multiple vulnerabilities

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Jun 22, 2012, 9:50 AM

Post #1 of 1 (97 views)
Permalink
[ GLSA 201206-16 ] TagLib: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201206-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: TagLib: Multiple vulnerabilities
Date: June 22, 2012
Bugs: #407673, #410953
ID: 201206-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in TagLib, possibly resulting
in Denial of Service.

Background
==========

TagLib is a library for reading and editing audio meta data.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/taglib < 1.7.1 >= 1.7.1

Description
===========

Multiple vulnerabilities have been found in TagLib:

* The "analyzeCurrent()" function in ape/apeproperties.cpp contains a
division by zero error (CVE-2012-1107).
* The "parse()" function in inogg/xiphcomment.cpp contains an error
when processing the "vendorLength" field (CVE-2012-1108).
* The "mid()" function in toolkit/tbytevector.cpp contains an integer
overflow error (CVE-2012-1584).

Impact
======

A remote attacker could entice a user or automated system to open a
specially crafted OGG file with an application using TagLib, possibly
resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All TagLib users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/taglib-1.7.1"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2012-1107
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1107
[ 2 ] CVE-2012-1108
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1108
[ 3 ] CVE-2012-1584
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1584

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201206-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.