Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201206-02 ] QtGui: User-assisted execution of arbitrary code

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Jun 3, 2012, 4:50 AM

Post #1 of 1 (115 views)
Permalink
[ GLSA 201206-02 ] QtGui: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201206-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: QtGui: User-assisted execution of arbitrary code
Date: June 03, 2012
Bugs: #384089
ID: 201206-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in QtGui could result in execution of arbitrary code
or Denial of Service.

Background
==========

QtGui is a module for the Qt toolkit.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-libs/qt-gui < 4.7.4-r1 >= 4.7.4-r1

Description
===========

An error in qtiffhandler.cpp could cause a buffer overflow.

Impact
======

A remote attacker could entice a user to open a specially crafted TIFF
image with an application linked against QtGui, possibly resulting in
execution of arbitrary code with the privileges of the process or a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All QtGui users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/qt-gui-4.7.4-r1"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2011-3194
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3194

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201206-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.