Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201204-06 ] PolicyKit: Multiple vulnerabilities

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Apr 17, 2012, 4:42 PM

Post #1 of 1 (164 views)
Permalink
[ GLSA 201204-06 ] PolicyKit: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201204-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: PolicyKit: Multiple vulnerabilities
Date: April 17, 2012
Bugs: #314535, #364973, #401513
ID: 201204-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PolicyKit, the worst of
which may allow a local attacker to gain root privileges.

Background
==========

PolicyKit is a toolkit for controlling privileges for system-wide
services.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-auth/polkit < 0.104-r1 >= 0.104-r1

Description
===========

Multiple vulnerabilities have been found in PolicyKit:

* Error messages in the pkexec utility disclose the existence of local
files (CVE-2010-0750).
* The pkexec utility initially checks the effective user ID of its
parent process for authorization, instead of checking the real user
ID (CVE-2011-1485).
* Members of the "wheel" group are able to execute commands as an
administrator without a password (CVE-2011-4945).

Impact
======

A local attacker could gain elevated privileges or sensitive
information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PolicyKit users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-auth/polkit-0.104-r1"

References
==========

[ 1 ] CVE-2010-0750
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0750
[ 2 ] CVE-2011-1485
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1485
[ 3 ] CVE-2011-4945
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4945

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201204-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.