Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201203-17 ] HPLIP: Multiple vulnerabilities

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Mar 16, 2012, 5:36 AM

Post #1 of 1 (190 views)
Permalink
[ GLSA 201203-17 ] HPLIP: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201203-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: HPLIP: Multiple vulnerabilities
Date: March 16, 2012
Bugs: #352085, #388655
ID: 201203-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in HPLIP, the worst of which
may allow execution of arbitrary code.

Background
==========

The Hewlett-Packard Linux Imaging and Printing system (HPLIP) provides
drivers for HP's inkjet and laser printers, scanners and fax machines.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-print/hplip < 3.11.10 >= 3.11.10

Description
===========

Two vulnerabilities have been found in HPLIP:

* The "hpmud_get_pml()" function in pml.c contains a boundary error
which could cause a stack-based buffer overflow (CVE-2010-4267).
* The "send_data_to_stdout()" function in hpcupsfax.cpp creates
insecure temporary files (CVE-2011-2722).

Impact
======

A remote attacker might send specially crafted SNMP reponses, possibly
resulting in execution of arbitrary code or a Denial of Service
condition. Furthermore, a local attacker could perform symlink attacks
to overwrite arbitrary files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All HPLIP users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-print/hplip-3.11.10"

References
==========

[ 1 ] CVE-2010-4267
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4267
[ 2 ] CVE-2011-2722
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2722

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201203-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.