Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce
[ GLSA 201203-15 ] gif2png: Multiple vulnerabilities
 

Index | Next | Previous | View Flat


ackle at gentoo

Mar 16, 2012, 4:43 AM


Views: 148
Permalink
[ GLSA 201203-15 ] gif2png: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201203-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: gif2png: Multiple vulnerabilities
Date: March 16, 2012
Bugs: #351698
ID: 201203-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in gif2png, the worst of which
might allow execution of arbitrary code.

Background
==========

gif2png converts images from GIF format to PNG format.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/gif2png < 2.5.8 >= 2.5.8

Description
===========

Two vulnerabilities have been found in gif2png:

* A boundary error in gif2png.c could cause a buffer overflow
(CVE-2010-4694).
* The patch for CVE-2009-5018 causes gif2png to truncate GIF pathnames
(CVE-2010-4695).

Impact
======

A remote attacker could entice a user to open a specially crafted GIF
file, possibly resulting in execution of arbitrary code, a Denial of
Service condition, or the creation of PNG files in unintended
directories.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All gif2png users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/gif2png-2.5.8"

References
==========

[ 1 ] CVE-2010-4694
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4694
[ 2 ] CVE-2010-4695
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4695

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201203-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Subject User Time
[ GLSA 201203-15 ] gif2png: Multiple vulnerabilities ackle at gentoo Mar 16, 2012, 4:43 AM

  Index | Next | Previous | View Flat
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.