Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201203-07 ] foomatic-filters: User-assisted execution of arbitrary code

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Mar 5, 2012, 6:05 PM

Post #1 of 1 (115 views)
Permalink
[ GLSA 201203-07 ] foomatic-filters: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201203-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: foomatic-filters: User-assisted execution of arbitrary code
Date: March 06, 2012
Bugs: #379559
ID: 201203-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in foomatic-filters could result in the execution of
arbitrary code.

Background
==========

The foomatic-filters package contains wrapper scripts which are
designed to be used with Foomatic.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-print/foomatic-filters
< 4.0.9 >= 4.0.9

Description
===========

The foomatic-rip filter improperly handles command-line arguments,
including those issued by FoomaticRIPCommandLine fields in PPD files.

Impact
======

A remote attacker could entice a user to open a specially crafted PPD
file, possibly resulting in execution of arbitrary code with the
privileges of the system user "lp".

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All foomatic-filters users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=net-print/foomatic-filters-4.0.9"

References
==========

[ 1 ] CVE-2011-2697
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2697
[ 2 ] CVE-2011-2964
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2964

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201203-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.