Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201203-06 ] sudo: Privilege escalation

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Mar 5, 2012, 6:03 PM

Post #1 of 1 (134 views)
Permalink
[ GLSA 201203-06 ] sudo: Privilege escalation

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201203-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: sudo: Privilege escalation
Date: March 06, 2012
Bugs: #351490, #401533
ID: 201203-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities have been discovered in sudo, allowing local
attackers to possibly gain escalated privileges.

Background
==========

sudo allows a system administrator to give users the ability to run
commands as other users.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/sudo < 1.8.3_p2 >= 1.8.3_p2
*>= 1.7.4_p5

Description
===========

Two vulnerabilities have been discovered in sudo:

* When the sudoers file is configured with a Runas group, sudo does not
prompt for a password when changing to the new group (CVE-2011-0010).
* A format string vulnerability exists in the "sudo_debug()" function
(CVE-2012-0809).

Impact
======

A local attacker could possibly gain the ability to run arbitrary
commands with the privileges of other users or groups, including root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All sudo users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/sudo-1.8.3_p2"

References
==========

[ 1 ] CVE-2011-0010
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0010
[ 2 ] CVE-2012-0809
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0809

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201203-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.