Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201201-06 ] iSCSI Enterprise Target: Arbitrary code execution

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


ackle at gentoo

Jan 23, 2012, 4:08 AM

Post #1 of 1 (122 views)
Permalink
[ GLSA 201201-06 ] iSCSI Enterprise Target: Arbitrary code execution

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201201-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: iSCSI Enterprise Target: Arbitrary code execution
Date: January 23, 2012
Bugs: #314187
ID: 201201-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Format string vulnerabilities in iSCSI Enterprise Target could result
in execution of arbitrary code or a Denial of Service.

Background
==========

iSCSI Enterprise Target is an open source iSCSI target with
professional features.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-block/iscsitarget < 1.4.19 >= 1.4.19

Description
===========

Multiple functions in usr/iscsi/isns.c of iSCSI Enterprise Target
contain format string errors.

Impact
======

A remote attacker could send a specially-crafted Internet Storage Name
Service (iSNS) request, possibly resulting in the execution of
arbitrary code with root privileges or cause a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All iSCSI Enterprise Target users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-block/iscsitarget-1.4.19"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 11, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-0743
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0743

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201201-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.29 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.