Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201010-01 ] Libpng: Multiple vulnerabilities

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


py at gentoo

Oct 5, 2010, 2:30 PM

Post #1 of 1 (485 views)
Permalink
[ GLSA 201010-01 ] Libpng: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201010-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Libpng: Multiple vulnerabilities
Date: October 05, 2010
Bugs: #307637, #324153, #335887
ID: 201010-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in libpng might lead to privilege escalation
or a Denial of Service.

Background
==========

libpng is a standard library used to process PNG (Portable Network
Graphics) images. It is used by several programs, including web
browsers and potentially server processes.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libpng < 1.4.3 >= 1.4.3

Description
===========

Multiple vulnerabilities were found in libpng:

* The png_decompress_chunk() function in pngrutil.c does not properly
handle certain type of compressed data (CVE-2010-0205)

* A buffer overflow in pngread.c when using progressive applications
(CVE-2010-1205)

* A memory leak in pngrutil.c when dealing with a certain type of
chunks (CVE-2010-2249)

Impact
======

An attacker could exploit these vulnerabilities to cause programs
linked against the library to crash or execute arbitrary code with the
permissions of the user running the vulnerable program, which could be
the root user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libpng users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libpng-1.4.3"

References
==========

[ 1 ] CVE-2010-0205
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0205
[ 2 ] CVE-2010-1205
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1205
[ 3 ] CVE-2010-2249
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2249

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201010-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.26 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.