Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 201009-04 ] SARG: User-assisted execution of arbitrary code

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


craig at gentoo

Sep 7, 2010, 12:13 PM

Post #1 of 1 (565 views)
Permalink
[ GLSA 201009-04 ] SARG: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201009-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: SARG: User-assisted execution of arbitrary code
Date: September 07, 2010
Bugs: #222121
ID: 201009-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple stack-based buffer overflow vulnerabilities were discovered in
SARG allowing for remote code execution.

Background
==========

SARG is the Squid Analysis Report Generator.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/sarg < 2.2.5-r5 >= 2.2.5-r5

Description
===========

Multiple vulnerabilities were discovered in SARG. For further
information please consult the CVE entries referenced below.

Impact
======

These vulnerabilities might allow attackers to execute arbitrary code
via unknown vectors.

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since April 18, 2009. It is likely that your system is
already no longer affected by this issue.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All SARG users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-analyzer/sarg-2.2.5-r5"

References
==========

[ 1 ] CVE-2008-1922
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1922

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201009-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.26 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.