Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Announce

[ GLSA 200909-18 ] nginx: Remote execution of arbitrary code

 

 

Gentoo announce RSS feed   Index | Next | Previous | View Threaded


a3li at gentoo

Sep 18, 2009, 12:45 PM

Post #1 of 1 (609 views)
Permalink
[ GLSA 200909-18 ] nginx: Remote execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200909-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: nginx: Remote execution of arbitrary code
Date: September 18, 2009
Bugs: #285162
ID: 200909-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer underflow vulnerability in the request URI processing of nginx
might enable remote attackers to execute arbitrary code or cause a
Denial of Service.

Background
==========

nginx is a robust, small and high performance HTTP and reverse proxy
server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/nginx < 0.7.62 *>= 0.5.38
*>= 0.6.39
>= 0.7.62

Description
===========

Chris Ries reported a heap-based buffer underflow in the
ngx_http_parse_complex_uri() function in http/ngx_http_parse.c when
parsing the request URI.

Impact
======

A remote attacker might send a specially crafted request URI to a nginx
server, possibly resulting in the remote execution of arbitrary code
with the privileges of the user running the server, or a Denial of
Service. NOTE: By default, nginx runs as the "nginx" user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All nginx 0.5.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose =www-servers/nginx-0.5.38

All nginx 0.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose =www-servers/nginx-0.6.39

All nginx 0.7.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose =www-servers/nginx-0.7.62

References
==========

[ 1 ] CVE-2009-2629
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2629

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200909-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security [at] gentoo or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachments: signature.asc (0.19 KB)

Gentoo announce RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.