Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Gentoo: Alpha

glibc2.5 build failed on alpha platform(both r2 and r3) with ntpl

 

 

Gentoo alpha RSS feed   Index | Next | Previous | View Threaded


wangbj at lzu

Jun 25, 2007, 2:08 AM

Post #1 of 4 (3938 views)
Permalink
glibc2.5 build failed on alpha platform(both r2 and r3) with ntpl

hi, list:

I got the following problem while emerge world (--update --deep --newuse):

gentoo 2007.0

USE FLAGS:

USE="-X -gtk -gnome -qt3 -qt4 -kde -java"
USE="$USE nptl nptlonly hal avahi ipv6 xml aio tcpd bzip2 zlib unicode cscope
bash-completion acl vim emacs threads fortran iconv"

portage version: 20070623
Gentoo Base System release 1.12.9 (/etc/gentoo-release)

glibc version: 2.5-r2(2.5-r3 also has the same problem)
platform: DEC alpha 4100(ev56)

error message while

# emerge glibc

alpha-unknown-linux-gnu-gcc ../sysdeps/unix/sysv/linux/alpha/sigsuspend.S -c -I../include -I/var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal -I/var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl -I../nptl/sysdeps/alpha/elf -I../sysdeps/alpha/elf -I../sysdeps/unix/sysv/linux/alpha/alpha -I../nptl/sysdeps/unix/sysv/linux/alpha -I../sysdeps/unix/sysv/linux/alpha -I../sysdeps/unix/sysv/linux/wordsize-64 -I../sysdeps/ieee754/ldbl-64-128 -I../sysdeps/ieee754/ldbl-opt -I../ports/sysdeps/unix/sysv/linux -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/alpha -I../ports/sysdeps/unix -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/alpha/fpu -I../nptl/sysdeps/alpha -I../sysdeps/alpha -I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-128 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/alpha/soft-fp -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../ports -I../nptl -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/alpha-unknown-linux-gnu/4.1.2/include -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h -DASSEMBLER -Wa,--noexecstack -o /var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal/sigsuspend.o -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal/sigsuspend.o.dt -MT /var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal/sigsuspend.o
../sysdeps/unix/sysv/linux/alpha/sigsuspend.S: Assembler messages:
../sysdeps/unix/sysv/linux/alpha/sigsuspend.S:41: Error: previous CFI entry
not closed (missing .cfi_endproc)
../sysdeps/unix/sysv/linux/alpha/sigsuspend.S:43: Error: .cfi_endproc without
corresponding .cfi_startproc
make[2]: ***
[/var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal/sigsuspend.o]
Error 1
make[2]: Leaving directory
`/var/tmp/portage/sys-libs/glibc-2.5-r2/work/glibc-2.5/signal'
make[1]: *** [signal/subdir_lib] Error 2
make[1]: Leaving directory
`/var/tmp/portage/sys-libs/glibc-2.5-r2/work/glibc-2.5'
make: *** [all] Error 2

I check the debian(ubuntu) glibc patch set, it contain a patch named
`submitted-sigsuspend.diff', I have tried to apply the patch, but it didn't
help, though. the attachment is the patch.

any idea to fix this problem? thanks in advance!

regards, Wang
--
Wang, Baojun Lanzhou University
Distributed & Embedded System Lab http://dslab.lzu.edu.cn
School of Information Science and Engeneering wangbj [at] lzu
Tianshui South Road 222. Lanzhou 730000 .P.R.China
Tel:+86-931-8912025 Fax:+86-931-8912022
Attachments: submitted-sigsuspend.diff (0.87 KB)


davide.cittaro at ifom-ieo-campus

Jun 25, 2007, 2:46 AM

Post #2 of 4 (3709 views)
Permalink
Re: glibc2.5 build failed on alpha platform(both r2 and r3) with ntpl [In reply to]

Hi, as Bryan suggested me some time ago, you can try to "upgrade to
binutils >=2.17.50.0.15 and risk possible unknown bugs
from doing so."
I've tried this and the machine seems to be pretty stable (Ok, I had
an CTERM hardware failure, but I hope it is related to old hardware
malfunction!)...

d
/*
Davide Cittaro
HPC and Bioinformatics Systems @ Informatics Core

IFOM - Istituto FIRC di Oncologia Molecolare
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
e-mail: davide.cittaro [at] ifom-ieo-campus
*/


wangbj at lzu

Jun 25, 2007, 5:01 AM

Post #3 of 4 (3723 views)
Permalink
Re: glibc2.5 build failed on alpha platform(both r2 and r3) with ntpl [In reply to]

On Monday 25 June 2007 17:46, Davide Cittaro wrote:
> Hi, as Bryan suggested me some time ago, you can try to "upgrade to
> binutils >=2.17.50.0.15 and risk possible unknown bugs
> from doing so."
> I've tried this and the machine seems to be pretty stable (Ok, I had
> an CTERM hardware failure, but I hope it is related to old hardware
> malfunction!)...
It's works, thanks very much!

binutils used: 2.17.50.0.16.20070511

I think it should also solve the problem when building linux kernel, the
assembler always complain (assembler warnings).

Wang
> d
> /*
> Davide Cittaro
> HPC and Bioinformatics Systems @ Informatics Core
>
> IFOM - Istituto FIRC di Oncologia Molecolare
> via adamello, 16
> 20139 Milano
> Italy
>
> tel.: +39(02)574303007
> e-mail: davide.cittaro [at] ifom-ieo-campus
> */

--
Wang, Baojun Lanzhou University
Distributed & Embedded System Lab http://dslab.lzu.edu.cn
School of Information Science and Engeneering wangbj [at] lzu
Tianshui South Road 222. Lanzhou 730000 .P.R.China
Tel:+86-931-8912025 Fax:+86-931-8912022


yoswink at gentoo

Jul 1, 2007, 3:26 PM

Post #4 of 4 (3710 views)
Permalink
Re: glibc2.5 build failed on alpha platform(both r2 and r3) with ntpl [In reply to]

Hi all:

El Mon, 25 Jun 2007 17:08:29 +0800
"Wang, Baojun" <wangbj [at] lzu> escribió:

> Assembler messages: ../sysdeps/unix/sysv/linux/alpha/sigsuspend.S:41:
> Error: previous CFI entry not closed
> (missing .cfi_endproc) ../sysdeps/unix/sysv/linux/alpha/sigsuspend.S:43:
> Error: .cfi_endproc without corresponding .cfi_startproc make[2]: ***
> [/var/tmp/portage/sys-libs/glibc-2.5-r2/work/build-default-alpha-unknown-linux-gnu-nptl/signal/sigsuspend.o]

> any idea to fix this problem? thanks in advance!

I've just marked the version 2.17.50.0.16 as stable in alpha which
solves the problem with glibc. Details in #179353[1].

Thanks to all the people for the reports and help.

[1] https://bugs.gentoo.org/179353
--
Jose Luis Rivero [yoswink [at] gentoo]
Gentoo/Doc Gentoo/Alpha
--
gentoo-alpha [at] gentoo mailing list

Gentoo alpha RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.