Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Forrest: Dev

[jira] [Issue Comment Edited] (FOR-1233) Forrest's PDF plugin configuration documentation seems to be incorrect

 

 

Forrest dev RSS feed   Index | Next | Previous | View Threaded


jira at apache

Jan 30, 2012, 11:54 PM

Post #1 of 2 (484 views)
Permalink
[jira] [Issue Comment Edited] (FOR-1233) Forrest's PDF plugin configuration documentation seems to be incorrect

[ https://issues.apache.org/jira/browse/FOR-1233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13196767#comment-13196767 ]

Karl Wright edited comment on FOR-1233 at 1/31/12 7:52 AM:
-----------------------------------------------------------

Thanks for the reference. But while I understand how entities work, but I still don't understand what I need to do to the project xml catalog to "configure them".

As the linked document points out, "You can supply lists of symbols for your own project too. Create a fresh site with 'forrest seed' and see the set at the src/documentation/resources/schema/symbols-project-v10.ent file. Copy that file to your own projects at the same location. Also add the entry to your project xml catalog as shown in the seed site at src/documentation/resources/schema/catalog.xcat file." We had a file at this location which did not seem to be read. (I've now removed it and we patch Forrest directly.) That is what I'm talking about. According to your doc, this file is supposedly created when you run "forrest seed". Now, our site was created several Forrest versions back, but simply copying or creating a symbols-project-v10.ent file in the above location had no effect. It is possible that some supporting collateral elsewhere in the site should also be modified, but I have absolutely no idea what that collateral would be, and I can find no doc that tells me what I'd need to do.

Perhaps the solution is, "if your site was created using "forrest seed" using a forrest version less than 0.90, you must recreate your site to get it to work". If so, the doc should state that clearly.


was (Author: kwright [at] metacarta):
I understand how entities work, but I don't understand what I need to do to the project xml catalog to configure them.

As the linked document points out, "You can supply lists of symbols for your own project too. Create a fresh site with 'forrest seed' and see the set at the src/documentation/resources/schema/symbols-project-v10.ent file. Copy that file to your own projects at the same location. Also add the entry to your project xml catalog as shown in the seed site at src/documentation/resources/schema/catalog.xcat file." We had a file at this location which did not seem to be read. (I've now removed it and we patch Forrest directly.) That is what I'm talking about. According to your doc, this file is supposedly created when you run "forrest seed". Now, our site was created several Forrest versions back, but simply copying or creating a symbols-project-v10.ent file in the above location had no effect. It is possible that some supporting collateral elsewhere in the site should also be modified, but I have absolutely no idea what that collateral would be, and I can find no doc that tells me what I'd need to do.

Perhaps the solution is, "if your site was created using "forrest seed" using a forrest version less than 0.90, you must recreate your site to get it to work". If so, the doc should state that clearly.


> Forrest's PDF plugin configuration documentation seems to be incorrect
> ----------------------------------------------------------------------
>
> Key: FOR-1233
> URL: https://issues.apache.org/jira/browse/FOR-1233
> Project: Forrest
> Issue Type: Bug
> Components: Documentation and website
> Affects Versions: 0.10-dev
> Reporter: Karl Wright
>
> When I follow the instructions at http://forrest.apache.org/pluginDocs/plugins_0_90/org.apache.forrest.plugin.output.pdf, they say to place a configuration file called config.xml at the location $PROJECT_HOME/src/documentation/resources/schema/symbols-project-v10.ent. However, when I create this file and point it to a config.xml, as stated in the documentation, the config.xml is never parsed. (I can determine this by making the xml badly formed, which I would hope would cause an error of some kind). I have not gone into using strace to see where Forrest is actually looking but will try this soon.
> I am using the trunk version of Forrest at the moment.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


jira at apache

Jan 30, 2012, 11:56 PM

Post #2 of 2 (441 views)
Permalink
[jira] [Issue Comment Edited] (FOR-1233) Forrest's PDF plugin configuration documentation seems to be incorrect [In reply to]

[ https://issues.apache.org/jira/browse/FOR-1233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13196767#comment-13196767 ]

Karl Wright edited comment on FOR-1233 at 1/31/12 7:54 AM:
-----------------------------------------------------------

Thanks for the reference. But while I understand how entities work, I still don't understand what I need to do to the project xml catalog to "configure them".

As the linked document points out, "You can supply lists of symbols for your own project too. Create a fresh site with 'forrest seed' and see the set at the src/documentation/resources/schema/symbols-project-v10.ent file. Copy that file to your own projects at the same location. Also add the entry to your project xml catalog as shown in the seed site at src/documentation/resources/schema/catalog.xcat file." We had a file at this location which did not seem to be read. (I've now removed it and we patch Forrest directly.) That is what I'm talking about. According to your doc, this file is supposedly created when you run "forrest seed". Now, our site was created several Forrest versions back, but simply copying or creating a symbols-project-v10.ent file in the above location had no effect. It is possible that some supporting collateral elsewhere in the site should also be modified, but I have absolutely no idea what that collateral would be, and I can find no doc that tells me what I'd need to do.

Perhaps the solution is, "if your site was created using "forrest seed" using a forrest version less than 0.90, you must recreate your site to get it to work". If so, the doc should state that clearly.


was (Author: kwright [at] metacarta):
Thanks for the reference. But while I understand how entities work, but I still don't understand what I need to do to the project xml catalog to "configure them".

As the linked document points out, "You can supply lists of symbols for your own project too. Create a fresh site with 'forrest seed' and see the set at the src/documentation/resources/schema/symbols-project-v10.ent file. Copy that file to your own projects at the same location. Also add the entry to your project xml catalog as shown in the seed site at src/documentation/resources/schema/catalog.xcat file." We had a file at this location which did not seem to be read. (I've now removed it and we patch Forrest directly.) That is what I'm talking about. According to your doc, this file is supposedly created when you run "forrest seed". Now, our site was created several Forrest versions back, but simply copying or creating a symbols-project-v10.ent file in the above location had no effect. It is possible that some supporting collateral elsewhere in the site should also be modified, but I have absolutely no idea what that collateral would be, and I can find no doc that tells me what I'd need to do.

Perhaps the solution is, "if your site was created using "forrest seed" using a forrest version less than 0.90, you must recreate your site to get it to work". If so, the doc should state that clearly.


> Forrest's PDF plugin configuration documentation seems to be incorrect
> ----------------------------------------------------------------------
>
> Key: FOR-1233
> URL: https://issues.apache.org/jira/browse/FOR-1233
> Project: Forrest
> Issue Type: Bug
> Components: Documentation and website
> Affects Versions: 0.10-dev
> Reporter: Karl Wright
>
> When I follow the instructions at http://forrest.apache.org/pluginDocs/plugins_0_90/org.apache.forrest.plugin.output.pdf, they say to place a configuration file called config.xml at the location $PROJECT_HOME/src/documentation/resources/schema/symbols-project-v10.ent. However, when I create this file and point it to a config.xml, as stated in the documentation, the config.xml is never parsed. (I can determine this by making the xml badly formed, which I would hope would cause an error of some kind). I have not gone into using strace to see where Forrest is actually looking but will try this soon.
> I am using the trunk version of Forrest at the moment.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

Forrest dev RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.