Mailing List Archive: Wikipedia: Mediawiki
Update.php to 1.11 didn't work?



azurite at seventh-star

Sep 15, 2007, 9:22 AM


Views: 1290
Update.php to 1.11 didn't work?

After some finagling with my host, I finally figured out how to run the
maintenance/update.php script from the command line using PHP5 as CGI.
It seems to run smoothly, but then when I look at the Special:Version
page (even after clearing my cache), it still says I'm running PHP
1.10.1. What's going on here? Did the update not take, or do I need to
manually edit something somewhere?
Also, after an update, what are other good maintenance scripts to run,
or folders that should be deleted? I keep hearing different things from
non-Wikimedia sources, so I thought I'd ask here.
-Azurite

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


robchur at gmail

Sep 15, 2007, 9:41 AM


Views: 1229
Re: Update.php to 1.11 didn't work?

On 15/09/2007, Azurite <azurite [at] seventh-star> wrote:
> After some finagling with my host, I finally figured out how to run the
> maintenance/update.php script from the command line using PHP5 as CGI.
> It seems to run smoothly, but then when I look at the Special:Version
> page (even after clearing my cache), it still says I'm running PHP
> 1.10.1. What's going on here? Did the update not take, or do I need to
> manually edit something somewhere?

Did anything actually get added/removed/changed? This would seem to
indicate that you're using the old code to access Special:Version -
you need to actually overwrite the files/update your symlinks/etc.

> Also, after an update, what are other good maintenance scripts to run,
> or folders that should be deleted? I keep hearing different things from
> non-Wikimedia sources, so I thought I'd ask here.

Depends on what the old version was. Pre-1.6, and I'd recommend doing
a links update - and possibly between any other versions which add
link tables, etc. Ideally, you shouldn't have to run any additional
scripts, but in practice, it's nice to check things at upgrade time.


Rob Church

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


azurite at seventh-star

Sep 15, 2007, 9:55 AM


Views: 1231
Re: Update.php to 1.11 didn't work?

> Did anything actually get added/removed/changed? This would seem to
> indicate that you're using the old code to access Special:Version -
> you need to actually overwrite the files/update your symlinks/etc.
>
The old version was 1.10.1, and when I ran the script from the command
line, everything seemed to be fine-- the only odd thing I noticed was
for an extension I had; it didn't like the include line in my
LocalSettings.php, even though it's correct (and displays properly in
Special:Version). And I did upload all the new files and everything--
so what else would be left that would cause the Special:Version to not
read the correct update?

Here's what the update.php script says (though this is a second
go-around; I already did it once before and I'm not sure if this is
exactly the same):
<br />
<b>Warning</b>:
include(./extensions/Bad-Behavior/bad-behavior-mediawiki.php) [<a
href='function.include'>function.include</a>]: failed to open stream: No
such file or directory in
<b>/home/usernamehere/public_html/wikific/LocalSettings.php</b> on line
<b>17</b><br />
<br />
<b>Warning</b>: include() [<a
href='function.include'>function.include</a>]: Failed opening
'./extensions/Bad-Behavior/bad-behavior-mediawiki.php' for inclusion
(include_path='.:/home/usernamehere/public_html/wikific:/home/usernamehere/public_html/wikific/includes:/home/usernamehere/public_html/wikific/languages')
in <b>/home/usernamehere/public_html/wikific/LocalSettings.php</b> on
line <b>17</b><br />
MediaWiki 1.10.1 Updater

Going to run database updates for usernamehere_Az01-wf_
Depending on the size of your database this may take a while!
Abort with control-c in the next five seconds...0
...hitcounter table already exists.
...querycache table already exists.
...objectcache table already exists.
...categorylinks table already exists.
...logging table already exists.
...user_newtalk table already exists.
...transcache table already exists.
...trackbacks table already exists.
...externallinks table already exists.
...job table already exists.
...langlinks table already exists.
...querycache_info table already exists.
...filearchive table already exists.
...querycachetwo table already exists.
...have ipb_id field in ipblocks table.
...have ipb_expiry field in ipblocks table.
...have rc_type field in recentchanges table.
...have rc_ip field in recentchanges table.
...have rc_id field in recentchanges table.
...have rc_patrolled field in recentchanges table.
...have rc_old_len field in recentchanges table.
...have user_real_name field in user table.
...have user_token field in user table.
...have user_email_token field in user table.
...have user_registration field in user table.
...have log_params field in logging table.
...have ar_rev_id field in archive table.
...have ar_text_id field in archive table.
...have page_len field in page table.
...have rev_deleted field in revision table.
...have img_width field in image table.
...have img_metadata field in image table.
...have img_media_type field in image table.
...have ss_total_pages field in site_stats table.
...have iw_trans field in interwiki table.
...have ipb_range_start field in ipblocks table.
...have ss_images field in site_stats table.
...have ipb_anon_only field in ipblocks table.
...have ipb_enable_autoblock field in ipblocks table.
...have user_newpass_time field in user table.
...have user_editcount field in user table.
...have rc_deleted field in recentchanges table.
...have log_id field in logging table.
...have log_deleted field in logging table.
...have ar_deleted field in archive table.
...have ipb_deleted field in ipblocks table.
...have fa_deleted field in filearchive table.
...have rev_len field in revision table.
...have ar_len field in archive table.
...have rev_parent_id field in revision table.
...have pr_id field in page_restrictions table.
...already have interwiki table
...indexes seem up to 20031107 standards
Already have pagelinks; skipping old links table updates.
...image primary key already set.
The watchlist table is already set up for email notification.
...watchlist talk page rows already present
...user table does not contain old email authentication field.
Logging table has correct title encoding.
...page table already exists.
revision timestamp indexes already up to 2005-03-13
...rev_text_id already in place.
...page_namespace is already a full int (int(11)).
...ar_namespace is already a full int (int(11)).
...rc_namespace is already a full int (int(11)).
...wl_namespace is already a full int (int(11)).
...qc_namespace is already a full int (int(11)).
...log_namespace is already a full int (int(11)).
...already have pagelinks table.
...templatelinks table already exists
No img_type field in image table; Good.
Already have unique user_name index.
...user_groups table already exists.
...user_groups is in current format.
...wl_notificationtimestamp is already nullable.
...timestamp key on logging already exists.
Setting page_random to a random value on rows where it equals
0...changed 0 rows
Checking for additional recent changes indices...
...index on ( rc_namespace, rc_user_text ) seems to be ok
...index on ( rc_user_text, rc_timestamp ) seems to be ok
...redirect table already exists.
Checking for backlinking indices...
Checking if pagelinks index pl_namespace includes field pl_from...
...index pl_namespace on table pagelinks seems to be ok
Checking if templatelinks index tl_namespace includes field tl_from...
...index tl_namespace on table templatelinks seems to be ok
Checking if imagelinks index il_to includes field il_from...
...index il_to on table imagelinks seems to be ok
...page_restrictions table already exists.
Deleting old default messages (this may take a long time!)...Done
Checking site_stats row...ok.
Purging caches...done.
Done.

Nothing looks unusual to me, but then again, I don't have the trained
"Wiki eye" to catch the one little thing that might be messing up the
Version number (or anything else I have yet to find)
-Azurite
_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


emufarmers at gmail

Sep 15, 2007, 11:10 AM


Views: 1215
Re: Update.php to 1.11 didn't work?

On 9/15/07, Azurite <azurite [at] seventh-star> wrote:

> MediaWiki 1.10.1 Updater

I was under the impression that the updated said the version of what you
were upgrading _to_. Are you SURE you extracted the 1.11.0 files to the
right place? The tarball by default extracts to ./mediawiki-[version], so
if you extracted it on your server, check that it isn't still sitting in
that directory.


--
Arr, ye emus, http://emufarmers.com
_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


azurite at seventh-star

Sep 15, 2007, 12:47 PM


Views: 1232
Re: Update.php to 1.11 didn't work?

> I was under the impression that the updated said the version of what you
> were upgrading _to_. Are you SURE you extracted the 1.11.0 files to the
> right place? The tarball by default extracts to ./mediawiki-[version], so
> if you extracted it on your server, check that it isn't still sitting in
> that directory.

Okay, that did end up being the case-- I thought I'd extracted the files
to wikific/ but for some reason they just ended up in my normal Site
folder (basically my local equivalent of public_html). I uploaded the
correct files and ran the script, and now I get an Internal Error. After
adding the specified line to LocalSettings.php, it says the following:


Internal error

Detected bug in an extension! Hook bb2_mediawiki_timer failed to return
a value; should return true to continue hook processing or false to abort.

Backtrace:

#0 /home/seventh/public_html/wikific/includes/Parser.php(386):
wfRunHooks('ParserAfterTidy', Array)
#1 /home/seventh/public_html/wikific/includes/Article.php(3017):
Parser->parse('[[Image:YClipar...', Object(Title),
Object(ParserOptions), true, true, 3231)
#2 /home/seventh/public_html/wikific/includes/Article.php(831):
Article->outputWikiText('[[Image:YClipar...')
#3 /home/seventh/public_html/wikific/includes/Wiki.php(383): Article->view()
#4 /home/seventh/public_html/wikific/includes/Wiki.php(48):
MediaWiki->performAction(Object(OutputPage), Object(Article),
Object(Title), Object(User), Object(WebRequest))
#5 /home/seventh/public_html/wikific/index.php(89):
MediaWiki->initialize(Object(Title), Object(OutputPage), Object(User),
Object(WebRequest))
#6 {main}

Now what???
_Azurite


_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


emufarmers at gmail

Sep 15, 2007, 2:21 PM


Views: 1224
Re: Update.php to 1.11 didn't work?

> Internal error
>
> Detected bug in an extension! Hook bb2_mediawiki_timer failed to return
> a value; should return true to continue hook processing or false to abort.
>
> Backtrace:
>
> #0 /home/seventh/public_html/wikific/includes/Parser.php(386):
> wfRunHooks('ParserAfterTidy', Array)
> #1 /home/seventh/public_html/wikific/includes/Article.php(3017):
> Parser->parse('[[Image:YClipar...', Object(Title),
> Object(ParserOptions), true, true, 3231)
> #2 /home/seventh/public_html/wikific/includes/Article.php(831):
> Article->outputWikiText('[[Image:YClipar...')
> #3 /home/seventh/public_html/wikific/includes/Wiki.php(383):
> Article->view()
> #4 /home/seventh/public_html/wikific/includes/Wiki.php(48):
> MediaWiki->performAction(Object(OutputPage), Object(Article),
> Object(Title), Object(User), Object(WebRequest))
> #5 /home/seventh/public_html/wikific/index.php(89):
> MediaWiki->initialize(Object(Title), Object(OutputPage), Object(User),
> Object(WebRequest))
> #6 {main}
>
> Now what???
> _Azurite

A change in error handling apparently causes some extensions to break (
http://lists.wikimedia.org/pipermail/mediawiki-l/2007-September/023348.html).
Disable the extension, contact its author and ask him to fix the problem, or
fix the problem yourself.


--
Arr, ye emus, http://emufarmers.com
_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


azurite at seventh-star

Sep 15, 2007, 3:09 PM


Views: 1232
Re: Update.php to 1.11 didn't work?

> A change in error handling apparently causes some extensions to break (
> http://lists.wikimedia.org/pipermail/mediawiki-l/2007-September/023348.html).
> Disable the extension, contact its author and ask him to fix the problem, or
> fix the problem yourself
How do I know which extension it is? Is it the general ParserHooks
extension, or something else? It doesn't seem very clear from the error.
-Azurite

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


thomas.dalton at gmail

Sep 15, 2007, 4:38 PM


Views: 1221
Re: Update.php to 1.11 didn't work?

On 15/09/2007, Azurite <azurite [at] seventh-star> wrote:
>
> > A change in error handling apparently causes some extensions to break (
> > http://lists.wikimedia.org/pipermail/mediawiki-l/2007-September/023348.html).
> > Disable the extension, contact its author and ask him to fix the problem, or
> > fix the problem yourself
> How do I know which extension it is? Is it the general ParserHooks
> extension, or something else? It doesn't seem very clear from the error.
> -Azurite

Does the name "bb2_mediawiki_timer" mean anything to you? The "bb2"
bit is probably an abbreviation of the extension name.

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


emufarmers at gmail

Sep 15, 2007, 4:56 PM


Views: 1223
Re: Update.php to 1.11 didn't work?

On 9/15/07, Thomas Dalton <thomas.dalton [at] gmail> wrote:
>
> On 15/09/2007, Azurite <azurite [at] seventh-star> wrote:
> >
> > > A change in error handling apparently causes some extensions to break
> (
> > >
> http://lists.wikimedia.org/pipermail/mediawiki-l/2007-September/023348.html
> ).
> > > Disable the extension, contact its author and ask him to fix the
> problem, or
> > > fix the problem yourself
> > How do I know which extension it is? Is it the general ParserHooks
> > extension, or something else? It doesn't seem very clear from the error.
> > -Azurite
>
> Does the name "bb2_mediawiki_timer" mean anything to you? The "bb2"
> bit is probably an abbreviation of the extension name.

That would be the Bad Behavior extension (which apparently caused problems
during the upgrade process as well). Disable the extension (there appear to
be two BB ones, and I don't know which you used) and ask its author to
commit a fix for it.


--
Arr, ye emus, http://emufarmers.com
_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l


azurite at seventh-star

Sep 15, 2007, 11:42 PM


Views: 1212
Re: Update.php to 1.11 didn't work?

> That would be the Bad Behavior extension (which apparently caused problems
> during the upgrade process as well). Disable the extension (there appear to
> be two BB ones, and I don't know which you used) and ask its author to
> commit a fix for it.
>

Thanks-- disabling that fixed it. For the problems it caused during the
upgrade, do you think I should run the script again, or any of the other
maintenance scripts?
-Azurite

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l