Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: DBMail: users

DBMail IMAP problem: authentication works for first connection after restart

 

 

DBMail users RSS feed   Index | Next | Previous | View Threaded


miles at atmos

Jun 6, 2012, 10:34 AM

Post #1 of 5 (615 views)
Permalink
DBMail IMAP problem: authentication works for first connection after restart

Hi folks,

I've set up the DBMail server (3.0.2) on one machine (Slackware 13.37
x64), and it's using a MySQL database on a NAS as storage. The DBMail
server has got full access to the database on the NAS.

I've tested with several e-mail clients (Thunderbird, Windows Live Mail,
KMail)

When I make the first connection to the DBMail server, the username and
passward are accepted, and download of message headers start. Staying in
the folder first opened, there are no problems to list messages, open
them, etc.

Whenever I move to a new IMAP folder, DBMail tries to authenticate,
fails and starts to ask for a password, without never accepting the
credentials again, until the DBMail server is restarted.

Is there somebody else having noticed this behavior when using a
database on a separate machine?

The reason, I do not want to put the MySQL server on the same machine as
the DBMail server is economy. Using a 7.5 TB RAID5 NAS as storage for
historical data that is sparesly accessed, and where performance is not
essential, is very economical.

Best regards,

Peter

_______________________________________________
DBmail mailing list
DBmail [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail


paul at nfg

Jun 7, 2012, 6:58 AM

Post #2 of 5 (582 views)
Permalink
Re: DBMail IMAP problem: authentication works for first connection after restart [In reply to]

On 06/06/2012 07:34 PM, Peter Milesson wrote:

> Whenever I move to a new IMAP folder, DBMail tries to authenticate,
> fails and starts to ask for a password, without never accepting the
> credentials again, until the DBMail server is restarted.

Which makes no sense at all. Could you post some anonymised logs at
file_logging_levels=511 ?

> Is there somebody else having noticed this behavior when using a
> database on a separate machine?

Using a separate database server is *very* common.




--
________________________________________________________________
Paul J Stevens pjstevns @ gmail, twitter, skype, linkedin

* Premium Hosting Services and Web Application Consultancy *

www.nfg.nl/info [at] nfg/+31.85.877.99.97
________________________________________________________________
_______________________________________________
DBmail mailing list
DBmail [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail


miles at atmos

Jun 10, 2012, 1:59 AM

Post #3 of 5 (584 views)
Permalink
Re: DBMail IMAP problem: authentication works for first connection after restart [In reply to]

Hi Paul,

Attached is a snippet from the log file. It's anonymized, including the
Base64 encoded parts.

I've double checked that the username/password pair is correct.
Authentication is in plain text. Passwords are also stored in plain text
in the database (a separate NAS box).

Thanks for your help,

Peter


On 7.6.2012 15:58, Paul J Stevens wrote:
> On 06/06/2012 07:34 PM, Peter Milesson wrote:
>
>> Whenever I move to a new IMAP folder, DBMail tries to authenticate,
>> fails and starts to ask for a password, without never accepting the
>> credentials again, until the DBMail server is restarted.
>
> Which makes no sense at all. Could you post some anonymised logs at
> file_logging_levels=511 ?
>
>> Is there somebody else having noticed this behavior when using a
>> database on a separate machine?
>
> Using a separate database server is *very* common.
>
>
>
>
Attachments: dbmail.err (160 KB)


paul at nfg

Jun 10, 2012, 7:29 AM

Post #4 of 5 (581 views)
Permalink
Re: DBMail IMAP problem: authentication works for first connection after restart [In reply to]

On 06/10/2012 10:59 AM, Peter Milesson wrote:
> Hi Paul,
>
> Attached is a snippet from the log file. It's anonymized, including the
> Base64 encoded parts.

Peter,

looks like a regression in the usermap code.
Please try:


http://git.dbmail.eu/paul/dbmail/patch/?id=0539f673e86fb9760999294b20792489c41f87a3

--
________________________________________________________________
Paul J Stevens pjstevns @ gmail, twitter, skype, linkedin

* Premium Hosting Services and Web Application Consultancy *

www.nfg.nl/info [at] nfg/+31.85.877.99.97
________________________________________________________________
_______________________________________________
DBmail mailing list
DBmail [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail


miles at atmos

Jun 10, 2012, 7:56 AM

Post #5 of 5 (576 views)
Permalink
Re: DBMail IMAP problem: authentication works for first connection after restart [In reply to]

Hi Paul,

Works like a charm!

You're No.1 :-)
Thanks a lot!

Peter

On 10.6.2012 16:29, Paul J Stevens wrote:
> On 06/10/2012 10:59 AM, Peter Milesson wrote:
>> Hi Paul,
>>
>> Attached is a snippet from the log file. It's anonymized, including the
>> Base64 encoded parts.
>
> Peter,
>
> looks like a regression in the usermap code.
> Please try:
>
>
> http://git.dbmail.eu/paul/dbmail/patch/?id=0539f673e86fb9760999294b20792489c41f87a3
>

_______________________________________________
DBmail mailing list
DBmail [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail

DBMail users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.