Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: DBMail: dev

[DBMail 0000942]: ZDB library not found even after install

 

 

DBMail dev RSS feed   Index | Next | Previous | View Threaded


bugtrack at dbmail

Apr 24, 2012, 11:24 AM

Post #1 of 3 (561 views)
Permalink
[DBMail 0000942]: ZDB library not found even after install

A NOTE has been added to this issue.
======================================================================
http://dbmail.org/mantis/view.php?id=942
======================================================================
Reported By: brosskgm1
Assigned To:
======================================================================
Project: DBMail
Issue ID: 942
Category: installation scripts
Reproducibility: always
Severity: minor
Priority: normal
Status: new
target:
======================================================================
Date Submitted: 16-Nov-11 03:39 CET
Last Modified: 24-Apr-12 20:24 CEST
======================================================================
Summary: ZDB library not found even after install
Description:
I installed the ZDB library, even forced the path /usr/local/bin,
/usr/local, /usr and it still errors on ./configure.

I'm at a real loss to get this working.

Thanks
Bob

======================================================================

----------------------------------------------------------------------
(0003349) brosskgm1 (reporter) - 19-Nov-11 16:20
http://dbmail.org/mantis/view.php?id=942#c3349
----------------------------------------------------------------------
Thanks, this can be removed.

----------------------------------------------------------------------
(0003441) joe (reporter) - 24-Apr-12 20:24
http://dbmail.org/mantis/view.php?id=942#c3441
----------------------------------------------------------------------
Hi brosskgm1,

I am having the same problem. Did you find a resolution?

I am running a Debian Squeeze postgres installation. I tried using
Synaptic and adjusted the sources.list according to the instructions on the
dbmail site, but the problem is that while the 3 series version of dbmail
is available, only the 2 series is available for dbmail-postgres.

So I decided, like you, to compile from source and ran into dependency
issues. Most I resolved, but am stuck with the

"configure: error: Could not find ZDB library."

error, which will not let me complete the ./configure command.

I installed both the libzdb7 and libzdb-dev package version 2.9-1 using
synaptic. That did not work, so I went to the libzdb site and downloaded
version 2.10.3, compiled it after a dependency issue or two. This did not
solve the problem either. The only thing that I did not do, because I don't
know how to, is to install a dev version of 2.10.3. Do you know how to
create and install the ...-dev from source?

If you know how to do that and it works for you, please let me know how
you did it.

Cheers

Joe

Issue History
Date Modified Username Field Change
======================================================================
16-Nov-11 03:39 brosskgm1 New Issue
19-Nov-11 16:20 brosskgm1 Note Added: 0003349
24-Apr-12 20:24 joe Note Added: 0003441
======================================================================

_______________________________________________
Dbmail-dev mailing list
Dbmail-dev [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail-dev


bugtrack at dbmail

Apr 25, 2012, 12:11 AM

Post #2 of 3 (520 views)
Permalink
[DBMail 0000942]: ZDB library not found even after install [In reply to]

A NOTE has been added to this issue.
======================================================================
http://dbmail.org/mantis/view.php?id=942
======================================================================
Reported By: brosskgm1
Assigned To:
======================================================================
Project: DBMail
Issue ID: 942
Category: installation scripts
Reproducibility: always
Severity: minor
Priority: normal
Status: new
target:
======================================================================
Date Submitted: 16-Nov-11 03:39 CET
Last Modified: 25-Apr-12 09:11 CEST
======================================================================
Summary: ZDB library not found even after install
Description:
I installed the ZDB library, even forced the path /usr/local/bin,
/usr/local, /usr and it still errors on ./configure.

I'm at a real loss to get this working.

Thanks
Bob

======================================================================

----------------------------------------------------------------------
(0003349) brosskgm1 (reporter) - 19-Nov-11 16:20
http://dbmail.org/mantis/view.php?id=942#c3349
----------------------------------------------------------------------
Thanks, this can be removed.

----------------------------------------------------------------------
(0003441) joe (reporter) - 24-Apr-12 20:24
http://dbmail.org/mantis/view.php?id=942#c3441
----------------------------------------------------------------------
Hi brosskgm1,

I am having the same problem. Did you find a resolution?

I am running a Debian Squeeze postgres installation. I tried using
Synaptic and adjusted the sources.list according to the instructions on the
dbmail site, but the problem is that while the 3 series version of dbmail
is available, only the 2 series is available for dbmail-postgres.

So I decided, like you, to compile from source and ran into dependency
issues. Most I resolved, but am stuck with the

"configure: error: Could not find ZDB library."

error, which will not let me complete the ./configure command.

I installed both the libzdb7 and libzdb-dev package version 2.9-1 using
synaptic. That did not work, so I went to the libzdb site and downloaded
version 2.10.3, compiled it after a dependency issue or two. This did not
solve the problem either. The only thing that I did not do, because I don't
know how to, is to install a dev version of 2.10.3. Do you know how to
create and install the ...-dev from source?

If you know how to do that and it works for you, please let me know how
you did it.

Cheers

Joe

----------------------------------------------------------------------
(0003442) paul (administrator) - 25-Apr-12 09:11
http://dbmail.org/mantis/view.php?id=942#c3442
----------------------------------------------------------------------
Joe,

For squeeze, running a

apt-get install dbmail

should do!

This will also install libzdb. If you want to use postgres you will have
to install libpq5.

Issue History
Date Modified Username Field Change
======================================================================
16-Nov-11 03:39 brosskgm1 New Issue
19-Nov-11 16:20 brosskgm1 Note Added: 0003349
24-Apr-12 20:24 joe Note Added: 0003441
25-Apr-12 09:11 paul Note Added: 0003442
======================================================================

_______________________________________________
Dbmail-dev mailing list
Dbmail-dev [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail-dev


bugtrack at dbmail

Apr 25, 2012, 12:12 AM

Post #3 of 3 (512 views)
Permalink
[DBMail 0000942]: ZDB library not found even after install [In reply to]

The following issue has been CLOSED
======================================================================
http://dbmail.org/mantis/view.php?id=942
======================================================================
Reported By: brosskgm1
Assigned To:
======================================================================
Project: DBMail
Issue ID: 942
Category: installation scripts
Reproducibility: always
Severity: minor
Priority: normal
Status: closed
target:
Resolution: no change required
Fixed in Version:
======================================================================
Date Submitted: 16-Nov-11 03:39 CET
Last Modified: 25-Apr-12 09:12 CEST
======================================================================
Summary: ZDB library not found even after install
Description:
I installed the ZDB library, even forced the path /usr/local/bin,
/usr/local, /usr and it still errors on ./configure.

I'm at a real loss to get this working.

Thanks
Bob

======================================================================

----------------------------------------------------------------------
(0003349) brosskgm1 (reporter) - 19-Nov-11 16:20
http://dbmail.org/mantis/view.php?id=942#c3349
----------------------------------------------------------------------
Thanks, this can be removed.

----------------------------------------------------------------------
(0003441) joe (reporter) - 24-Apr-12 20:24
http://dbmail.org/mantis/view.php?id=942#c3441
----------------------------------------------------------------------
Hi brosskgm1,

I am having the same problem. Did you find a resolution?

I am running a Debian Squeeze postgres installation. I tried using
Synaptic and adjusted the sources.list according to the instructions on the
dbmail site, but the problem is that while the 3 series version of dbmail
is available, only the 2 series is available for dbmail-postgres.

So I decided, like you, to compile from source and ran into dependency
issues. Most I resolved, but am stuck with the

"configure: error: Could not find ZDB library."

error, which will not let me complete the ./configure command.

I installed both the libzdb7 and libzdb-dev package version 2.9-1 using
synaptic. That did not work, so I went to the libzdb site and downloaded
version 2.10.3, compiled it after a dependency issue or two. This did not
solve the problem either. The only thing that I did not do, because I don't
know how to, is to install a dev version of 2.10.3. Do you know how to
create and install the ...-dev from source?

If you know how to do that and it works for you, please let me know how
you did it.

Cheers

Joe

----------------------------------------------------------------------
(0003442) paul (administrator) - 25-Apr-12 09:11
http://dbmail.org/mantis/view.php?id=942#c3442
----------------------------------------------------------------------
Joe,

For squeeze, running a

apt-get install dbmail

should do!

This will also install libzdb. If you want to use postgres you will have
to install libpq5.

----------------------------------------------------------------------
(0003443) paul (administrator) - 25-Apr-12 09:12
http://dbmail.org/mantis/view.php?id=942#c3443
----------------------------------------------------------------------
I'm closing this issue. Please ask around on the list for help.

Issue History
Date Modified Username Field Change
======================================================================
16-Nov-11 03:39 brosskgm1 New Issue
19-Nov-11 16:20 brosskgm1 Note Added: 0003349
24-Apr-12 20:24 joe Note Added: 0003441
25-Apr-12 09:11 paul Note Added: 0003442
25-Apr-12 09:12 paul Note Added: 0003443
25-Apr-12 09:12 paul Status new => closed
25-Apr-12 09:12 paul Resolution open => no change
required
======================================================================

_______________________________________________
Dbmail-dev mailing list
Dbmail-dev [at] dbmail
http://mailman.fastxs.nl/cgi-bin/mailman/listinfo/dbmail-dev

DBMail dev RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.