Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: VOIP

Problem with inbound calls to FXO interface

 

 

Cisco voip RSS feed   Index | Next | Previous | View Threaded


JToth at cmefcu

Oct 14, 2005, 7:11 AM

Post #1 of 4 (2722 views)
Permalink
Problem with inbound calls to FXO interface

Greetings,



I am having a problem getting an FXO interface on a 1760 router to work
correctly. I am able to make outbound calls correctly, however when I
try to make and inbound call I can't get it to ring to the Attendant DN.
Following the initial configuration when I would dial into the Interface
it would ring once and then playback dial tone. I have a feeling that at
this point the gateway was possibly waiting to hear digits in-band to
know where to route the call to. However inputting digits at the dial
tone had no effect on getting the call to ring the extension.



At the suggestion of someone else I tried using the "connection plar"
statement on the voice port and pointing it at the attendant DN number
in this case 6000. Using this statement did change the behavior of the
gateway when called; when I call now the line rings once and then goes
to a fast busy instead of a dial tone.



I was hoping someone might have some ideas on what I might be missing
here; this is my first time working with an Inbound FXO Gateway so I am
a bit unsure of where I might be going wrong. I have pasted the Gateway
config in-line below.



Thanks in advance



Joe Toth



t5cmhrtr1#sh run

Building configuration...



Current configuration : 1790 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname t5cmhrtr1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$ohqE$yr6y51hBjsYZAeWzO7Xyv/

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

voice-card 0

!

voice-card 1

!

ip subnet-zero

ip cef

!

!

!

!

ip domain lookup source-interface FastEthernet0/0

ip domain name t5.com

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.XX 255.255.255.0

speed auto

!

ip classless

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

!

voice-port 0/0

timing hookflash-out 500

!

voice-port 0/1

timing hookflash-out 500

connection plar 6000

!

voice-port 1/0

!

voice-port 1/1

!

voice-port 1/2

!

voice-port 1/3

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.0.XX

ccm-manager config

!

mgcp

mgcp call-agent 192.168.0.27 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

dial-peer voice 10 pots

destination-pattern 9T

port 0/0

!

dial-peer voice 11 pots

destination-pattern 9T

port 0/1

!

dial-peer voice 99900 pots

service mgcpapp

port 0/0

!

dial-peer voice 99901 pots

service mgcpapp

port 0/1

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXX

login

line vty 5 15

password XXXXXXX

!

end


Kris.Seraphine at cliftoncpa

Oct 14, 2005, 7:50 AM

Post #2 of 4 (2698 views)
Permalink
RE: Problem with inbound calls to FXO interface [In reply to]

The connection plar 6000 won't work unless you have a voip dial-peer
that matches that number, or an ephone registered with that extension.



If you are trying to configure the gateway for SRST, you'll need to add
the following command:



application

global

service alternate default



I don't think that will solve your problem though. If not, I would
suggest removing the connection plar and dial-peers 10 and 11 (or add
the session mgcp command to them). There have been problems in the past
with MGCP where the default session dial-peers are matched when they
shouldn't be. The fact that your calls were being answered with dial
tone makes me think this is the problem.







Kris Seraphine


CORTIZ at broward

Oct 14, 2005, 7:56 AM

Post #3 of 4 (2713 views)
Permalink
RE: Problem with inbound calls to FXO interface [In reply to]

It might be a bug as someone suggested, but since this is MGCP, the
calls are controlled by the Call Manager. Check the inbound Calling
Search Space of the port to verify you can reach the internal phones. I
once has a situation where the phone would ring once then go no further
and it was the calling search space.



Carlos



________________________________

From: cisco-voip-bounces [at] puck
[mailto:cisco-voip-bounces [at] puck] On Behalf Of Joe Toth
Sent: Friday, October 14, 2005 10:11 AM
To: cisco-voip [at] puck
Subject: [cisco-voip] Problem with inbound calls to FXO interface



Greetings,



I am having a problem getting an FXO interface on a 1760 router to work
correctly. I am able to make outbound calls correctly, however when I
try to make and inbound call I can't get it to ring to the Attendant DN.
Following the initial configuration when I would dial into the Interface
it would ring once and then playback dial tone. I have a feeling that at
this point the gateway was possibly waiting to hear digits in-band to
know where to route the call to. However inputting digits at the dial
tone had no effect on getting the call to ring the extension.



At the suggestion of someone else I tried using the "connection plar"
statement on the voice port and pointing it at the attendant DN number
in this case 6000. Using this statement did change the behavior of the
gateway when called; when I call now the line rings once and then goes
to a fast busy instead of a dial tone.



I was hoping someone might have some ideas on what I might be missing
here; this is my first time working with an Inbound FXO Gateway so I am
a bit unsure of where I might be going wrong. I have pasted the Gateway
config in-line below.



Thanks in advance



Joe Toth



t5cmhrtr1#sh run

Building configuration...



Current configuration : 1790 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname t5cmhrtr1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$ohqE$yr6y51hBjsYZAeWzO7Xyv/

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

voice-card 0

!

voice-card 1

!

ip subnet-zero

ip cef

!

!

!

!

ip domain lookup source-interface FastEthernet0/0

ip domain name t5.com

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.XX 255.255.255.0

speed auto

!

ip classless

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

!

voice-port 0/0

timing hookflash-out 500

!

voice-port 0/1

timing hookflash-out 500

connection plar 6000

!

voice-port 1/0

!

voice-port 1/1

!

voice-port 1/2

!

voice-port 1/3

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.0.XX

ccm-manager config

!

mgcp

mgcp call-agent 192.168.0.27 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

dial-peer voice 10 pots

destination-pattern 9T

port 0/0

!

dial-peer voice 11 pots

destination-pattern 9T

port 0/1

!

dial-peer voice 99900 pots

service mgcpapp

port 0/0

!

dial-peer voice 99901 pots

service mgcpapp

port 0/1

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXX

login

line vty 5 15

password XXXXXXX

!

end


JToth at cmefcu

Oct 14, 2005, 11:37 AM

Post #4 of 4 (2695 views)
Permalink
RE: Problem with inbound calls to FXO interface [In reply to]

Kris,

As soon as I removed the dial-peer per your instructions it worked
perfectly.

Thanks,

Joe Toth

Systems Engineer

CME Federal Credit Union



P: (614) 222-3350

F: (614) 222-3351

E: jtoth [at] cmefcu

-----Original Message-----
From: cisco-voip-bounces [at] puck
[mailto:cisco-voip-bounces [at] puck] On Behalf Of
cisco-voip-request [at] puck
Sent: Friday, October 14, 2005 10:56 AM
To: cisco-voip [at] puck
Subject: cisco-voip Digest, Vol 32, Issue 59

Send cisco-voip mailing list submissions to
cisco-voip [at] puck

To subscribe or unsubscribe via the World Wide Web, visit
https://puck.nether.net/mailman/listinfo/cisco-voip
or, via email, send a message with subject or body 'help' to
cisco-voip-request [at] puck

You can reach the person managing the list at
cisco-voip-owner [at] puck

When replying, please edit your Subject line so it is more specific
than "Re: Contents of cisco-voip digest..."


Today's Topics:

1. CER upgrade from 1.2(2) to 1.2(3) - OS Error (Carter, Bill)
2. RE: Problem with inbound calls to FXO interface (Kris Seraphine)
3. Re: CER upgrade from 1.2(2) to 1.2(3) - OS Error (Kevin Thorngren)
4. RE: Problem with inbound calls to FXO interface (Ortiz, Carlos)


----------------------------------------------------------------------

Message: 1
Date: Fri, 14 Oct 2005 09:47:33 -0500
From: "Carter, Bill" <bcarter [at] sentinel>
Subject: [cisco-voip] CER upgrade from 1.2(2) to 1.2(3) - OS Error
To: <cisco-voip [at] puck>
Message-ID:
<6A0744639B86DD459433108DBF101D26A42F21 [at] MAIL01>
Content-Type: text/plain; charset="us-ascii"

I am trying to upgrade an Emergency responder from 1.2(2) to 1.2(3a).
Release notes say minimum OS version 2000.2.6sr2 or later is required.
I installed 2000.2.7 and 2000.2.7sr7. CER upgrade fails on OS check
saying it did not detect 2000.2.6sr2 or later.?.

How do I install the CER upgrade ??? do I need to install 2000.2.6 and
2000.2.6sr2 on top of the 2000.2.7??


-------------- next part --------------
An HTML attachment was scrubbed...
URL:
https://puck.nether.net/pipermail/cisco-voip/attachments/20051014/c4783a
38/attachment-0001.html

------------------------------

Message: 2
Date: Fri, 14 Oct 2005 09:50:31 -0500
From: "Kris Seraphine" <Kris.Seraphine [at] cliftoncpa>
Subject: [cisco-voip] RE: Problem with inbound calls to FXO interface
To: <cisco-voip [at] puck>
Message-ID:
<49050C5A9350604E903A8A0B6744A43DE802C8 [at] cgts-mail>
Content-Type: text/plain; charset="us-ascii"

The connection plar 6000 won't work unless you have a voip dial-peer
that matches that number, or an ephone registered with that extension.



If you are trying to configure the gateway for SRST, you'll need to add
the following command:



application

global

service alternate default



I don't think that will solve your problem though. If not, I would
suggest removing the connection plar and dial-peers 10 and 11 (or add
the session mgcp command to them). There have been problems in the past
with MGCP where the default session dial-peers are matched when they
shouldn't be. The fact that your calls were being answered with dial
tone makes me think this is the problem.







Kris Seraphine



-------------- next part --------------
An HTML attachment was scrubbed...
URL:
https://puck.nether.net/pipermail/cisco-voip/attachments/20051014/ec5b1e
ff/attachment-0001.html

------------------------------

Message: 3
Date: Fri, 14 Oct 2005 10:55:25 -0400
From: Kevin Thorngren <kthorngr [at] cisco>
Subject: Re: [cisco-voip] CER upgrade from 1.2(2) to 1.2(3) - OS Error
To: "Carter, Bill" <bcarter [at] sentinel>
Cc: cisco-voip [at] puck
Message-ID: <934a98676ed1ac8450c01e4625992190 [at] cisco>
Content-Type: text/plain; charset="iso-8859-1"

Looks like you are running into this issue:
CSCsa61886 - CER 1.2(3) upgrade may fail on OS version check
Symptom:

A. OS upgrade version 2000.2.7 and above. Without OS service release.
Upgrade to CER 1.2.3 may comeback with an error:
1."OS Image is less that 2000.2.6. This install is supported on
OS versions 2000.2.6.sr2 and
above.Aborting..."
B. OS upgrade version 2000.2.7 and above. With OS service release
2000.2.7sr1 and above.
Upgrade to CER 1.2.3 may comeback with an error:
1."Error in retrieving OS and JRE Versions from registry
keys.This install is supported only on
OS versions 2000.2.6sr2 and above.Aborting..."
and the installation will abort.

Conditions:
If OS upgrade version 2000.2.7 and above, with or without OS service
release 2000.2.7sr1 and higher is running and if the above any error is
received then use the workaround to upgrade to CER 1.2(3)

Workaround:
1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\System Info.
Export registry entry, Registry --> Export Registry, save it as
orginalReg.reg

2. Execute workaround.reg, given in the atttachment

3. Install CER 1.2.3

4. After CER 1.2.3 installation is over, execute workaround2.reg, given
in the atttachment

5. At the end execute orginalReg.reg

Please open a TAC case to receive the .reg files for the workaround.

Kevin
On Oct 14, 2005, at 10:47 AM, Carter, Bill wrote:

> I am trying to upgrade an Emergency responder from 1.2(2) to 1.2(3a).?

> Release notes say minimum OS version 2000.2.6sr2 or later is
> required.? I installed 2000.2.7 and 2000.2.7sr7.? CER upgrade fails on

> OS check saying it did not detect 2000.2.6sr2 or later.?.
> ?
> How do I install the CER upgrade ??? do I need to install 2000.2.6 and

> 2000.2.6sr2 on top of the 2000.2.7??
> ?
> ?_______________________________________________
> cisco-voip mailing list
> cisco-voip [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-voip
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 2129 bytes
Desc: not available
Url :
https://puck.nether.net/pipermail/cisco-voip/attachments/20051014/b8a0a9
4e/attachment-0001.bin

------------------------------

Message: 4
Date: Fri, 14 Oct 2005 10:56:08 -0400
From: "Ortiz, Carlos" <CORTIZ [at] broward>
Subject: RE: [cisco-voip] Problem with inbound calls to FXO interface
To: "Joe Toth" <JToth [at] cmefcu>, <cisco-voip [at] puck>
Message-ID:

<26B357EF9FB7D04A989C9E82A9E5436E01BC29B0 [at] MREXVS01>
Content-Type: text/plain; charset="us-ascii"

It might be a bug as someone suggested, but since this is MGCP, the
calls are controlled by the Call Manager. Check the inbound Calling
Search Space of the port to verify you can reach the internal phones. I
once has a situation where the phone would ring once then go no further
and it was the calling search space.



Carlos



________________________________

From: cisco-voip-bounces [at] puck
[mailto:cisco-voip-bounces [at] puck] On Behalf Of Joe Toth
Sent: Friday, October 14, 2005 10:11 AM
To: cisco-voip [at] puck
Subject: [cisco-voip] Problem with inbound calls to FXO interface



Greetings,



I am having a problem getting an FXO interface on a 1760 router to work
correctly. I am able to make outbound calls correctly, however when I
try to make and inbound call I can't get it to ring to the Attendant DN.
Following the initial configuration when I would dial into the Interface
it would ring once and then playback dial tone. I have a feeling that at
this point the gateway was possibly waiting to hear digits in-band to
know where to route the call to. However inputting digits at the dial
tone had no effect on getting the call to ring the extension.



At the suggestion of someone else I tried using the "connection plar"
statement on the voice port and pointing it at the attendant DN number
in this case 6000. Using this statement did change the behavior of the
gateway when called; when I call now the line rings once and then goes
to a fast busy instead of a dial tone.



I was hoping someone might have some ideas on what I might be missing
here; this is my first time working with an Inbound FXO Gateway so I am
a bit unsure of where I might be going wrong. I have pasted the Gateway
config in-line below.



Thanks in advance



Joe Toth



t5cmhrtr1#sh run

Building configuration...



Current configuration : 1790 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname t5cmhrtr1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$ohqE$yr6y51hBjsYZAeWzO7Xyv/

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

voice-card 0

!

voice-card 1

!

ip subnet-zero

ip cef

!

!

!

!

ip domain lookup source-interface FastEthernet0/0

ip domain name t5.com

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.XX 255.255.255.0

speed auto

!

ip classless

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

!

voice-port 0/0

timing hookflash-out 500

!

voice-port 0/1

timing hookflash-out 500

connection plar 6000

!

voice-port 1/0

!

voice-port 1/1

!

voice-port 1/2

!

voice-port 1/3

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.0.XX

ccm-manager config

!

mgcp

mgcp call-agent 192.168.0.27 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

dial-peer voice 10 pots

destination-pattern 9T

port 0/0

!

dial-peer voice 11 pots

destination-pattern 9T

port 0/1

!

dial-peer voice 99900 pots

service mgcpapp

port 0/0

!

dial-peer voice 99901 pots

service mgcpapp

port 0/1

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXX

login

line vty 5 15

password XXXXXXX

!

end



-------------- next part --------------
An HTML attachment was scrubbed...
URL:
https://puck.nether.net/pipermail/cisco-voip/attachments/20051014/b585fe
c1/attachment.html

------------------------------

_______________________________________________
cisco-voip mailing list
cisco-voip [at] puck
https://puck.nether.net/mailman/listinfo/cisco-voip


End of cisco-voip Digest, Vol 32, Issue 59
******************************************

Cisco voip RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.