Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NSP

ME3600X Embedded Packet Capture

 

 

Cisco nsp RSS feed   Index | Next | Previous | View Threaded


cisco-nsp at itpro

Aug 9, 2012, 10:35 PM

Post #1 of 11 (1569 views)
Permalink
ME3600X Embedded Packet Capture

Hi,

Has anyone used Embedded Packet Capture on the ME3600X successfully? If
so are their any gotchas to be weary of?

The only things that come up when I search for this is CSCtq11526 Embedded
Packet Capture stops BFD neighbor adjacency, but have been unable to find
details of what packets can be captured - hardware v cpu etc. Any
documentation pointers would be appreciated.

Thanks

Ivan

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


waris at cisco

Aug 10, 2012, 1:09 AM

Post #2 of 11 (1528 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Ivan,
Which packet capture you are referring to on ME3600X?
There is no support of embedded packet capture on ME3600X.

Regards,
Waris


-----Original Message-----
From: cisco-nsp-bounces [at] puck [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ivan
Sent: Thursday, August 09, 2012 10:35 PM
To: cisco-nsp [at] puck
Subject: [c-nsp] ME3600X Embedded Packet Capture

Hi,

Has anyone used Embedded Packet Capture on the ME3600X successfully? If so are their any gotchas to be weary of?

The only things that come up when I search for this is CSCtq11526 Embedded Packet Capture stops BFD neighbor adjacency, but have been unable to find details of what packets can be captured - hardware v cpu etc. Any documentation pointers would be appreciated.

Thanks

Ivan

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cisco-nsp at itpro

Aug 10, 2012, 3:27 AM

Post #3 of 11 (1518 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi Waris,

I had come across that bug referring to EPC in "Release Notes for the
Cisco ME 3800X and ME 3600X Switch" -
http://www.cisco.com/en/US/docs/switches/metro/me3600x_3800x/software/release/15.1_2_ey/release/notes/ol25360.html
and had hoped that the feature was available. I wasn't able to find any
other documentation thus my question to the list.

What I am really looking for is a possible way to verify any seen mac
addresses on a customer EVC xconnect when running MPLS to the edge for
troubleshooting. This was quite easy and useful with a switched access
layer. I don't really want to xconnect on vlans and bridge to EVCs (not
sure that is possible on the ME3600X platform)

Thanks

Ivan

On 10/Aug/2012 8:09 p.m., Waris Sagheer (waris) wrote:
> Ivan,
> Which packet capture you are referring to on ME3600X?
> There is no support of embedded packet capture on ME3600X.
>
> Regards,
> Waris
>
>
> -----Original Message-----
> From: cisco-nsp-bounces [at] puck [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ivan
> Sent: Thursday, August 09, 2012 10:35 PM
> To: cisco-nsp [at] puck
> Subject: [c-nsp] ME3600X Embedded Packet Capture
>
> Hi,
>
> Has anyone used Embedded Packet Capture on the ME3600X successfully? If so are their any gotchas to be weary of?
>
> The only things that come up when I search for this is CSCtq11526 Embedded Packet Capture stops BFD neighbor adjacency, but have been unable to find details of what packets can be captured - hardware v cpu etc. Any documentation pointers would be appreciated.
>
> Thanks
>
> Ivan
>
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


waris at cisco

Aug 10, 2012, 8:53 AM

Post #4 of 11 (1537 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi Ivan,
How do you want to verify the mac address? Can you send me configuration example on access layer switch?
Also, what is the current configuration on ME3600X?

Regards,
Waris


-----Original Message-----
From: Ivan [mailto:cisco-nsp [at] itpro]
Sent: Friday, August 10, 2012 3:27 AM
To: Waris Sagheer (waris)
Cc: cisco-nsp [at] puck
Subject: Re: [c-nsp] ME3600X Embedded Packet Capture

Hi Waris,

I had come across that bug referring to EPC in "Release Notes for the Cisco ME 3800X and ME 3600X Switch" - http://www.cisco.com/en/US/docs/switches/metro/me3600x_3800x/software/release/15.1_2_ey/release/notes/ol25360.html
and had hoped that the feature was available. I wasn't able to find any other documentation thus my question to the list.

What I am really looking for is a possible way to verify any seen mac addresses on a customer EVC xconnect when running MPLS to the edge for troubleshooting. This was quite easy and useful with a switched access layer. I don't really want to xconnect on vlans and bridge to EVCs (not sure that is possible on the ME3600X platform)

Thanks

Ivan

On 10/Aug/2012 8:09 p.m., Waris Sagheer (waris) wrote:
> Ivan,
> Which packet capture you are referring to on ME3600X?
> There is no support of embedded packet capture on ME3600X.
>
> Regards,
> Waris
>
>
> -----Original Message-----
> From: cisco-nsp-bounces [at] puck
> [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ivan
> Sent: Thursday, August 09, 2012 10:35 PM
> To: cisco-nsp [at] puck
> Subject: [c-nsp] ME3600X Embedded Packet Capture
>
> Hi,
>
> Has anyone used Embedded Packet Capture on the ME3600X successfully? If so are their any gotchas to be weary of?
>
> The only things that come up when I search for this is CSCtq11526 Embedded Packet Capture stops BFD neighbor adjacency, but have been unable to find details of what packets can be captured - hardware v cpu etc. Any documentation pointers would be appreciated.
>
> Thanks
>
> Ivan
>
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/


_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cisco-nsp at itpro

Aug 10, 2012, 3:32 PM

Post #5 of 11 (1527 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi Waris,

When troubleshooting a layer 2 service checking what mac addresses can
seen seen from the customer has been very useful. Previously with a
switched access we could look at the mac addresses on the access
switch. With MPLS to the edge I haven't found anyway to be able to
verify customer mac addresses. I was hopeful EPC may have been an
option after looking at the release notes I previously referenced.

Using a ME3600X for MPLS to the edge a layer 2 handoff may look
something like the following

interface GigabitEthernet0/1
description Customer A
switchport mode trunk
mtu 9216
load-interval 30
no cdp enable
service instance 666 ethernet
encapsulation dot1q 666
rewrite ingress tag pop 1 symmetric
xconnect 1.2.3.4 666 encapsulation mpls

With a switched access there would be similar config as the above on the
PE but a switch (ACCESS) with vlan 666 between the PE and the customer.
Checking what mac addresses are seen from the customer is as easy as
"show mac address-table dynamic vlan 666" or "show mac address-table
dynamic interface GigabitEthernet 0/1"

With MPLS to the edge it is great the provider doesn't have to worry
about keeping mac address tables etc - much more scalable, but it would
be handy if there was an easy way to "peek" to help with
troubleshooting, as it generally indicates if the problem lies with the
customer or provider.

Thanks

Ivan

On 11/Aug/2012 3:53 a.m., Waris Sagheer (waris) wrote:
> Hi Ivan,
> How do you want to verify the mac address? Can you send me configuration example on access layer switch?
> Also, what is the current configuration on ME3600X?
>
> Regards,
> Waris
>
>
> -----Original Message-----
> From: Ivan [mailto:cisco-nsp [at] itpro]
> Sent: Friday, August 10, 2012 3:27 AM
> To: Waris Sagheer (waris)
> Cc: cisco-nsp [at] puck
> Subject: Re: [c-nsp] ME3600X Embedded Packet Capture
>
> Hi Waris,
>
> I had come across that bug referring to EPC in "Release Notes for the Cisco ME 3800X and ME 3600X Switch" - http://www.cisco.com/en/US/docs/switches/metro/me3600x_3800x/software/release/15.1_2_ey/release/notes/ol25360.html
> and had hoped that the feature was available. I wasn't able to find any other documentation thus my question to the list.
>
> What I am really looking for is a possible way to verify any seen mac addresses on a customer EVC xconnect when running MPLS to the edge for troubleshooting. This was quite easy and useful with a switched access layer. I don't really want to xconnect on vlans and bridge to EVCs (not sure that is possible on the ME3600X platform)
>
> Thanks
>
> Ivan
>
> On 10/Aug/2012 8:09 p.m., Waris Sagheer (waris) wrote:
>> Ivan,
>> Which packet capture you are referring to on ME3600X?
>> There is no support of embedded packet capture on ME3600X.
>>
>> Regards,
>> Waris
>>
>>
>> -----Original Message-----
>> From: cisco-nsp-bounces [at] puck
>> [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ivan
>> Sent: Thursday, August 09, 2012 10:35 PM
>> To: cisco-nsp [at] puck
>> Subject: [c-nsp] ME3600X Embedded Packet Capture
>>
>> Hi,
>>
>> Has anyone used Embedded Packet Capture on the ME3600X successfully? If so are their any gotchas to be weary of?
>>
>> The only things that come up when I search for this is CSCtq11526 Embedded Packet Capture stops BFD neighbor adjacency, but have been unable to find details of what packets can be captured - hardware v cpu etc. Any documentation pointers would be appreciated.
>>
>> Thanks
>>
>> Ivan
>>
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp [at] puck
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


pshem.k at gmail

Aug 12, 2012, 1:17 PM

Post #6 of 11 (1487 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi,


On 11 August 2012 10:32, Ivan <cisco-nsp [at] itpro> wrote:

{cut}

> xconnect 1.2.3.4 666 encapsulation mpls

Speaking from general experience - this is the culprit. In
point-to-point L2VPNs there is (usually, I admit I'm not sure if
that's the case on 3600x) no MAC address learning (which nicely
conserves the resources on the switch). If you really need to see that
address - you should turn that into a point-to-point VPLS.

kind regards
Pshem
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cisco-nsp at itpro

Aug 12, 2012, 7:17 PM

Post #7 of 11 (1475 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi,

Yes, as far as I understand there is no mac learning which is great for
resource utilisation and scalability. No requirement other than "it is
helpful for troubleshooting" to see any macs.

Cheers

Ivan

> Hi,
>
>
> On 11 August 2012 10:32, Ivan <cisco-nsp [at] itpro> wrote:
>
> {cut}
>
>> xconnect 1.2.3.4 666 encapsulation mpls
>
> Speaking from general experience - this is the culprit. In
> point-to-point L2VPNs there is (usually, I admit I'm not sure if
> that's the case on 3600x) no MAC address learning (which nicely
> conserves the resources on the switch). If you really need to see that
> address - you should turn that into a point-to-point VPLS.
>
> kind regards
> Pshem
>


_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


waris at cisco

Aug 13, 2012, 12:47 AM

Post #8 of 11 (1476 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi Ivan,
You can use the following EVPL configuration which would allow you to see the mac addresses e.g. in the following example you can see the mac addresses under bridge-domain 10.

interface GigabitEthernet0/1
switchport trunk allowed vlan none
switchport mode trunk
service instance 10 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 10

interface Vlan10
no ip address
xconnect 2.2.2.2 10 encapsulation mpls


Regards,
Waris


-----Original Message-----
From: Ivan [mailto:cisco-nsp [at] itpro]
Sent: Sunday, August 12, 2012 7:17 PM
To: Pshem Kowalczyk
Cc: Ivan; Waris Sagheer (waris); cisco-nsp [at] puck
Subject: Re: [c-nsp] ME3600X Embedded Packet Capture

Hi,

Yes, as far as I understand there is no mac learning which is great for resource utilisation and scalability. No requirement other than "it is helpful for troubleshooting" to see any macs.

Cheers

Ivan

> Hi,
>
>
> On 11 August 2012 10:32, Ivan <cisco-nsp [at] itpro> wrote:
>
> {cut}
>
>> xconnect 1.2.3.4 666 encapsulation mpls
>
> Speaking from general experience - this is the culprit. In
> point-to-point L2VPNs there is (usually, I admit I'm not sure if
> that's the case on 3600x) no MAC address learning (which nicely
> conserves the resources on the switch). If you really need to see that
> address - you should turn that into a point-to-point VPLS.
>
> kind regards
> Pshem
>



_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cisco-nsp at itpro

Aug 13, 2012, 2:18 AM

Post #9 of 11 (1469 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hi Waris,

Thanks, I hadn't tested the bridging mode yet on this platform but have
used on the ES+ linecards. Wouldn't be looking to use all the time as I
like the per port vlan scope when doing the xconnect on the evc.
Reconfiguring to bridging method for troubleshooting purposes seems to
be the only option for checking mac address.

Cheers

Ivan

On 13/Aug/2012 7:47 p.m., Waris Sagheer (waris) wrote:
> Hi Ivan,
> You can use the following EVPL configuration which would allow you to see the mac addresses e.g. in the following example you can see the mac addresses under bridge-domain 10.
>
> interface GigabitEthernet0/1
> switchport trunk allowed vlan none
> switchport mode trunk
> service instance 10 ethernet
> encapsulation dot1q 100
> rewrite ingress tag pop 1 symmetric
> bridge-domain 10
>
> interface Vlan10
> no ip address
> xconnect 2.2.2.2 10 encapsulation mpls
>
>
> Regards,
> Waris
>
>
> -----Original Message-----
> From: Ivan [mailto:cisco-nsp [at] itpro]
> Sent: Sunday, August 12, 2012 7:17 PM
> To: Pshem Kowalczyk
> Cc: Ivan; Waris Sagheer (waris); cisco-nsp [at] puck
> Subject: Re: [c-nsp] ME3600X Embedded Packet Capture
>
> Hi,
>
> Yes, as far as I understand there is no mac learning which is great for resource utilisation and scalability. No requirement other than "it is helpful for troubleshooting" to see any macs.
>
> Cheers
>
> Ivan
>
>> Hi,
>>
>>
>> On 11 August 2012 10:32, Ivan <cisco-nsp [at] itpro> wrote:
>>
>> {cut}
>>
>>> xconnect 1.2.3.4 666 encapsulation mpls
>> Speaking from general experience - this is the culprit. In
>> point-to-point L2VPNs there is (usually, I admit I'm not sure if
>> that's the case on 3600x) no MAC address learning (which nicely
>> conserves the resources on the switch). If you really need to see that
>> address - you should turn that into a point-to-point VPLS.
>>
>> kind regards
>> Pshem
>>
>

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


adam.vitkovsky at swan

Aug 13, 2012, 3:48 AM

Post #10 of 11 (1478 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Ivan,
Now as you switched to MPLS to the access layer approach and literally
creating p2p wires between two customer devices
Customers should understand they cannot involve you with mac learning issues
between two datacenters

Or you could consider managed services and start deploying ISP managed CE
devices as a value added service addition to the p2p wire


adam
-----Original Message-----
From: cisco-nsp-bounces [at] puck
[mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ivan
Sent: Monday, August 13, 2012 11:19 AM
To: Waris Sagheer (waris)
Cc: cisco-nsp [at] puck
Subject: Re: [c-nsp] ME3600X Embedded Packet Capture

Hi Waris,

Thanks, I hadn't tested the bridging mode yet on this platform but have used
on the ES+ linecards. Wouldn't be looking to use all the time as I like the
per port vlan scope when doing the xconnect on the evc.
Reconfiguring to bridging method for troubleshooting purposes seems to be
the only option for checking mac address.

Cheers

Ivan

On 13/Aug/2012 7:47 p.m., Waris Sagheer (waris) wrote:
> Hi Ivan,
> You can use the following EVPL configuration which would allow you to see
the mac addresses e.g. in the following example you can see the mac
addresses under bridge-domain 10.
>
> interface GigabitEthernet0/1
> switchport trunk allowed vlan none
> switchport mode trunk
> service instance 10 ethernet
> encapsulation dot1q 100
> rewrite ingress tag pop 1 symmetric
> bridge-domain 10
>
> interface Vlan10
> no ip address
> xconnect 2.2.2.2 10 encapsulation mpls
>
>
> Regards,
> Waris
>
>
> -----Original Message-----
> From: Ivan [mailto:cisco-nsp [at] itpro]
> Sent: Sunday, August 12, 2012 7:17 PM
> To: Pshem Kowalczyk
> Cc: Ivan; Waris Sagheer (waris); cisco-nsp [at] puck
> Subject: Re: [c-nsp] ME3600X Embedded Packet Capture
>
> Hi,
>
> Yes, as far as I understand there is no mac learning which is great for
resource utilisation and scalability. No requirement other than "it is
helpful for troubleshooting" to see any macs.
>
> Cheers
>
> Ivan
>
>> Hi,
>>
>>
>> On 11 August 2012 10:32, Ivan <cisco-nsp [at] itpro> wrote:
>>
>> {cut}
>>
>>> xconnect 1.2.3.4 666 encapsulation mpls
>> Speaking from general experience - this is the culprit. In
>> point-to-point L2VPNs there is (usually, I admit I'm not sure if
>> that's the case on 3600x) no MAC address learning (which nicely
>> conserves the resources on the switch). If you really need to see
>> that address - you should turn that into a point-to-point VPLS.
>>
>> kind regards
>> Pshem
>>
>

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


christian at errxtx

Aug 13, 2012, 12:54 PM

Post #11 of 11 (1450 views)
Permalink
Re: ME3600X Embedded Packet Capture [In reply to]

Hey,

> Now as you switched to MPLS to the access layer approach and literally
> creating p2p wires between two customer devices Customers should
> understand they cannot involve you with mac learning issues between two
> datacenters

Well, you must keep in mind that many setups require local-tail carriers, but
you are the one having the contract with the client. In such case all you can
do is checking for mac or start to involve the local tail.

Christian
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Cisco nsp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.