Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NSP

Gigabit link between 2960S and 4948 won't come up

 

 

Cisco nsp RSS feed   Index | Next | Previous | View Threaded


cnspmail002 at googlemail

Jun 13, 2012, 3:41 AM

Post #1 of 6 (1976 views)
Permalink
Gigabit link between 2960S and 4948 won't come up

Dear List,

i am having a somewhat (in my opinion) odd issue.

We have an Cisco 4948 acting as our core switch running Cisco IOS Software,
Catalyst 4500 L3 Switch Software (cat4500-ENTSERVICESK9-M), Version
12.2(54)SG

We recently purchased a WS-C2960S-48LPS-L running Cisco IOS Software,
C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(58)SE2

I am having a hard time to bring the Link up at 1 Gbit Speed between these
two devices. The Link will only come up if configure the speed to 100Mbit
and duplex to full on both sides.
My first guess was a bad (copper) cable, so i tried it with 5 different
cables but no luck. In the next step i tested it with different ports on
both side, but still no luck.

Interestingly, if i use the same cables and connect the 2960S to an 3750G
running 12.2(55) SE4 the link comes up just fine with 1Gbit (using the same
ports). Also, if i connect the 4948 to the 3750G the link comes up fine at
1Gbit.

My Laptop also negotiates just fine to 1Gbit on the 4948 and 2960S (with
the same cables).

I am kind of lost as i am running out of ideas what could cause this
behavior.

Has someone run into this problem? Do you have any ideas what could cause
this issue, or what else i could be testing?

I appreciate every input and thanks in advance. If you need any additional
info, please don't hesitate to ask.

Below is the output of the interface configuration and what "show int" says.

Kind regards,
Peter


The Port configuration looks like the following:

C2960S:

interface GigabitEthernet1/0/47
description ===XXX===
switchport trunk allowed vlan 500-502,532
switchport mode trunk
switchport nonegotiate
load-interval 30
speed 100
duplex full

4948:
interface GigabitEthernet1/47
description ===XXX===
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 500-502,532
switchport mode trunk
switchport nonegotiate
media-type rj45
speed 100
duplex full


Show interface brings up the following:

4948:

GigabitEthernet1/47 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet Port, address is 0018.18b7.ee2e (bia
0018.18b7.ee2e)
Description: ===XXX===
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 4/255, rxload 4/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX
Media-type configured as RJ45 connector
input flow-control is off, output flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input 19:23:29, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1891000 bits/sec, 311 packets/sec
5 minute output rate 1959000 bits/sec, 339 packets/sec
204875190 packets input, 65988069530 bytes, 0 no buffer
Received 325083 broadcasts (147424 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
292744855 packets output, 333704421693 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cisco 2960S:

GigabitEthernet1/0/47 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is a456.30e3.d0af (bia
a456.30e3.d0af)
Description: ===XXX===
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 2/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 19:23:51, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3709
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 796000 bits/sec, 108 packets/sec
30 second output rate 187000 bits/sec, 132 packets/sec
23172539 packets input, 20875225690 bytes, 0 no buffer
Received 156759 broadcasts (156578 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 156578 multicast, 0 pause input
0 input packets with dribble condition detected
19788925 packets output, 7529119002 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cnspmail002 at googlemail

Jun 13, 2012, 3:59 AM

Post #2 of 6 (1896 views)
Permalink
Re: Gigabit link between 2960S and 4948 won't come up [In reply to]

Hi James,

thanks for the (quick) reply.

Honestly, no i haven't checked auto MDIX settings, but will do, thanks for
the pointer.

I tried it with an crossover cable, but no luck.

Kind regards,
Peter

On Wed, Jun 13, 2012 at 12:49 PM, James Bensley <jwbensley [at] gmail> wrote:

> Hi Peter,
>
> Have you checked auto MDIX settings and also a cross over?
>
> Just my two pence.
> James.
>
> On 13 June 2012 11:41, Peter Subnovic <cnspmail002 [at] googlemail> wrote:
> > Dear List,
> >
> > i am having a somewhat (in my opinion) odd issue.
> >
> > We have an Cisco 4948 acting as our core switch running Cisco IOS
> Software,
> > Catalyst 4500 L3 Switch Software (cat4500-ENTSERVICESK9-M), Version
> > 12.2(54)SG
> >
> > We recently purchased a WS-C2960S-48LPS-L running Cisco IOS Software,
> > C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(58)SE2
> >
> > I am having a hard time to bring the Link up at 1 Gbit Speed between
> these
> > two devices. The Link will only come up if configure the speed to 100Mbit
> > and duplex to full on both sides.
> > My first guess was a bad (copper) cable, so i tried it with 5 different
> > cables but no luck. In the next step i tested it with different ports on
> > both side, but still no luck.
> >
> > Interestingly, if i use the same cables and connect the 2960S to an
> 3750G
> > running 12.2(55) SE4 the link comes up just fine with 1Gbit (using the
> same
> > ports). Also, if i connect the 4948 to the 3750G the link comes up fine
> at
> > 1Gbit.
> >
> > My Laptop also negotiates just fine to 1Gbit on the 4948 and 2960S (with
> > the same cables).
> >
> > I am kind of lost as i am running out of ideas what could cause this
> > behavior.
> >
> > Has someone run into this problem? Do you have any ideas what could cause
> > this issue, or what else i could be testing?
> >
> > I appreciate every input and thanks in advance. If you need any
> additional
> > info, please don't hesitate to ask.
> >
> > Below is the output of the interface configuration and what "show int"
> says.
> >
> > Kind regards,
> > Peter
> >
> >
> > The Port configuration looks like the following:
> >
> > C2960S:
> >
> > interface GigabitEthernet1/0/47
> > description ===XXX===
> > switchport trunk allowed vlan 500-502,532
> > switchport mode trunk
> > switchport nonegotiate
> > load-interval 30
> > speed 100
> > duplex full
> >
> > 4948:
> > interface GigabitEthernet1/47
> > description ===XXX===
> > switchport trunk encapsulation dot1q
> > switchport trunk allowed vlan 500-502,532
> > switchport mode trunk
> > switchport nonegotiate
> > media-type rj45
> > speed 100
> > duplex full
> >
> >
> > Show interface brings up the following:
> >
> > 4948:
> >
> > GigabitEthernet1/47 is up, line protocol is up (connected)
> > Hardware is Gigabit Ethernet Port, address is 0018.18b7.ee2e (bia
> > 0018.18b7.ee2e)
> > Description: ===XXX===
> > MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> > reliability 255/255, txload 4/255, rxload 4/255
> > Encapsulation ARPA, loopback not set
> > Keepalive set (10 sec)
> > Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX
> > Media-type configured as RJ45 connector
> > input flow-control is off, output flow-control is off
> > ARP type: ARPA, ARP Timeout 04:00:00
> > Last input 19:23:29, output never, output hang never
> > Last clearing of "show interface" counters never
> > Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
> > Queueing strategy: fifo
> > Output queue: 0/40 (size/max)
> > 5 minute input rate 1891000 bits/sec, 311 packets/sec
> > 5 minute output rate 1959000 bits/sec, 339 packets/sec
> > 204875190 packets input, 65988069530 bytes, 0 no buffer
> > Received 325083 broadcasts (147424 multicasts)
> > 0 runts, 0 giants, 0 throttles
> > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
> > 0 input packets with dribble condition detected
> > 292744855 packets output, 333704421693 bytes, 0 underruns
> > 0 output errors, 0 collisions, 0 interface resets
> > 0 babbles, 0 late collision, 0 deferred
> > 0 lost carrier, 0 no carrier
> > 0 output buffer failures, 0 output buffers swapped out
> >
> > Cisco 2960S:
> >
> > GigabitEthernet1/0/47 is up, line protocol is up (connected)
> > Hardware is Gigabit Ethernet, address is a456.30e3.d0af (bia
> > a456.30e3.d0af)
> > Description: ===XXX===
> > MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
> > reliability 255/255, txload 1/255, rxload 2/255
> > Encapsulation ARPA, loopback not set
> > Keepalive set (10 sec)
> > Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
> > input flow-control is off, output flow-control is unsupported
> > ARP type: ARPA, ARP Timeout 04:00:00
> > Last input 00:00:00, output 19:23:51, output hang never
> > Last clearing of "show interface" counters never
> > Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3709
> > Queueing strategy: fifo
> > Output queue: 0/40 (size/max)
> > 30 second input rate 796000 bits/sec, 108 packets/sec
> > 30 second output rate 187000 bits/sec, 132 packets/sec
> > 23172539 packets input, 20875225690 bytes, 0 no buffer
> > Received 156759 broadcasts (156578 multicasts)
> > 0 runts, 0 giants, 0 throttles
> > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
> > 0 watchdog, 156578 multicast, 0 pause input
> > 0 input packets with dribble condition detected
> > 19788925 packets output, 7529119002 bytes, 0 underruns
> > 0 output errors, 0 collisions, 1 interface resets
> > 0 unknown protocol drops
> > 0 babbles, 0 late collision, 0 deferred
> > 0 lost carrier, 0 no carrier, 0 pause output
> > 0 output buffer failures, 0 output buffers swapped out
> > _______________________________________________
> > cisco-nsp mailing list cisco-nsp [at] puck
> > https://puck.nether.net/mailman/listinfo/cisco-nsp
> > archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


lists at carels

Jun 13, 2012, 4:06 AM

Post #3 of 6 (1889 views)
Permalink
Re: Gigabit link between 2960S and 4948 won't come up [In reply to]

On 13 Jun 2012, at 12:59 , Peter Subnovic wrote:

> Hi James,
>
> thanks for the (quick) reply.
>
> Honestly, no i haven't checked auto MDIX settings, but will do, thanks for
> the pointer.
>
> I tried it with an crossover cable, but no luck.

Used the right crossover cable? I've seen them with only 12/36 crossed and 45/78 not connected. You may need the 12/36 crossed 45/78 straight connected variety.

--maarten
Attachments: signature.asc (0.48 KB)


cnspmail002 at googlemail

Jun 13, 2012, 4:49 AM

Post #4 of 6 (1896 views)
Permalink
Re: Gigabit link between 2960S and 4948 won't come up [In reply to]

Hi,

as a follow-up:

On the 2960S Side auto MDIX seems to be off:

2960#show controllers ethernet-controller gigabitEthernet 1/0/47 phy detail
| include MDIX
Auto-MDIX : Off [AdminState=1 Flags=0]

On the 4948 it should be on:

According to:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/46sg/configuration/guide/sw_int.html#wp1071819

Auto-MDIX is enabled per default, but i couldn't find any information in
the "show int" output, which is the suggested way in the document to verify
the Auto-MDIX state.

When i am not mistaken, it must be on on the 4948 otherwise the link
shouldn't come up at all when i use a straight cable.

What makes me a little curious is that, in order for auto-MDIX to work
correctly, the speed and duplex must be set to auto, which is not the case
in my configuration.

But even if it doesn't work correctly the link shouldn't come up with the
straight cable, or am i understand something wrong?

Thanks in advance,

Kind regards,
Peter




On Wed, Jun 13, 2012 at 12:59 PM, Peter Subnovic <cnspmail002 [at] googlemail
> wrote:

> Hi James,
>
> thanks for the (quick) reply.
>
> Honestly, no i haven't checked auto MDIX settings, but will do, thanks for
> the pointer.
>
> I tried it with an crossover cable, but no luck.
>
> Kind regards,
> Peter
>
>
> On Wed, Jun 13, 2012 at 12:49 PM, James Bensley <jwbensley [at] gmail>wrote:
>
>> Hi Peter,
>>
>> Have you checked auto MDIX settings and also a cross over?
>>
>> Just my two pence.
>> James.
>>
>> On 13 June 2012 11:41, Peter Subnovic <cnspmail002 [at] googlemail> wrote:
>> > Dear List,
>> >
>> > i am having a somewhat (in my opinion) odd issue.
>> >
>> > We have an Cisco 4948 acting as our core switch running Cisco IOS
>> Software,
>> > Catalyst 4500 L3 Switch Software (cat4500-ENTSERVICESK9-M), Version
>> > 12.2(54)SG
>> >
>> > We recently purchased a WS-C2960S-48LPS-L running Cisco IOS Software,
>> > C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(58)SE2
>> >
>> > I am having a hard time to bring the Link up at 1 Gbit Speed between
>> these
>> > two devices. The Link will only come up if configure the speed to
>> 100Mbit
>> > and duplex to full on both sides.
>> > My first guess was a bad (copper) cable, so i tried it with 5 different
>> > cables but no luck. In the next step i tested it with different ports on
>> > both side, but still no luck.
>> >
>> > Interestingly, if i use the same cables and connect the 2960S to an
>> 3750G
>> > running 12.2(55) SE4 the link comes up just fine with 1Gbit (using the
>> same
>> > ports). Also, if i connect the 4948 to the 3750G the link comes up fine
>> at
>> > 1Gbit.
>> >
>> > My Laptop also negotiates just fine to 1Gbit on the 4948 and 2960S (with
>> > the same cables).
>> >
>> > I am kind of lost as i am running out of ideas what could cause this
>> > behavior.
>> >
>> > Has someone run into this problem? Do you have any ideas what could
>> cause
>> > this issue, or what else i could be testing?
>> >
>> > I appreciate every input and thanks in advance. If you need any
>> additional
>> > info, please don't hesitate to ask.
>> >
>> > Below is the output of the interface configuration and what "show int"
>> says.
>> >
>> > Kind regards,
>> > Peter
>> >
>> >
>> > The Port configuration looks like the following:
>> >
>> > C2960S:
>> >
>> > interface GigabitEthernet1/0/47
>> > description ===XXX===
>> > switchport trunk allowed vlan 500-502,532
>> > switchport mode trunk
>> > switchport nonegotiate
>> > load-interval 30
>> > speed 100
>> > duplex full
>> >
>> > 4948:
>> > interface GigabitEthernet1/47
>> > description ===XXX===
>> > switchport trunk encapsulation dot1q
>> > switchport trunk allowed vlan 500-502,532
>> > switchport mode trunk
>> > switchport nonegotiate
>> > media-type rj45
>> > speed 100
>> > duplex full
>> >
>> >
>> > Show interface brings up the following:
>> >
>> > 4948:
>> >
>> > GigabitEthernet1/47 is up, line protocol is up (connected)
>> > Hardware is Gigabit Ethernet Port, address is 0018.18b7.ee2e (bia
>> > 0018.18b7.ee2e)
>> > Description: ===XXX===
>> > MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
>> > reliability 255/255, txload 4/255, rxload 4/255
>> > Encapsulation ARPA, loopback not set
>> > Keepalive set (10 sec)
>> > Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX
>> > Media-type configured as RJ45 connector
>> > input flow-control is off, output flow-control is off
>> > ARP type: ARPA, ARP Timeout 04:00:00
>> > Last input 19:23:29, output never, output hang never
>> > Last clearing of "show interface" counters never
>> > Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
>> > Queueing strategy: fifo
>> > Output queue: 0/40 (size/max)
>> > 5 minute input rate 1891000 bits/sec, 311 packets/sec
>> > 5 minute output rate 1959000 bits/sec, 339 packets/sec
>> > 204875190 packets input, 65988069530 bytes, 0 no buffer
>> > Received 325083 broadcasts (147424 multicasts)
>> > 0 runts, 0 giants, 0 throttles
>> > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
>> > 0 input packets with dribble condition detected
>> > 292744855 packets output, 333704421693 bytes, 0 underruns
>> > 0 output errors, 0 collisions, 0 interface resets
>> > 0 babbles, 0 late collision, 0 deferred
>> > 0 lost carrier, 0 no carrier
>> > 0 output buffer failures, 0 output buffers swapped out
>> >
>> > Cisco 2960S:
>> >
>> > GigabitEthernet1/0/47 is up, line protocol is up (connected)
>> > Hardware is Gigabit Ethernet, address is a456.30e3.d0af (bia
>> > a456.30e3.d0af)
>> > Description: ===XXX===
>> > MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
>> > reliability 255/255, txload 1/255, rxload 2/255
>> > Encapsulation ARPA, loopback not set
>> > Keepalive set (10 sec)
>> > Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
>> > input flow-control is off, output flow-control is unsupported
>> > ARP type: ARPA, ARP Timeout 04:00:00
>> > Last input 00:00:00, output 19:23:51, output hang never
>> > Last clearing of "show interface" counters never
>> > Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
>> 3709
>> > Queueing strategy: fifo
>> > Output queue: 0/40 (size/max)
>> > 30 second input rate 796000 bits/sec, 108 packets/sec
>> > 30 second output rate 187000 bits/sec, 132 packets/sec
>> > 23172539 packets input, 20875225690 bytes, 0 no buffer
>> > Received 156759 broadcasts (156578 multicasts)
>> > 0 runts, 0 giants, 0 throttles
>> > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
>> > 0 watchdog, 156578 multicast, 0 pause input
>> > 0 input packets with dribble condition detected
>> > 19788925 packets output, 7529119002 bytes, 0 underruns
>> > 0 output errors, 0 collisions, 1 interface resets
>> > 0 unknown protocol drops
>> > 0 babbles, 0 late collision, 0 deferred
>> > 0 lost carrier, 0 no carrier, 0 pause output
>> > 0 output buffer failures, 0 output buffers swapped out
>> > _______________________________________________
>> > cisco-nsp mailing list cisco-nsp [at] puck
>> > https://puck.nether.net/mailman/listinfo/cisco-nsp
>> > archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
>
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


gert at greenie

Jun 13, 2012, 5:10 AM

Post #5 of 6 (1885 views)
Permalink
Re: Gigabit link between 2960S and 4948 won't come up [In reply to]

Hi,

On Wed, Jun 13, 2012 at 01:06:51PM +0200, Maarten Carels wrote:
> Used the right crossover cable? I've seen them with only 12/36 crossed and 45/78 not connected. You may need the 12/36 crossed 45/78 straight connected variety.

GigE-on-copper works perfectly fine with no crossing at all. Depending
on the transceivers in question, "crossing some pairs and not others"
might actually confuse their logic that determines cable layout.

gert
--
USENET is *not* the non-clickable part of WWW!
//www.muc.de/~gert/
Gert Doering - Munich, Germany gert [at] greenie
fax: +49-89-35655025 gert [at] net


lists at carels

Jun 13, 2012, 6:53 AM

Post #6 of 6 (1890 views)
Permalink
Re: Gigabit link between 2960S and 4948 won't come up [In reply to]

On 13 Jun 2012, at 14:10 , Gert Doering wrote:

> Hi,
>
> On Wed, Jun 13, 2012 at 01:06:51PM +0200, Maarten Carels wrote:
>> Used the right crossover cable? I've seen them with only 12/36 crossed and 45/78 not connected. You may need the 12/36 crossed 45/78 straight connected variety.
>
> GigE-on-copper works perfectly fine with no crossing at all. Depending
> on the transceivers in question, "crossing some pairs and not others"
> might actually confuse their logic that determines cable layout.

Long time ago I connected a small cisco switch (2940 or so) to a chassis based access switch (4500 with gig-E blades).

It insisted on having the right crosscable (12/36 crossed, 45/78 straight) between them...

Usually not crossing works fine, but sometimes... And beware of 100Mb crosscables that cross 12/36 and leave the rest unconnected.

--maarten
Attachments: signature.asc (0.48 KB)

Cisco nsp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.